
Femap Readme
Simcenter Femap 2412 Series



Unpublished work. © 2024 Siemens

This Documentation contains trade secrets or otherwise confidential information owned by Siemens Industry Software Inc. or
its affiliates (collectively, “Siemens”), or its licensors. Access to and use of this Documentation is strictly limited as set forth in
Customer’s applicable agreement(s) with Siemens. This Documentation may not be copied, distributed, or otherwise disclosed
by Customer without the express written permission of Siemens, and may not be used in any way not expressly authorized by
Siemens.

This Documentation is for information and instruction purposes. Siemens reserves the right to make changes in specifications
and other information contained in this Documentation without prior notice, and the reader should, in all cases, consult
Siemens to determine whether any changes have been made.

No representation or other affirmation of fact contained in this Documentation shall be deemed to be a warranty or give rise to
any liability of Siemens whatsoever.

If you have a signed license agreement with Siemens for the product with which this Documentation will be used, your use of
this Documentation is subject to the scope of license and the software protection and security provisions of that agreement.
If you do not have such a signed license agreement, your use is subject to the Siemens Universal Customer Agreement, which
may be viewed at https://www.sw.siemens.com/en-US/sw-terms/base/uca/, as supplemented by the product specific terms
which may be viewed at https://www.sw.siemens.com/en-US/sw-terms/supplements/.

SIEMENS MAKES NO WARRANTY OF ANY KIND WITH REGARD TO THIS DOCUMENTATION INCLUDING, BUT NOT LIMITED
TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, AND NON-INFRINGEMENT OF
INTELLECTUAL PROPERTY. SIEMENS SHALL NOT BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, CONSEQUENTIAL OR
PUNITIVE DAMAGES, LOST DATA OR PROFITS, EVEN IF SUCH DAMAGES WERE FORESEEABLE, ARISING OUT OF OR RELATED
TO THIS DOCUMENTATION OR THE INFORMATION CONTAINED IN IT, EVEN IF SIEMENS HAS BEEN ADVISED OF THE POSSIBILITY
OF SUCH DAMAGES.

TRADEMARKS: The trademarks, logos, and service marks (collectively, "Marks") used herein are the property of Siemens or other
parties. No one is permitted to use these Marks without the prior written consent of Siemens or the owner of the Marks,
as applicable. The use herein of third party Marks is not an attempt to indicate Siemens as a source of a product, but is
intended to indicate a product from, or associated with, a particular third party. A list of Siemens’ Marks may be viewed at:
www.plm.automation.siemens.com/global/en/legal/trademarks.html. The registered trademark Linux® is used pursuant to a
sublicense from LMI, the exclusive licensee of Linus Torvalds, owner of the mark on a world-wide basis.

About Siemens Digital Industries Software

Siemens Digital Industries Software is a global leader in the growing field of product lifecycle management (PLM),
manufacturing operations management (MOM), and electronic design automation (EDA) software, hardware, and services.
Siemens works with more than 100,000 customers, leading the digitalization of their planning and manufacturing processes. At
Siemens Digital Industries Software, we blur the boundaries between industry domains by integrating the virtual and physical,
hardware and software, design and manufacturing worlds. With the rapid pace of innovation, digitalization is no longer
tomorrow’s idea. We take what the future promises tomorrow and make it real for our customers today. Where today meets
tomorrow. Our culture encourages creativity, welcomes fresh thinking and focuses on growth, so our people, our business, and
our customers can achieve their full potential.

Support Center: support.sw.siemens.com

Send Feedback on Documentation: support.sw.siemens.com/doc_feedback_form

https://www.sw.siemens.com/en-US/sw-terms/base/uca/
https://www.sw.siemens.com/en-US/sw-terms/supplements/
http://www.plm.automation.siemens.com/global/en/legal/trademarks.html
https://support.sw.siemens.com
https://support.sw.siemens.com/doc_feedback_form


Contents

Welcome to the Femap Readme
Femap v2412 ──────────────────────────── 1-1
Femap v2406.0001 ────────────────────────── 1-8
Femap v2406 ──────────────────────────── 1-12
Femap v2401.0002 ───────────────────────── 1-20
Femap v2401.0001 ───────────────────────── 1-23
Femap v2401 ──────────────────────────── 1-27
Femap v2306.0003 ───────────────────────── 1-40
Femap v2306.0002 ───────────────────────── 1-42
Femap v2306.0001 ───────────────────────── 1-43
Femap v2306 ──────────────────────────── 1-47
Femap v2301.0004 ───────────────────────── 1-54
Femap v2301.0003 ───────────────────────── 1-55
Femap v2301.0002 ───────────────────────── 1-57
Femap v2301 MP1 ───────────────────────── 1-59
Femap v2301 ──────────────────────────── 1-62
Femap v2022.2 MP 4 ──────────────────────── 1-80
Femap v2022.2 MP 3 ──────────────────────── 1-80
Femap v2022.2 MP 2 ──────────────────────── 1-83
Femap v2022.2 MP 1 ──────────────────────── 1-86
Femap v2022.2 ─────────────────────────── 1-88
Femap v2022.1 MP 2 ──────────────────────── 1-96
Femap v2022.1 MP 1 ──────────────────────── 1-96
Femap v2022.1 ─────────────────────────── 1-99
Femap v2021.2 MP 2 ──────────────────────── 1-111
Femap v2021.2 MP 1 ──────────────────────── 1-113
Femap v2021.2 ────────────────────────── 1-114

Femap Readme, Simcenter Femap 2412 Series  3
© 2024 Siemens



4  Femap Readme, Simcenter Femap 2412 Series
© 2024 Siemens



1. Welcome to the Femap Readme
Welcome to the Femap Readme. In this guide, you will find detailed information about the changes,
enhancements, and corrections made to Femap for the following releases:

• Femap v2412

• Femap v2406.0001

• Femap v2406

• Femap v2401.0002

• Femap v2401.0001

• Femap v2401

• Femap v2306.0003

• Femap v2306.0002

• Femap v2306.0001

• Femap v2306

• Femap v2301 MP1.0004

• Femap v2301 MP1.0003

• Femap v2301 MP1.0002

• Femap v2301 MP1

• Femap v2301

• Femap v2022.2 MP4

• Femap v2022.2 MP3

• Femap v2022.2 MP2

• Femap v2022.2 MP1

• Femap v2022.2

• Femap v2022.1 MP2

• Femap v2022.1 MP1

• Femap v2022.1

• Femap v2021.2 MP2

• Femap v2021.2 MP1

• Femap v2021.2

Note:

For versions of Femap prior to version 2021.2, refer to the Femap document
readme_Pre2021-2.pdf

Femap v2412

Updates and Enhancements

Teamcenter Integration

Teamcenter Open

• Added ability to reset column visibility and column order in the Teamcenter Open dialog box.

• Added the Filter option for filtering results in the Teamcenter Open dialog box.

• Added support for opening files from Teamcenter by double clicking on the row in the report
control table.

Teamcenter Save
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• Added ability to reset column visibility and column order like in the Teamcenter Open dialog
box.

• Added the Filter and Add buttons for filtering results and adding associated files to the
Teamcenter Save dialog box.

• Added the Add Associated Files button to open a new Manage Associated Files dialog box
providing a hierarchical view with check-boxes to include or remove associated files and each
of their children.

• Added support for saving files from Teamcenter by double clicking on the row in the report
control table.

Teamcenter Import Geometry

• Added ability to import different geometry file formats from Teamcenter into Femap. Added
the Teamcenter Import Geometry dialog box (PDM → Teamcenter → Import → Geometry).

Note:

For NX geometry files, only NX parts can be imported directly from Teamcenter. For
importing NX assemblies from Teamcenter, please use the Teamcenter utility or NX
application to download the entire assembly locally.

• Moved the Import Shattered JT functionality into the larger Import Geometry functionality
driven by the XML file as the input.

Note:

To continue importing geometry using Shattered JT Assembly, choose of object of type
“BOMView Revision”. This method of geometry import uses BOM-view to get info about
the part/sub-assembly objects. From these objects, the JT files of each components are
downloaded & assembled as per the transformations mentioned in BOMView.

• Added support for import of all geometry types by processing them based on the matched
dataset-file filter.

• Added ability to assign a default Revision Rule using the Teamcenter preference
TC_config_rule_name. Teamcenter allows changing of the default Revision Rule in the
Structure Manager application for BOM expansion using TC_config_rule_name. Femap's
Teamcenter Import Geometry dialog box, the default Revision Rule is applied when the Search
button is clicked.

Teamcenter Import Analysis Model/Results

• Added the ability to manage the Simulation Files In Teamcenter. When saving a file to
Teamcenter, Femap creates datasets for each individual Analysis Set and uploads the files to
Teamcenter. Information about the managed files is retained and if there are changes made
to the managed files, a prompt dialog box appears.
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• Added Teamcenter Import Analysis Model dialog box to the user interface (PDM →
Teamcenter → Import → Analysis Model).

• Added Teamcenter Import Analysis Results dialog box to the user interface (PDM →
Teamcenter → Import → Analysis Results).

Graphics - Maximum Refresh Rate Preference

• Femap is capable of drawing some models so fast, it can make dynamic rotation appear jittery
– that is, if you draw faster than the refresh rate on your monitor. Added Max FPS option to
the Graphics tab of the Preferences dialog box. This option is used to limit FPS (frames per
second). The preference default is set to 40Hz which is faster than the human eye can detect
(24Hz is frame rate of movies) – you can get max absolute by entering zero (gives you 60Hz).

Modal Frequency Response (MFREQ) Multi-step Structural Solution (SOL 401)

Analysis Case creation

• Added support for building of Modal Frequency Response subcases in Multi-step structural
solution (SOL 401) using the Analysis Manager. When creating an analysis case in a Multi-step
Structural solution (SOL 401), a new analysis type 4..Frequency/Harmonic Response option
is available in the Analysis Case dialog box combo box. This allows you to create a modal
frequency response subcase for the Multi-step Structural solution.

Mass and Damping

• The Mass and Damping node under the Options node of the Analysis Set is used to set the
mass and damping properties at the global level. An additional field in the Mass and Damping
dialog box is now available to create/select a Modal Damping Table which is only applicable
to the 4..Frequency/Harmonic Response subcase.

• Only the Overall Structural Damping Coeff (G), Modal Damping Table, and Mass
formulation options at the analysis set level are applicable for the 4..Frequency/Harmonic
Response subcase. All other fields in the Mass and Damping dialog box are not applicable,
and are grayed out.

• The Mass and Damping node is available under the 4..Frequency/Harmonic Response
subcase to set the Overall Structural Damping Coeff (G) and Modal Damping Table at
the subcase level. W3, W4, and mass formulation is not available at the subcase level.

Solution Frequencies

• The Solution Frequencies node is now available under the 4..Frequency/Harmonic Response
subcase to select the solution frequencies at which the solution is to be performed.

• Solution Frequencies can now be created by selecting any of the combinations of FREQ,
FREQ1, FREQ2 options from the Form of Frequency List combo box of the NASTRAN
Dynamic Analysis dialog box. These frequencies are exported as FREQ, FREQ1, and FREQ2
cards.

• Solution Frequencies can also be created by using the Frequency Response option in the
Options for Dynamic Analysis tab of the Dynamic Analysis dialog box. This is where you can
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select an existing Frequency table or create a frequency table using already calculated modal
frequencies by clicking the Modal Freq button.

Exporting Multi-step Structural solution (SOL 401) Modal Frequency Response subcase

• Subcase definition - Support added for the ANALYSIS=MFREQ card to specify the subcase’s
analysis type as being a modal frequency response.

• Mass definition - Support added for export of Lumped and Coupled mass formulations:

PARAM,COUPMASS,-1 - Lumped mass formulation

PARAM,COUPMASS,1 - Coupled mass formulation

• Damping Definition - Support added for the combination of the following CARDS:

• DAMPTAB bulk data entry - for defining modal damping table

• DAMPING bulk data entry - for defining overall structural damping coefficient

• Parameters bulk data entry - for defining overall structural damping coefficient, mass
proportional damping coefficient, and stiffness proportional damping coefficient

Support added for the case control command DAMPING to reference DAMPING and/or DAMPTAB
bulk data entry.

Note:

Frequency dependent damping is not supported.

• Dynamic Loads:

• Support added for the RLOAD2 bulk data entry.

• Support added for the DLOAD bulk data entry that references RLOAD2 cards to create a linear
combination of load sets.

• Support added for the case control command DLOAD to reference the DLOAD bulk data entry.

• Solution Frequencies - Support added for FREQ, FREQ1, and FREQ2 cards to define a set of
frequencies used in the solution of a modal frequency response subcase. Support added for the
case control command FREQUENCY to reference the FREQi bulk data entries.

• Output Requests - You can now request all nodal and elemental outputs for a modal frequency
response subcase in a multi-step structural (SOL 401) analysis via the NASTRAN Output Requests
dialog box.

Importing a Multi-step Structural solution (SOL 401), Modal Frequency Response subcase

1. Welcome to the Femap Readme
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• Support added for import of all the cards mentioned in the previous sections.

Analyze and Read Results from a Multi-step Structural solution (SOL 401), Modal Frequency
Response subcase

• Support added for analyzing a SOL 401, modal frequency response subcase along with the ability
to read all applicable output vectors.

Versioning

• Since Femap 2301, a consistent release cadence with other products within the Simcenter
portfolio and our user-facing versioning has reflected that convention (i.e. Femap YYMM) has
been maintained. Internal product versioning, however, has simply used the minor version to
indicate the feature version within a year (e.g. 23.1 = 2301, 23.2 = 2306). This caused confusion
that is being rectified with these Versioning changes.

• Going forward, program versioning will mirror the user version, and will utilize the tenths and
hundredths place to denote year and month: YYMM = YY.MM.

Note:

FOR Femap V 2412 ONLY – while the user facing version is 2412, the Femap team is
treating it as version 25.01 to minimize any compatibility issues for those comparing the
minor version as an integer. All subsequent releases will follow the previously described
convention.

• This also affects database versioning, including within the neutral file. For those who write
custom neutral files, ensure 2412 neutral files use 25.01, including the leading zero

• Maintenance packs shall reflect in the program version (e.g. 2506 MP2 = 25.062), and with this
convention may be reflected in the database version. However this is exceedingly rare, as the
Femap team strives to maintain database compatibility within a feature release.

• API versioning shall be similar. However, the major version will follow the old convention due
to hexadecimal conversions. Additionally, the maintenance pack level shall be encoded into a
hexadecimal conversion of the thousandth place, (MMP) and the Femap team will no longer
increment the type library version for every maintenance pack unless the API changes. This
should lead to fewer required changes the developer in the long run. For reference, here is a table
of the type library versions:

• Year = 25 (including Femap 2412) = 19, 26=20, 27=21, etc…

• Month

// 010=A, 011=B, 012=C, 013=D, 014=E

// 020=14, 021=15, 022=16, 023=17, 024=18

// 030=1E, 031=1F, 032=20, 033=21, 034=22

Femap v2412
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// 040=28, 041=29, 042=2A, 043=2B, 044=2C

// 050=32, 051=33, 052=34, 053=35, 054=36

// 060=3C, 061=3D, 062=3E, 063=3F, 064=40

// 070=46, 071=47, 072=48, 073=49, 074=4A

// 080=50, 081=51, 082=52, 083=53, 084=54

// 090=5A, 091=5B, 092=5C, 093=5D, 094=5E

// 100=64, 101=65, 102=66, 103=67, 104=68

// 110=6E, 111=6F, 112=70, 113=71, 114=72

// 120=78, 121=79, 122=7A, 123=7B, 124=7C

• Registry

• The root folder for the Femap registry hive has changed from “UGS PLM Solutions Femap” to
simply “Siemens”, and the versioning shall now mirror the user-version. Maintenance packs
shall never be reflected here.

• This applies to all keys in both HKEY_LOCAL_MACHINE as well as HKEY_CURRENT_USER

eg Computer\HKEY_CURRENT_USER\Software\Siemens\Simcenter Femap 2412

• User directory

• The root folder for the user directory remains the same (%APPDATA%\Femap\), however, the
version subfolder shall reflect the user version as well.

• As a reminder, this folder can always be seen in the Help → About command dialog box.

Corrections

Teamcenter Integration

• Corrected issue that caused layer,color import options to be ignored for acis. Issue was reported in
the forum.

• Corrected issue where open/save/import files from Teamcenter by double clicking on the row of
the report control table was prohibited.

Meshing

1. Welcome to the Femap Readme
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• Corrected an issue where parabolic TRIA6 elements were corrupted after using Mesh > Extrude >
Element Face or Mesh > Revolve > Element Face commands.

Model

• Corrected issue where material.esp was not loading personal saved materials. Increased the width
of the format specifier to 6. Width of 5 was not enough as the internal version number for Femap
version 2401 is 24.11 unlike all other versions which was of the form xx.x. (PR# 11091138)

• Corrected issue where Aero Panels not included in model box, causing auto-scale to fail. This fix
does not handle auto-scale visible in all cases. Normally not an issue as the modfem will have a
spatially corresponding mesh.

• Corrected issue where single section curved beam sections did not draw the stress locations on
the second end.

• Corrected issue where follower forces were being incorrectly scaled when a definition coordinate
system was applied via a command like Model->Rotate By->Node. (PR# 11152186)

• Corrected issue where a vulnerability existed in reading properties from neutral files. (PR#
11156772)

Elements

• Corrected issue where the application might crash with weld elements when picking. Also added
RROD and RBAR to FUGUE as they are like Line2 elements.

Analysis Set - Abaqus

• Corrected issue where Femap falsely gives the warning in the Message window that advanced
geometric constraints cannot be exported for Abaqus. Removed this warning message. (PR#
11092400)

• Corrected issue when reading Abaqus INP file, all sectional information for a beam section
assigned to PIPE31 type of elements were zeroed out. Fixed issue by determining the type of
the elements in ELSET of the BEAM SECTION and then assigning the correct property type. (PR#
11103686)

Performance Graphics

• Corrected issue where bad background color caused Performance Graphics label backgrounds to
be random colors. The background color cannot be bad via the UI - some other issue must have
changed the background color to 3162 (transparent white).

• Corrected issue where elements were drawn deformed in show entity (preview) when deformed
mode is Arrow - they should have been drawn not deformed. (PR# 11119118)

• Corrected issue introduced in 2022.1 MP1 when fixing PR# 10263076 where scaling of contour
arrows was not done correctly. That fix did not handle negative values correctly and this new fix
resolves that issue.

Femap v2412
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• Corrected issue with Arrow Deformed Style and Arrow Contour Style (nodal results) where some
internal nodes were not included in the arrow display.

• Corrected issue where most elemental load symbols for heat flux on face 1 and 2 were drawn
incorrectly.

• Corrected issue where negative scale factor on beam diagram options could cause dark shading of
contours.

Analysis Set Manager

• Analysis set is skipped when results are loaded manually from the job monitor pane. Fix: Fixed
the issue. Analysis set will not be skipped when results are loaded manually from the job monitor
pane. (PR# 11108319)

• Corrected issue with graying on NLCNTL NLCNTL2 dialog boxes when user clicks Skip and reenters
the dialog. Corrected and issue where TSTEPK was not unloading properly.

• Corrected issue that could potentially cause a crash when using feFileWriteNastran if you do not
have the AnalysisMgrSet created, causing the application to use a nullptr object. This occurs when
you go through the old Analysis Control dialog with no Analysis Manager set created.

Geometry

• Corrected issue where geometry would not copy using the Between Vector method with parallel
vectors. Added error message for anti-parallel case (parallel opposite directions).

• Corrected issue where nodes could not be picked in measure between nodes if the nodes were
picked with multi-select selector being on (PR# 11145432).

API

• Corrected tech support issue in any API function with 18 variables, the macro helper in Femap left
off the last variable causing any API to think the wrong number of entries was being entered. The
only impacted the functions feElem.GetAllArray2, and feProp.PutAllArray.

• Corrected issue where Save on Close dialog not showing in some cases when closing model via
API.

Licensing

• Corrected issue with Windows license server esplmd, rebuilt to address license borrowing
performance and return.

Femap v2406.0001

Updates and Enhancements

Licensing

• Updated to FlexLM License Servers to version 11.19.6.0.
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Note:

The Femap FlexLM Linux license server has been built on RedHat 9.4 and has been updated
to version 11.19.6.0 for security concerns. As a result, the serving platform compatibility is
affected. For RedHat, version 9 is the minimum system. For other Linux distributions, GLIBC
>=2.34 and ELF is required. See ReadMe.txt in LSB_64 folder for tested systems. While it
is recommended to update the Linux license server, it is not necessary. The server-client
compatibility remains the same as Flex 11.19.4.

Flex 11.19.6.0 Supports:

Linux 64-bit x64 9
SLES 15 SP3, SLES 15 SP4, and SLES 15 SP5
Ubuntu 20.4 and Ubuntu 22.4

Note:

The Femap FlexLM Windows license server has been updated to version 11.19.6.0 for
security concerns. See ReadMe.txt in x64_n6 folder for build information. While it is
recommended to update the Windows license server, it is not necessary. The server-client
compatibility remains the same as Flex 11.19.4.

Flex 11.19.6.0 Supports:

Microsoft Windows 64-bit x64 Windows 10
Windows 11
Windows Server 2019
Windows Server 2022

It is a best practice to run license servers on a server-based OS.

Teamcenter Integration

• Added ReadShareUrl() function to read 'TCShareUrlLink' from registry for provide facility of set
url from outside of femap.exe(i.e registry) for customer in case url chaned by XShare team.

• Added preprod url in url list.

• Replaced production url, connector.exe download url.

PostProcessing

• Added support for the following NH5RDB datasets - ELEMENTAL/STRAIN/
QUAD4_COMP ELEMENTAL/STRAIN/QUAD8_COMP ELEMENTAL/STRAIN/QUADR_COMP ELEMENTAL/
STRAIN/TRIA3_COMP ELEMENTAL/STRAIN/TRIA6_COMP ELEMENTAL/STRAIN/TRIAR_COMP

Femap v2406.0001
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Corrections

Analysis - Abaqus

• Corrected issue when reading Abaqus INP file, all sectional information for a beam section
assigned to PIPE31 type of elements are zeroed out. Fixed the issue by determining the type
of the elements in ELSET of the BEAM SECTION and then assigning the correct property type. (PR#
11103686)

• Femap falsely gives the warning in the message window that advanced geometric constraints
cannot be exported for Abaqus. Fix: Removed this warning message. (PR# 11092400)

• Corrected issue when reading the Abaqus INP file. All sectional information for a beam section is
assigned to PIPE31 type of elements are zeroed out. (PR# 11085429)

Teamcenter Integration

• Corrected issue where an incorrect transform occurred by assigning Xform = NULL FD-769 :
Moved pOccur->ResolveTransformRef() inside LoadSERep() and LoadSEPart() to avoid the conflict
of transforms.

Graphics and Performance Graphics

• Corrected issue with colors of curve associated data of beam property y-direction.

• Corrected issue when using Unified Architecture (in OpenGL 1.0, 1.1 or 2.1 but not 4.2) where
recently created entities, such as coordinate systems, are not drawn correctly until a ctrl-G is
done.

• Corrected issue where a crash occurs when using geometry based constraints in groups in Unified
Architecture graphics. Workaround is to go into File > Preferences... Graphics tab and deselect
Geometry based loads and constraints in the Unified Architecture sub dialog.

• Corrected issue where deformed arrow components not handled correctly in Unified Architecture.

• Corrected issue where bearing loads on surfaces not offset correctly in Unified Architecture.

• Corrected issue where geometry based follower loads not drawn correctly in Unified Architecture

• Corrected issue where element faces of Pyramid5 elements were not pickable - for example when
creating loads on element faces.

Meshing

• Corrected issue in the Body Mesher where entering a Mesh Quality, "Min Tri/Quad Quality" value
outside of the recommended range of 0.01 to 0.1 would cause the Body Mesher to crash.
Updated the values Femap will let one enter to match the 0.01 to 0.1 range.

• Corrected issue where parabolic TRIA6 elements were corrupted after a Mesh > Extrude > Element
Face or Mesh > Revolve > Element Face Bug command.

1. Welcome to the Femap Readme
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Geometry

• Rolled back fix for PR 11086301 where the scale_factor on solids was getting lost after a hole was
filled with the FEMAP menu command - Solid - Fill Hole. New code grabs the scale_factor before
the Parasolid call, and then reapplies it after. No idea why this fixes it, but it does. We have a
query in to the Parasolid team to try and figure out why this was required. (PR# 11086301)

• Corrected issue when converting Femap curves (mainly arcs/circles) to Parasolid wire bodies. This
code was used in IGES exporter to export Femap wireframe geometry.

• Corrected issue with GeometryInterface.cpp : enabling the IGES export option when points and
curves are present in the model but no solid geometry is.

• Corrected issue with sol_rd.cpp : exporting points and curves to IGES file when all solid
geometries are hidden in the model.

Elements

• Corrected issue where the CBUSH element in the entity editor was prompting the wrong dialogs
from the orientation vector and coordinate system commands. This was only happening in
Japanese localization. Internal notes - string compare was not working in Japanese localization.
So we needed to use a UIString and "CompareLeft( wLdStr(...) )". (PR# 11084756)

Analysis Manager

• Corrected issue where Femap crashes when the job monitor pane is closed and model is closed
while the jobs are running Added a NULL check for activeJobMonitorData pointer. (PR#
11092126)

• Added the Joint Time Constraints dialog (JCON) to Analysis Manager tree for the solution. Ability
to read/write JCON was added in Femap version 2406, but dialog was not exposed to set variables
(bug).

Dockable Panes

• Corrected issue when previewing coincident point. Message was listed to the message window
stating how many were detected but was misleading because it said nodes and not points.
Internal - hard coded the eName to Node in the error warn message. Changed it to dataType
coming into the function. So it should work with Nodes. Points or whatever else comes through
there.

File Operations

• Corrected issue when exporting Points and Curves to an IGES file when options are selected on
the IGES export dialog. (PR#11079846)

API

• Corrected issue where Femap crashes due to API feGetElementFacesFromSet. (PR#
11094366)

Femap v2406.0001
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• Corrected issue uncovered by Tech support in any API function with 18 variables. The macro
helper in Femap left off the last variable causing any API to think the wrong number of entries
were entered. Impacted functions: feElem.GetAllArray2, and feProp.PutAllArray.

Femap v2406

Updates and Enhancements

Teamcenter Integration

Open/Save Files from/to Teamcenter

• Migrated the supported dataset from 'CAE Analysis' to 'CAE Femap'.

Note:

Any files saved to the 'CAE Analysis' dataset are now supported only for the Teamcenter
Open operation.

• Added support for opening of mod and neu files.

• Created a new user interface for selecting data from Teamcenter operations.

• Added ability to reorder columns or toggle visibility of columns.

• Retain changes done in column orders and visibility for any subsequent usage of the dialog
box.

• For modfem files opened from the 'CAE Femap' dialog box, the Read-only check box lets
you open the file as read-only. By default, Read-only is off and the data checked-out post
file open.

• Auto-fill the current Item-ID and its Revision-ID upon opening the Teamcenter Save dialog
box.

• Added retention of last 5 most recently used items for the Teamcenter search during
Teamcenter Open, Save and Import Shattered JT Assembly commands.

• For the Teamcenter Save operation, added a warning for empty dataset names in the
Teamcenter Save dialog box. If you enter an Item Revision with no 'CAE Femap' dataset,
an empty row is created with empty name. The warning icon and a tool-tip appear for the
empty dataset name. Upon clicking of the Save button, a new dataset is created under the
Item-Revision object of type 'CAE Femap' and the file is uploaded in the dataset.

New Item Revision Creation
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• Added a Create button in the Teamcenter Save dialog box. Opens the Teamcenter Create a
New Item dialog box containing options to define/assign Item ID, Revision ID, Name and
Folder.

• The Folder option Browse button opens the Select Folder dialog box which lists the folders
available in Teamcenter.

• Newly created Item-ID and Revision-ID gets auto-filled in the Teamcenter Save dialog box
Search operation input

Check Out/Check In from/to Teamcenter

• Check-out and Check-in buttons added to the Teamcenter toolbar.

• Buttons are activated exclusively for files opened from Teamcenter.

• Check Out provides an exclusive access to the data opened from Teamcenter.

• Check In is activated when the active model is checked out to the logged in user.

• Check In saves the current model opened from Teamcenter and uploads it to Teamcenter.

• After a successful upload, the data is checked-in and the exclusive lock is released.

Layup Builder

Update Layup Builder When Deleting Material

If you are working in the Layup Builder and deleting a material from the Femap user interface,
the Layup Builder pane is updated to reflect the change. Rows using that material are no longer
listed.

Bi-direction Composites HDF5 Data Exchange

Layup Builder now supports bi-direction Composites HDF5 data exchange. Users commonly to
go from Femap FEA to Fibersim as a starting point.

Randomized Property Colors

A new option is available to randomize new property colors when generating layups. This is
turned on in the Layup Creation tab of the Layup Builder Options dialog box.

Save Prompt Upon Exiting Layup Builder

A prompt now presents you with and option Save when you exit the Layup Builder pane.

Set Offset on Laminates

A new option is available to set an offset on laminates. This is turned on, and the offset specified
in the Layup Creation tab of the Layup Builder Options dialog box.

Change names of HDF5 related commands, options, and settings

Throughout the Layup Builder user interface, the term "Fibersim" is replaced with "Composites
HDF5".
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Define Text in 3D Model Space

• The Tools → Text command is enhanced to create the Text object in View space, but also have
the pointer be attached to a point in 3D model space. Two new radio buttons are added in the
Style section of the Define Text dialog box. They control the Pointer behavior. If you choose the
Position of the text to be in View, you also have the option to put the Pointer in View or Model.
If the text is in Model position, the pointer will only be allowed to be placed in Model space.

Dockable
Panes -
Model Info
Tree
Constraints

• Added Auto Create Definition option to the Other Constraints context sensitive
menus. The new option allows you to highlight any number of constraints and will
automatically create new constraint definitions based on type and constraint. A new
definition will be created for constraints of the same type which have different values
and/or different settings, which differs from the Create Constraint command.

Meshing Toolbox

Geometry Editing: New Edge Replace Option

Edge Replace and Methods are added to the Geometry Editing command Operation options.

When editing geometry, the Edge Replace option extends Surface(s) connected to the first
selected Curve to the second selected Curve via three Methods. Full replaces the first selected
curve with the second selected curve. Partial updates the surface(s) by moving the points of
the first selected Surface to the closest location on the second selected Curve. Edge Aligned
replaces first selected edge to the second selected edge by linearly extending the adjacent edges
of the first selected curve.

Mesh Sizing: New Spacing Option

The option Use Existing Spacing is added to the Mesh Sizing command Spacing biasing
options drop-down menu. When the option is used, the existing biasing option on the curve will
be maintained.

Sloshing - VMESH incompressible fluid option

• A Simcenter Nastran version 2406 update to the INCMOPT bulk entry is incorporated into
Femap's Sloshing analysis set options. The INCMOPT bulk entry specifies options for modeling
incompressible fluids with fluid elements. Several options in Femap's Incompressible Fluid
Options dialog box are added for outputting a visualization mesh for a sloshing surface.

The new options are related to the Simcenter Nastran VMESH bulk entry field.

Output visualization mesh (VMESH)

Outputs a visualization mesh for a sloshing surface. Options are: 0..No (default) and 1..Yes.

Note:

The software always outputs the mesh of PLOTEL visualization elements it creates for a
sloshing surface to the .op2 file. When Output visualization mesh (VMESH) is set to
1..Yes, the software also outputs the mesh of PLOTEL visualization elements to an ASCII
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file named input_file_plotel.dat and saves the file in the folder with the other files for
the solution.

Node ID Offset (GOFFSET)

Sets a grid ID offset for the visualization mesh output. (Integer ≥ 0; Default = 0)

Element ID Offset (EOFFSET)

Sets an element ID offset for the visualization mesh output. (Integer ≥ 0; Default = 0)

Read Aero Results from the op2 File

• In previous versions of Simcenter Nastran, aero results from flutter solutions were only written to
the *.f06 file making it difficult or confusing to setup Femap to read the flutter results for aero
data. Femap version 2406 adds support for reading the aero results data from the *.op2 files.

Translators - ANSYS

• Reduce and consolidate the number of error and warning messages from the ANSYS translator.
The ANSYS translator issues error/warning messages for every ANSYS unsupported command.
In many cases, the commands are not critical. Receiving excessive amounts of error/warning
messages can be misleading and confusing to users.

Import of Abaqus Output Requests

The import of Abaqus output requests is the final piece of functionality added to Femap's Abaqus
*STEP import functionality. Femap version 2401 focused on importing other data contained in a
*STEP. Femap version 2406 is focused on importing Output Requests for Abaqus.

Improvements are added to the Abaqus Output Request dialog box and to the export of the output
requests. These improvements ensure the propagation, re-specification, and suppression of output
requests are done in a consistent manner.

• A new check-box Inherit Output Requests from Previous Step is added to the Output Requests
dialog box in an Abaqus Solver analysis set. When on, you can propagate the results from the
previous step. When off, you can re-specify the output requests specifically for the current step.

• Support is added to the import of output requests specified in the Abaqus input file. This includes
improved warning messages, and the display of relevant information in the warning messages
during the export of the output requests.

Solvers

• For solutions that involve real eigenvalue analysis with the Lanczos method in Femap
versions 2406 and higher (SOL 103 – Normal Modes, SOL 105 – Linear Buckling, SOL 111 –
Modal Frequency, and SOL 112 – Modal Transient ), the MUMPS solver is now the default.
Reverting to the solver used in earlier versions prior to version 2406 can be done by adding the
SYSTEM(810)=0 system cell to the analysis set.

Rigid Elements

Added support for Rigid Elements RROD and RBAR. In Simcenter Nastran, for SOL 401, an existing
element architecture with small strains is available that improves performance. When you run your
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analysis with large strains turned off (PARAM,LGSTRN,0), the software now uses the improved
approach by default. The small strain architecture now supports RROD and RBAR rigid elements.

• In Femap, RROD and RBAR rigid elements can now be created with the Model → Element
command. The RROD and RBAR rigid elements are defined on two new tabs added to the Define
Rigid Element dialog box. The RROD and RBAR tabs contain connectivity and degrees of freedom
options for both.

API

• Added AbaUsePreviousOutput and GlueSetType for Analysis Case Objects

• Added GlueSetType, NasINCMOPTVMESH, NasINCMOPTGOFFSET, and NasINCMOPTEOFFSET
for Analysis Set Object

• Added RigidRodDependentDofLoc, RigidRodDependentDof, RigidBarDOFs, and
vRigidBarDOFs for Element Object

• Added AutoCreateBCDef for Constraint Set Objects

• Added AutoCreateLoadDef for Load Set Objects

• Added feTextPut2 method to the feText object which creates or updates a text annotation.
Contains new input BOOL pointerIs3D which if True, and modelPos is False, the pointer will
be placed in Model space.

• Added feTextMultiPut2 method to the feText object which creates multiple text annotations.
Contains new input BOOL pointerIs3D which if True, and modelPos is False, the pointer will
be placed in Model space.

• Added feTextGet2 method to the feText object which retrieves a text entity. Contains new input
BOOL pointerIs3D which if True pointer is in Model space. If False pointer is in View space.

• Added BOOL pointerIs3D property to the feText object. If True pointer is in Model space. If
False pointer is in View space..

• Added feMeshPlatePatternRefine method to provide API access to the Mesh → Editing →
Element Refine command. The input is the ID of a Femap Set containing the shell elements to be
refined, and definition of the Split Pattern to be used.

• Added feMeshHexPatternRefine to access functionality of Mesh → Editing → Mapped Hex
Refine command programmatically

• Added feGetTeamcenterSessionInfo to retrieve information displayed in Teamcenter
Account Information dialog box when using PDM → Teamcenter → Account Information
command
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• Updated feLoginToTeamcenter and feSaveModelToTeamcenter to reflect changes made
to dialog boxes of commands on the PDM → Teamcenter menu

Corrections

Teamcenter Integration

• Corrected issue with possible incorrect assignment of check-out=true during query even when a
BOMView Revision or dataset is not checked out by anyone on Teamcenter.

• Corrected issue with Item ID population in Teamcenter Open dialog.

• Corrected Coverity issue: Prefer using LIMITstrcpy/LIMITstrcat over sprintf to avoid overflow of
limited size character array in case the source string is too long for copy/concat operation. (CID#
66314)

• Corrected Coverity issue: Parsing Waring: parameter_hidden: declaration hides parameter
"objects" (declared at line 820). (CID# 66355)

• Corrected issue where Open and Save queries did not work as expected.

• Corrected issue when fetching checked out user info. Removed commented code.

• Corrected Coverity issue: 'Femap Aggressive' warnings. (CID#'s 66354 and 66328)

• Corrected issue with opening dataset resulting in incorrect output when there are two datasets
with same file name in Item-Revision.

• Corrected memory leaks by releasing memory on open Updated return codes OnOpenPress.

• Corrected warning: redeclaration of variable.

• Corrected issue with a warning and updated variable names in PDM.h.

• Corrected link errors by giving unique name to CheckOut and CheckIn entry point in PDM project
for Teamcenter.

• Corrected issue where Femap crashes when it has no model opened and the user tries to work in
the Teamcenter dialog.

• Corrected issue where Femap crashes when the internet is off and the user tries to Search/Open a
dataset from "Open file from Teamcenter" dialog.

• Corrected issue occurring due to hard coding dataset filters. Removed all hard coded filters in
TCClient code. Filters are now set only on UI level code. Re-factored Upload/Download APIs to use
Dataset UIDs instead of Dataset names.
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• Corrected issue with entering all capital User ID during login. Teamcenter does not recognize
check-in check-out state of dataset.

• Corrected issue with Check-in/Check-out functionality behaving incorrectly when a user logged in
apart from admin credentials.

• Corrected Coverity issues: (CID# 66409) Calling risky function, Impact-Low. (CID# 66410)
Uninitialized scalar variable, Impact-High. (CID# 66411) Unchecked return value, Impact -
Medium. (CID# 66413) Unreferenced null return value, Impact - Medium.

Analysis Interfaces - Abaqus

• Corrected issue associated with writing the "name" parameter for the *STEP keyword in Femap
version 2401. Abaqus restricts allowing multiple steps with the same name. Rectified by ensuring
the "name" parameter is no longer written for *STEP. (PR# 11042617)

• Corrected issue where Femap crashes upon importing an Abaqus input file. The crash occurs
when either a blank subheading data line is present or if the subheading data line is omitted
altogether. (PR# 11042626)

• Corrected issue where a spurious printf statement was raising an error and caused issues with
ABAQUS model preview (from Analysis Manager, not from the Model Info tree) where the model
itself wouldn't get written to the preview window. Didn't happen on export. Regression from
Femap 2020.1. Fix was to comment out unnecessary debug messages.

Analysis Cases

• Corrected issue in dInit_AnalysisCase. Line 3609 was doing an upper bound check if A->act_case
< A->num_case in the if condition. Removed this check as it is not needed.

Model

• Corrected issue with Layup Builder which caused Femap to crash if using the Check Layups vs.
Composites HDF5 command when the Data Table was not open.

• Corrected issue when Validate is turned on for a Global Ply. The user is prompted to update the
material and/or thickness of the plies in any Layups assigned with that Global Ply. This was a
capability that existed in versions prior to Femap 2301. Now, the user will only be prompted if the
Validate check is on.

• Corrected issue when copying subsets of a Parasolid body, i.e. when copying just some of the
surfaces of a Parasolid solid. There was a bug not setting lines correctly and they could draw
in the wrong location until a File > Rebuild was executed. There were no other problems than
visual, they meshed fine.

Meshing

• Corrected issue where code has some incorrect logic to handle tolerances and multiple nodes and
curves. Updated code so it sets the custom mesh size on curves with existing node locations to
work correctly. (PR# 11050134)

Graphics and Performance Graphics
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• Corrected issue in New Picking when picking properties, materials or layups using the Select
Visible button, incorrect entities were marked.

• Corrected issue when drawing stresses on beam cross-sections in screen space was including
model drawn by Unified Architecture.

• Corrected issue when using selector with elements and doing an action that causes a
regeneration (for example switching deformation on from toolbar) that caused elements to be
unpick-able. As a workaround, switching the selector to node and then back to element resolves
this issue.

• Corrected issue where drawing freebody arrows as solid caused symbols and labels in Unified
Architecture to not be drawn.

• Corrected issue where picking by polygon was deleting markers for previously picked entities.

• Corrected issue where some entities (e.g. elements) were not drawn correctly when doing a
Window → Show Entities... command with the Transparent Highlight option off.

• Made further corrections to marking picks when using New Picking to pick properties (and
materials and layups) and using the Select Visible button and preview buttons.

• Corrected Coverity issue: Coverity does not account for #pragma once and thought
OGL_Bitmap.hxx was included twice in a couple to files. (CID# 62704)

• Corrected Coverity issue: Checked return values but it is impossible for them to return FALSE.
(CID# 66297)

• Corrected Coverity issue: Array was not large enough. (CID# 66303)

• Corrected Coverity issue: INitialized variable even though it is not needed. (CID# 66310)

• Corrected Coverity issues: Removed unused variable and removed always true check on fNormal.
(CID#s 66381 and 66358)

• Corrected Coverity issue: Removed unused variable. (CID# 66383)

• Corrected issue where showing an expanded connection region flashes on and off if the Auto
Regeneration switch is on in the Graphics Preferences.

Output

• Corrected issue where Femap fails to import the data stored due to "Inherit Output Requests from
Previous Step" in the Output Request dialog.

Loads and Constraints

• Removed an unnecessary Put statement in TreeCmd and included line to avoid code execution
when user attempts to use Constraint Equation as well as inform the user.
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• Corrected issue where Freebody entities were created with active layer, but weren't used
anywhere and couldn't be changed via the UI. If deleting a layer, List → Tools → Layer would
indicate that the layer was missing due to 2 freebodies. Fixed issue by not setting layer in rec init
and also removing layer get / set from the toolbox. Can still technically be set via the API but not
removing that because it may break.

Licensing

• Corrected issue which could prevent module/user list data from populating in Help → Manage
Licensing for FlexLM node-locked licensing.

Command Finder

• Corrected issue where the search online link in the Command Finder Search dialog stays visible if
Ctrl+F is used to navigate to Command Finder in the session.

• Corrected issue where pressing the command finder shortcut post resetting the menu bar,
populates the search dialog with matches from the previously searched command list.

File Operations

• Corrected issue when closing an empty model where there have been no changes or only
orientation changes so that no Save Yes/No/Cancel prompt is issued.

API

• Corrected an issue where both the NodesAsSet and ElementsAsSet methods on the Connection
Region object were ignoring the bClear argument and would not clear the Set object if set to True.

• Corrected issue with a runtime exception handling for GetRevisionRules API.

Help

• Corrected issue where the compatible Simcenter Nastran version for Femap version 2401 was not
available in Japanese Help. Added correct version. (PR# 11053174)

Femap v2401.0002

Updates and Enhancements

Licensing

• Updated to FlexLM License Servers to version 11.19.6.0.

Note:

The Femap FlexLM Linux license server has been built on RedHat 9.4 and has been updated
to version 11.19.6.0 for security concerns. As a result, the serving platform compatibility is
affected. For RedHat, version 9 is the minimum system. For other Linux distributions, GLIBC
>=2.34 and ELF is required. See ReadMe.txt in LSB_64 folder for tested systems. While it
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is recommended to update the Linux license server, it is not necessary. The server-client
compatibility remains the same as Flex 11.19.4.

Flex 11.19.6.0 Supports:

Linux 64-bit x64 9
SLES 15 SP3, SLES 15 SP4, and SLES 15 SP5
Ubuntu 20.4 and Ubuntu 22.4

Note:

The Femap FlexLM Windows license server has been updated to version 11.19.6.0 for
security concerns. See ReadMe.txt in x64_n6 folder for build information. While it is
recommended to update the Windows license server, it is not necessary. The server-client
compatibility remains the same as Flex 11.19.4.

Flex 11.19.6.0 Supports:

Microsoft Windows 64-bit x64 Windows 10
Windows 11
Windows Server 2019
Windows Server 2022

It is a best practice to run license servers on a server-based OS.

Geometry

• Enabled IGES export option when points and curves are present in the model but there is no solid
geometry. sol_rd.cpp : Now exporting points and curves to IGES file when all solid geometries are
hidden in the model.

Corrections

Analysis Manager

• Corrected issue where Femap crashes when the Job Monitor pane is closed and the model is
closed while the jobs are running. Added a NULL check for activeJobMonitorData pointer. (PR#
11092126)

PostProcessing

• Added support for the following NH5RDB datasets: ELEMENTAL/STRAIN/QUAD4_COMP
ELEMENTAL/STRAIN/QUAD8_COMP ELEMENTAL/STRAIN/QUADR_COMP ELEMENTAL/STRAIN/
TRIA3_COMP ELEMENTAL/STRAIN/TRIA6_COMP ELEMENTAL/STRAIN/TRIAR_COMP

Geometry

• Corrected issue when converting Femap curves (mainly arcs/circles) to Parasolid wire bodies. This
code was used in our IGES exporter to export Femap wireframe geometry.
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• Corrected issue when Exporting Points and Curves to IGES file when options selected on IGES
export dialog. ( PR# 11079846)

• Rolled back fix for PR 11086301 where the scale_factor on solids was getting lost after a hole was
filled with the Femap menu command - Solid>Fill Hole. New code grabs the scale_factor before
the Parasolid call, and then reapplies it after. (PR# 11086301)

• Corrected issue with complex expanded total translation. (PR# 10789657)

Finite Elements

• Corrected issue where material.esp was not loading personal saved materials. Increased the width
of the format specifier to 6. Width of 5 was not enough as the internal version number for 2401 is
24.11 unlike all other versions which was of the form xx.x. (PR# 11091138)

• Corrected issue where the CBUSH element in the entity editor was prompting the wrong dialogs
from the orientation vector and coordinate system commands. This was only happening in
Japanese localization. Internal notes - string compare was not working in Japanese localization.
Needed to use a UIString and "CompareLeft( wLdStr(...) )". (PR# 11084756)

• Corrected issue where if Validate is turned on for a Global Ply, you are prompted to update the
material and/or thickness of the plies in any Layups assigned with that Global Ply. This was a
capability that existed in versions prior to 2301. You are now prompted only if the Validate check
is on.

Graphics and Performance Graphics

• Corrected issue introduced when fixing PR 10263076 where scaling of contour arrows was not
done correctly - fix did not handle negative values correctly and this fix resolves that issue.

• Corrected issue where element faces of Pyramid5 elements were not lick-able, for example when
creating loads on element faces.

• Corrected issue where Performance Graphics deformed arrows normal to the screen were not
drawn correctly.

• Corrected issue where values of transformed deformed arrows were not correct when using
Performance Graphics.

Meshing

• Corrected issue where parabolic TRIA6 elements were corrupted after using
Mesh>Extrude>Element Face or Mesh>Revolve>Element Face Bug commands.

• Corrected issue with the Body Mesher where entering a Mesh Quality, "Min Tri/Quad Quality"
value outside of the recommended range of 0.01 to 0.1 would cause the Body Mesher to crash.
Updated the values Femap will let one enter to match the 0.01 to 0.1 range.

API

• Corrected issue when Tech support uncovered a bug in any API function with 18 variables,
the macro helper in Femap left off the last variable causing any API to think the wrong
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number of entries was being entered. The only impacted the functions feElem.GetAllArray2, and
feProp.PutAllArray.

• Corrected issue where Femap crashed due to API call feGetElementFacesFromSet. (PR#11094366)

• Corrected issue where using the AddEntitiesOnLayer method of the feSet object was not adding
Text entities on specific layers into the set object. (PR# 11084573)

• Corrected issue with potential crash occurring when using feFileWriteNastran when you do
not have the AnalysisMgrSet created, causing us to use a nullptr object. This occurs when a going
through the old Analysis Control dialog with no Analysis Manager set created.

Femap v2401.0001

Updates and Enhancements

Femap License Management

• The Show Modules and Show Users buttons are now separate buttons.

• The Manage FEMAP Licensing dialog box is now re-sizable.

• The DEX/SSC Subscription option is renamed to Siemens Software Center.

• The Connection Status indicator now includes information on the entitlement type (subscription,
trial, etc.).

Analysis Monitor and Analysis Queue

• Re-factored code to improve the filtering of connections in the Boundary Conditions dialog box of
different solvers.

• Changed the import of the ABAQUS input file to initialize the analysis case during the first pass.

• Rolled back BC Set filtering.

Connection Properties, Regions, and Connectors

• Changed the default option of SHLTHK on BCTPARM for Sol 401 from 0 - include shell thickness
to 1 - do not include shell thickness. Also issue a warning message when the user writes a
Simcenter Nastran deck using SHLTHK=0.

Interfaces - ANSYS

• Changed how RBE2 elements are written. In previous releases, RBE2 with dependent DOFS
(TX,TY,TZ) was written as MPC184 elements; and RBE2 with dependent DOFS (TX,TY,TZ,RX,RY,RZ)
was written as CONTAC175/TARGET170 elements. Now all RBE2 elements are written as CERIG.
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Corrections

Femap Entities

• Corrected issue in Femap data types where in extreme cases, there is a possibility of data
corruption with certain entity types. This issue does not impact computation and/or display of
results data. This issue may lead to API incompatibility for API scripts referencing entity type
constants beyond FT_AMGR_CASE (numeric value 61), and potential data corruption for models
containing any of the subsequently numbered entity types. If a pre-v2401 neutral file contains
any of these entities and is imported into v2401, or if a pre-v2401 Femap model is opened
in v2401, these data types could be affected. This issue does not affect models that were not
migrated from previous versions of Femap or models that do not contain these entity types. (PR#
11044663)

Note:

Please see Femap software field bulletin PL8786576 for more information (https://
support.sw.siemens.com/knowledge-base/PL8786576).

Meshing

• Corrected issue with incorrect logic to handle tolerances and multiple nodes and curves. Updated
code that sets the custom mesh size on curves with existing node locations to work correctly.
(PR# 11050134)

Graphics - Unified Architecture

• Corrected issue in New Picking when picking properties, materials or layups using the Select
Visible button, incorrect entities were marked.

• Corrected issue where Unified Architecture drawing of nodes was not obeying blanking correctly.

• Corrected issue where graphics image goes bad if the user has Performance Graphics on with
front pick, fast pick visible and uses the middle mouse button as OK.

• Corrected issue in Performance Graphics where nodal loads were not drawn if labels were off and
the loads were scaled by magnitude.

• Corrected issue where nodal loads in local definition coordinate system were not draw correctly
(database was not effected) if one or more of the DOF control check boxes are set off on the
load dialog. This impacted Performance Graphics but not the non performance graphics. (PR#
10895814 and its duplicate PR# 10896185).

• Corrected issue when drawing stresses on beam cross-sections in screen space was including
model drawn by Unified Architecture.

• Corrected issue where drawing freebody arrows as solid caused symbols and labels in Unified
Architecture to not be drawn.

Graphics
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• Corrected issue where aero entities were not drawn to CAE JT file.

• Corrected issue where the meshes of triangular Aero Panels are not drawn correctly.

• Corrected issue when using selector with elements and doing an action that causes a
regeneration (for example switching deformation on from toolbar) that caused elements to be
unpickable. As a workaround, switching the selector to node and then back to element resolves
this issue.

Analysis Monitor and Analysis Queue

• Corrected issue with dInit_AnalysisCase. Line 3609 was doing an upper bound check if A-
>act_case < A->num_case in the if condition. Removed this check as it is not needed.

• Corrected issue with elapsed time stops after the job is completed. (PR# 10995379)

Output and PostProcessing

• Corrected issue with vectorIDs of different output sets in Model > Output > Transform. (PR#
11026340 and PR# 11036238)

• Corrected issue where *FILE OUPUT keyword is not written if an explicit method is chosen. (PR#
11036943)

• Corrected issue with beam moment direction. (PR# 10889600)

• Corrected issue which prevented force balance results from being requested for dynamic
aeroelastic analyses.

Geometry

• Corrected issue which caused Femap to hang on imprinting 8000 curves. Based on input from
the Parasolid team, in this case, where only one planar surface is being projected on, the option
to "connect all side disjoint components" is irrelevant, however it's what is causing the long
execution time. Updated code in Femap to detect this connection and change the.Connect option
to None. (PR# 10750238)

Interfaces - ABAQUS

• Corrected issue with build errors. Changed the call to OGL_NEW to OGL_NEW_THROW. Re-
factored some code.

• Corrected issue associated with writing the "name" parameter for the *STEP keyword. Abaqus
restricts on allowing multiple steps with the same name. Rectified by ensuring the "name"
parameter is no longer written for *STEP. (PR# 11042617)

• Corrected issue where Femap crashes upon importing an Abaqus input file. The crash occurs
when either a blank subheading data line is present or if the subheading data line is omitted
altogether. (PR# 11042626)

Interfaces - Nastran
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• Corrected issue with writing the BSURFS entry for dynamic analysis with incompressible fluids if
multiple fluids regions were in the model.

Dockable Panes - Entity Editor

• Corrected issue which prevented various Entity Editor options from being configured and saved.
(PR# 10999426)

Model

• Corrected an issue which prevented the control function's bulk data entry for the driver load on a
flexible slider from being written. (PR# 10929689)

• Corrected issue to keep user created vector IDs consecutive in a set. (PR# 10878640)

• Corrected issue with wrong labeling of ply number in elements and surface selection dialogs.

• Corrected issue where Femap would crash if using the Check Layups vs. Composites HDF5
command when the Data Table was not open.

Licensing

• Corrected an issue which could cause a crash if Femap's auth DLL was loaded with auth_salt.dll

• Corrected issue which could prevent module/user data from populating in Help > Manage
Licensing for FlexLM node-locked licensing.

File Operations

• Corrected issue when using File > Picture > Save JT... where the selected load and constraint sets
were not output correctly to the JT file if the All or Select option was used.

• Corrected issue with importing Solid Edge ".par" into Femap resulting in a "file does not exist'
error. (PR# 10859271)

VisQ

• Corrected issue where VisQ does not start. (PR# 11026494)

API

• Corrected issue when using API to write CAE JT files that caused functions to always return fail
even if they succeeded.

• Corrected issue with enums for API access to JT file versions.

• Corrected issue with JT file versions used by API to match what was available in the version of
JtTk used by each version of Femap. This impacts the API functions feFilePictureSaveJT and
feFilePictureSaveJTMultiResults.

• Corrected issue w both the NodesAsSet and ElementsAsSet methods on the Connection
Region object were ignoring the bClear argument and would not clear the Set object if set to
True.
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Help
• Corrected issue with the default value documented for the 0..Stiffness Between the Friction

Stress and the Relative Displacement value in the Multistep Kinematic (402) tab of the Define
Connection Property dialog box. Value changed from 1.0E8 to 2. (PR# 10280879)

• Corrected issue where there was no description provided for the go_bundle.bat licensing option.
Documentation added to relevant section of Help. (ER# 10974519)

• Corrected issue where the Split Quads Command guide's help was still active in Help after the
command had been deprecated. Related topics were removed/updated. (PR# 10867884)

Femap v2401

Updates and Enhancements

Manage Femap Licensing
• Licensing is updated in Femap version 2401 to seamlessly accommodate the use of different

licensing types, giving you the ability to access them in Femap without interrupting Femap (on
the fly). This is done with Femap's new Manage Femap Licensing dialog which is now the
centralized location for configuring licensing for Femap. This dialog provides a series of License
Types to select from, controls to specify the License Location information, and a Connect button
to connect to the license. The Manage Femap Licensing dialog is accessed from the main menu
at Help → Manage Licensing.

With Manage Femap Licensing, you no longer need to exit Femap and execute a batch file
( go_...bat) to switch or set a new licensing type. The Manage Femap Licensing dialog also
allows you to view available features, set your licensing to new or old legacy methods, connect to
licenses, and receive feedback on connection status (without the need to shut down and restart
Femap).

• Added checks in Registry as well as .ini for license path.

Model
• A new Layup Builder dockable pane is available using the new Tools → Layup Builder command.

Layup Builder is used to interactively create a large number of Layups using an intuitive table
control. Layup Builder presents a different workflow for creating layup entities than the existing
Layup Manager. Where Layup Manager workflow typically allows you to create the layup, and
apply the layup to a property referenced by a specific element selection set, Layup Builder allows
you to build a list of plys and select elements, surfaces or groups where each individual ply
lands on. Using the Layup Builder table list, Femap finds the plies applied to specific elements,
and builds the corresponding Layups and properties on them to automatically update the finite
element model.

• A new Add Plys to Mesh command is available that allows you to add a specific number of plies
of certain material and thickness at a specified location across selected Layup elements. You can
now modify those layups to have the additional unidirectional ply at the top without modifying
the rest of the model. Running this command (Model → Laminates → Add Plys to Mesh...)
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opens the Add New Ply to Mesh dialog which contains the controls used to add plys. The outcome
of using this dialog is the new elements have an updated property and corresponding layup with
the newly added plys.

• Added to Abaqus Connections Write: Activating and deactivating connections in the step feature
added.

• Added changes for Neutral file read to support new Femap version 2401 Abaqus features.

• Updated the Femap Neutral file converter to 2401.

• Added improvements to Abaqus Import of load sets and constraint sets.

• Added functionality for Load from Layups commend to load information from an existing layup
into a Layup Builder Stack.

• Commented out code that greyed out the data table radio button (if the data table was closed)
when using the List > Output > Force Balance command. Now, if the radio button is selected
when the data table is closed, it automatically opens the data table and displays the information.

• Added 'analysis' keyword for 'analysis model' solve/import/export commands from toolbars.

• Added keywords for - Model > Output > Computed Vectors --> factor of safety, margin of
safety (Solidworks simulate) --> derived results (HyperView) Model > Output > Process --> create
envelope loadsteps (HyperView) --> output set.

• Added special code to process extremely small circular and circular tube cross sections that does
not depend on the current Parasolid Scale Factor.

Analysis Set Manager

• ABAQUS Analysis Manager and *STEP Import: Femap version 2401 updates the ABAQUS analysis
interface to support *STEP import functionality, and additional improvements in the Analysis Set
Manager for the Abaqus solver.

The Analysis Set Manager for the ABAQUS solver user interface is enhanced so ABAQUS
terminologies are used throughout. For instance, “Global Requests and Conditions” is changed
to "Initial Step”, and “Cases” are changed to “Steps”. The tree structure for an ABAQUS analysis will
appear considerably different from previous versions of Femap.

The Initial Step defines the permanent Boundary Conditions (zero boundary conditions). The
Boundary Conditions dialog opening from the Initial Step has the following options activated:
Constraints, Initial Conditions, Constraint Equations, Contact Sets, and Glue Sets. These are
applicable at the beginning of the analysis, and will be applied throughout the analysis.

The Cases node of the analysis set is changed to Step which is equivalent to the analysis step
terminology used by ABAQUS. Constraints, Loads, and Connections can be defined in each
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analysis Step. The glue type connections referenced in the initial step cannot be deactivated
and remain active through all the analysis steps.

The Boundary Conditions dialog is modified for the ABAQUS solver so only ABAQUS related
options are activated. When the dialog opens from any of the analysis steps, only the following
options are activated: Constraints, Loads, and Contact Sets. These are applicable for each Step
of the analysis.

• Abaqus Analysis Manager and *STEP import: Initial Conditions, Constraints Equations, Constraints
fields in the Boundary Conditions dialog filter the combo boxes to show only relevant loads and
constraints for the Abaqus solver. changed the default contact set for new creation of analysis set.

• Added for Abaqus Analysis Manager: Optimized the writing of the comment Femap Constraint
Set, and the export of Initial Conditions and Constraint Equations.

• Added for Abaqus Analysis Manager: Creation of a new analysis set also creates an analysis case
with the default settings.

• Added for Abaqus Analysis Manager: When a new analysis case is created for an Abaqus solver,
default the settings of the newly created analysis case.

• Set the Constraints and Initial conditions in Abaqus Analysis Manager to None for the Initial Step
when an analysis set is created.

• Err added for Abaqus import error messages.

• Changed the default for the NLCNTL parameter CRLIMR from 0.0 to 1.0 to follow Simcenter
Nastran 2312 guide.

• Changed the default for the NLCNTL2 parameter CRINFAC from 0.5 to 1 to follow Simcenter
Nastran 2312.

• Added support for NLCNTL Sol 401 Strategy Parameters dialog redesign. Implementation of tabs
and loading and unloading of parameters.

• Changed dialog unloading to only unload some parameters when AUTOTIM is ON to follow new
NLCNTL2 Simcenter Nastran 2312 footnote.

• Added support for Nastran 2312 new Sol 401 NLCNTL parameters RTOLB, NRRFOUT, and STKFRST.

• Added support for writing active group as Portion of Model to Write for LSDYNA and ANSYS
analyses. Echo written group to message window on write.

• Added active group to tree for ANSYS and LSDYNA.

• Added a directory explorer button to the Entity Editor to select an output directory for analysis
sets.
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• Did work for NLCNTL Sol 401 Strategy Parameters dialog redesign. Implementation of tabs and
loading and unloading of parameters.

• Abaqus Analysis Manager improvements: Enhanced the writing of the comment Femap
Constraint Set, and enhanced the export of Initial Conditions and constraint equations.

• Added support for the User Typed in Preference ABASkipStandardBeamShapes. Analysts can enter
a 1, and skip standard sections, and get general sections when exporting to ABAQUS Standard
(Implicit).

Analysis Interfaces

• Sloshing Analysis: Femap version 2401 includes extended support for dynamic analysis with
incompressible fluids. This type of analysis is typically used to simulate fluid filled tanks. The
dynamic behavior of fluid filled tanks is different from the unwetted structure, due to the effect
of the fluid on the structure. Previous versions of Femap included support for modeling the
incompressible fluids as a virtual fluid mass using boundary element techniques (i.e. the “Virtual
Fluid Mass” method). Femap version 2401 now includes support for modeling the incompressible
fluid explicitly as a defined fluid mass with finite elements (i.e. the “Defined Fluid Mass” method).
This capability allows you to compute the elastic modes of the containing structure while
accounting for the Sloshing of a fluid free surface, which cannot be done with the current Virtual
Fluid Mass method.

• Added for Abaqus *STEP Import:

• CompareConstraintSets function modified. It now takes two additional arguments to compare
only constraints, only constraint equations or both.

• Added code to import Constraint Equations and Constraints correctly. Code refactored and
reordered functions. Proper initializations of variables and null check for pointers. Added code
to show error messages to the user if any during *STEP import.

• Modifications to Abaqus export of connections.

• Write "** Femap Constraint Set Equation: <constraint set title>" comment before writing
*EQUATION if a separate constraint set is referred for Constraint Equations in the Initial field. If
the constraint equation is referring "From Constraints Set" then don't write this comment, This
comment is used during Import of abaqus input file to determine if a new constraint set has to
be created or not.

• Write appropriate comments to the input file to support import of activated/deactivated status
of connections.

• Code changes to support successful import of activated/deactivated status of connections.

• Importing Abaqus input file sets the correct title for the analysis set created.

• Improved import of connection sets.
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• Improved the import of activated/deactivated status of connections. Updated the list of valid
headers so that correct error messages are shown in the Messages area.

• Set the contact type to "All" in the initial step of non explicit and to "None" in the initial step of
explicit.

• Set the solve using to Linked Solver when an Abaqus input file is imported.

• Did code refactoring for Abaqus connections enhancement for explicit.

• Added improvements to the error messages shown during Abaqus input file import.

• Updated Femap Load Set in some places: Initialized in Connection and Connection_Prop records
in ABAQUS_Write_CONTACT_PAIR_EXPLICIT function.

• Added support for Nastran 2312 new Sol 401 NLCNTL parameters RTOLB, NRRFOUT, and STKFRST.

• Added support for writing the active group as Portion of Model to Write for LSDYNA and ANSYS
analyses. Echo written group to message window on write.

• Added active group to tree for ANSYS and LSDYNA.

• Added Analysis Set object to the Entity Editor and Data Table/Report Window. The added AmOpt
data type is used to incrementally plot the record to refresh Entity Editor after changes. For
Simcenter Nastran Bulk Data, changed Analysis Set Manager tree item to write active group
information for Portion of Model to Write and echo the group to the Messages window during
preview/solve. Users can clearly see the active group being used to run analysis.

• Added Abaqus Import improvements for importing load sets and constraint sets.

• Resulting from fix PR 10871254: Removed function
OGL_NodalConnectivity::OGL_IsAeroCriteriaVectorID and replaced calls with the new function
CResults::IsAeroResultVector. This function checks to see if the output set is valiud for aero and if
not, prevents aero being valid.

• Added updates to MSC Nastran workflow. No longer prompts the user to save a file name before
analysis.

• Added enhancements to Abaqus Connections Write by activating and deactivating connections in
the step feature.

• Added description for Custom Tool 'Multi Dependent Rigid Check' - 'Nastran USER FATAL MESSAGE
5289'

• Updated to released version of NX Adapter 2312, and updated base PLMXML to maint rollup 4.

User Interface
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• Updated asserts during calculation of client/window rectangle when Window > Toggle Tabs option
is off. Affected - File Save & TouchWnd for toggle tabs off (ME-378981).

• Updated tooltip for View Feature Line command in the View and View Style toolbars.

Meshing

• Added filtering to the Mesh Surfaces property combobox in the Meshing toolbox to only show
viable 2D surface properties. Changed the button in the combo box to open a dialog that allows
property picking on screen. (ER: 10868447)

• Updated CCM Mesh toolkit.

• Updated Surface Meshing with the Body Mesher to honor the "Growth Ratio" input when a user
sizes surfaces/solids for meshing.

Loads and Constraints

• Cleaned up old Output Object initialization that causes Femap to warn with deprecated code.
Enhanced to account for nodal temperates in Other Loads. Checked to see if Body Load Temp was
present, then applied it to all nodes without temp loads.

• Added default arguments for CompareConstraintSet. Constraints set to TRUE and constraintEqu
set to TRUE.

• Refactored code: Changed the order of writing keywords *BOUNDARY, and *EQUATION, and
changed the order of writing keywords *CONTACT PAIR for explicit simulation and *MODEL
CHANGE.

Graphics and Performance Graphics

• Implemented Contour Arrows on Nodes.

• Changed uiOptions to uiArrowOptions for clarity.

• Added fValues to process texture values for contour arrows.

• Added deformation of line contour arrows.

• Added Timing to Thumbnail Generation to prevent missed regen when coming out of thumbnail
drawing.

• Added PG free face into FUGUE if OGL is on to get node visibility correct.

• Added code for traceline in FUGUE.

• Added enhancement to New Picking: When entering a group list of entities, the markers are
reloaded, and when selecting the Previous button, they are reloaded.

Misc
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• Updated Femap to parasolid 36.0.x, including xttoolkit and bodyshop.

• Modified code to avoid debug assert caused by invalid index versus size of m_matchedCommands
CArray.

Command Finder

• Added functionality for opening help and doing online searches for Command Finder queries. A
more user friendly results drop down includes the ? icon for help, and the Search online for...
hyperlink.

• Added code to popup Custom Tools commands dynamically by using codejock's controls instead
of MFC's CMenu class to get control back to Command Finder after Custom Tools command
popups (which was not possible by using CMenu.)

• Added user tools commands to Command Finder search.

• Added DoDelayedDraws().

API

• Added bClear, nShowSetID, and nHideSetID to the feView object to set the group ids in Set
Objects used in the current view for Multi Group Display.

• Added SetMultiGroupListFromSets method to the feView object.

• Added new API which creates static analysis with subcases, specifically for wingpost.modfem in
the Examples.

• Added feCheckCoincidentElemQuick, exactly mimics the existing API function
feCheckCoincidentElem. The new Quick Version corresponds to the GUI Option for Quick
turned on, while the existing function goes through the full check.

Corrections

Analysis Set Manager

• Fixed an issue where *MODEL CHANGE data lines did not write the correct surface names when
Write Entity Titles as Set names is unchecked.

• Corrected an issue where the NLCNTL2 parameter TSCVSC was incorrectly written as "TSVSC" in
Femap versions 2301 and 2306.

• Corrected an issue where a combo box was loading an incorrect string resource. Originally
"Generalized Alpha", now "Modified Generalized Alpha".

• Corrected an issue in graying with Sol 414 specific parameters.

• Corrected the IT2K default in nas write.
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• Corrected an issue where an analysis set restarts if a new analysis set is set to analyze and put in
the queue (PR# 10883134).

• Corrected an issue where geometric bcs is not shown in the drop down of constraint sets of the
Boundary Conditions dialog for Abaqus.

• Corrected an issue with filtering of constraint sets in the Boundary Conditions dialog box.

• Corrected an issue with an error message that should be a warning only. The correction changes
the error message to a warning message. Warning message is only shown if the nonlinear
analysis->Solution Type is set to Transient (PR# 10969396).

• Corrected an issue with Abaqus import/export. If Write All Groups as Sets is turned off and only
one load set exists, then export and import of an Abaqus file does not set the load set in the
analysis step. The fix correctly sets the load set in the analysis step.

Analysis Interfaces

• Corrected an issue with complex convert for Mises, principals. Replaced GetVectorCompute with
GetVectorComputeType and removed else block from DB::GetVectorCompute (PR# 10900912).

• Corrected an issue when there no analysis results by zeroing min and max values.

• Corrected an issue which could cause incorrect syntax on the GPFORCE case control command in
Random Response analysis.

• Resulting from fix to PR 10871254: Removed function
OGL_NodalConnectivity::OGL_IsAeroCriteriaVectorID and replaced calls with the new function
CResults::IsAeroResultVector. This function checks to see if the output set is valiud for aero and if
not, prevents aero being valid.

• Corrected an issue which could occur when attaching to the scd5, is the solution group was not
the first group in the data source.

• Corrected an issue with Abaqus import performance: Reduced the calls to
CFemapAnalysisMgr::Get and CFemapAnalysisMgr::Put to improve performance.

• Corrected an issue in writing ABAQUS standard beam sections: I-Beam output has been updated
to move the beam to its shear center. ABAQUS standard section beams do not have any additional
"offset", the beam is between its node at the beam shear center. Also, a correction was made in
trapezoidal beams where the top and bottom widths were reversed on output.

Licensing

• Corrected an issue with OEM licensing which could cause certain translator entitlements to be
lost during program execution.

Model

• Corrected an issue when writing out Parasolid file with more than one body. Femap was creating
a copy of each body, clearing the ID attributes, but then wrote out the original bodies with ID
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attributes. When importing Parasolid bodies with their Femap ID Attributes intact, ID duplication
could happen. Updated code to correctly write out the bodies without their Femap ID attributes.

• Corrected an issue with the Model > Output > Complex Expansion command (PR# 10789657).

• Corrected an issue with the S being added to the parameter list for
ProcessAllSolidsConnectionRegions but no others.

• Corrected an issue with Output Vector IDs for Plate Membrane Corner Stress Intensities.

• Corrected an issue with averaging of second nodes. Initialized array to zero (Coverity 65325).

• Corrected an issue with complex results when using the Model > Output > Process command (PR#
10878640).

Loads and Constraints

• Fixed a filtering issue of constraint equations, constraints, and initial conditions. The issue was if
the constraints or load definitions are removed so that the loads and constraints do not have an
associated definition, then such type of constraints or loads did not appear in the drop down.

• Corrected an issue with *DLOAD (pressure loads). (PR# 10850246)

• Corrected an issue when Constraints or Loads are set to modify and no constraint or load is
selected for a particular step in Abaqus solver, Export and import of the input file does not set the
constraints or loads to modify but to new.

Meshing

• Corrected an issue with the close button is not working in the Mesh Control -> Interactive
command.

Geometry

• Corrected an issue with invalid return codes inside CGeomIF::Import() when importing geometry
using alternate geometry interface. ATP IDs fixed - 5, 131 - 134 (Import of IGES file format) Known
results for above ATP IDs are banchmarked against Femap 2021.2 version.

• Corrected an issue where CLOAD/DLOAD does not refer the correct NSET/ELSET (PR# 10934763).

• Corrected an issue with the Import of glued connections with Surface to Surface turned on does
work correctly. The surface to surface option is not turned on after import Fixed the above PR:
Surface to Surface option is turned on for glued connection after import (PR# 10930324)

• Corrected an issue when writing out a Parasolid file with more than one body. Femap was
creating a copy of each body, clearing the ID attributes, but then was writing out the original
bodies with ID attributes. When importing Parasolid bodies with their Femap ID Attributes intact,
ID duplication could happen. Updated the code to correctly write out the bodies without their
Femap ID attributes.
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• Corrected an issue with the Translate Surface command not working after undo operation
(ME-349882).

Teamcenter Share

• Corrected an issue with internet interruption when working in Teamcenter Share. The issue will
cause to Femap freeze. This fix is for the status bar appearing despite internet access not being
there (ME-297900).

• (In touch screen system) Mouse cursor would disappear when clicking in the integrated
Teamcenter Share web browser area (ME-326934).

• Corrected an issue in the Teamcenter Login Dialog - Set Focus back to edit-box/combo-box for
failure during dialog input validation.

• Corrected an issue with the file WIN_TCOPEN.

• Corrected an issue with the Teamcenter Share login dialog - Set Focus back to edit-box/combo-box
for failure during dialog input validation (ME-386869).

User Interface

• Corrected an issue where pressing the Reset View button on the Visibility dialog was not resetting
the screen orientation (PR# 10883711).

• Corrected an issue with using Keyboard shortcuts to navigate the menubar (Alt+D+...) when
mouse cursor is located at the location of sub-popup menu (PR #10860875).

• Print the failed check-in/check-out messages in the message box, when those operations are failed
(ME-372010).

• Corrected an issue with Femap was unable to maintain toolbar location in a multi-monitor setup.
Toolbars located on different monitors were shifted to the monitor with cursor pointer on Femap
restart (PR #10850005).

• Corrected an issue where searching help for the "Customize" command in Command Finder shows
no results. Set Femap Commands Guide page as default home page if command has no help
assigned (ME-364452).

Graphics and Performance Graphics

• Corrected an issue where blanked surfaces are drawn when drawing a group containing the
parent solid.

• Corrected an issue with switching between output sets, deformation not updating correctly as it
does not detect a change.

• Corrected an issue with surface backfaces not being controlled by the pView-
>label[PL_ELEM_FILL] flag.
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• Corrected an issue when the force/moment/double ended/headless options were added. Also
removed confusion of headless having no suffix and therefore "looked like" force.

• Corrected an issue with the solid arrow double ended with end reversal for negative values not
working in shaders.

• Corrected an issue with multiple node picks on a single dialog - eg element create and measure
between nodes. In vector deformation mode, for the first node to pick, the deformation is off as
it should be but the incremental plot call for marking, resets the deformation values and causes
nodes to be deformed for the picker.

• Corrected an issue with deformation vector arrow sizes.

• Corrected an issue with casting warnings from the Visual Studio error window.

• Corrected an issue where selection by group is not showing in marking

• Corrected an issue where paste IDs were not showing in marking.

• Corrected an issue with Add (All) Connected Elements so marking does not get lost when
rotating.

• Corrected an issue when using Entity Selection dialog Delete button to remove an entry in the
pick list. The pick markers on the model were not being updated. When using preview, the pick
markers on the model were undisplayed. Fixed in New Picking. Also added "X" symbols to entities
that are picked as exclude.

• Corrected an issue with deformed picking of nodes in OGL and PG (caused by FUGUE addition of
nodes).

• Corrected an issue with labeling constraints on nodes with permanent constraints in some cases
of group displays.

• Corrected an issue where free face was not evaluated correctly for OGL when controlling layer
visibility from the Visibility (ctrl-Q) dialog.

• Corrected an issue with NULL to 0 for clarity to match change from pointer to INT32.

• Corrected an issue where Unified Architecture was not updating the image immediately when
using the toolbar icons to control entity labels. Workaround was to do a ctrl-G after the toolbar
icon.

• Corrected an issue with view visibility based on free edge, free face etc.

• Corrected an issue where nodes location was scaled due to non zero normal[3].
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• Corrected an issue in OpenGL Intel on Intel hardware, where the clipping plane flag did not
function correctly inside shader code. In shader code, we need to roll our own clipping, but Intel
does some odd clipping on each individual label.

• Corrected an issue where Performance Graphics incorrectly uses aero criteria results for elements.
Elements should never show aero criteria or contour results.

• Corrected an issue where graphics could abort due to the add rows dialog of the CTableCtrl
object.

• Corrected an issue where pressing ctrl-A while tracelines were visible, makes the tracelines zero
length. Workaround is to do a ctrl-G.

• Corrected an issue with scaling of flat line arrows when drawn in non shader paths.

• Corrected an issue where solids were not being drawn correctly after the solid layer was changed
(PR# 10929556).

• Corrected an issue with draw mode parameters for lighting.

• Corrected an issue where results are damaged by thumbnail drawing in PG/FUGUE shader code
and VBO code - anything where data is stored on the GPU.

• Corrected an issue where user could not pick elements in New Picking in OGL if Elements are off.
Appeared to cause freeface issues but they were there before.

• Corrected an issue with zero min max values if there are no results. May not handle all cases.

• Corrected an issue in dev where PG would not draw contour/criteria on freeface on shells due to
incorrect change to freeface flags.

• Corrected an issue with surface backfaces not being controlled by pView->label[PL_ELEM_FILL]
flag.

• Corrected an issue with selection by group not showing in marking.

• Corrected an issue with paste IDs not showing in marking.

• Corrected an issue with Add (All) Connected Elements so marking does not get lost when
rotating.

• Corrected an issue with complex animation - was actually PG and OGL that were wrong.

• Corrected an issue where modifying the layer of a solid was not causing the graphics to
regenerate.
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• Corrected issues with geometry load scaling (non shader), and number of primitives emitted
(shaders).

• Corrected an issue where errors have occurred message when reading in a neutral file with no
graphics window open. The model create that occurs before the file is read is then included in the
command processing of error_has_been_called and logs the graphics card OEM and character set
red "errors".

• Corrected an issue that caused OpenGL debug messages to be output (wgl context
not set) when updating geometry (elements on curve for example) that triggered
FUGUE_ReloadGeometryEntities.

Command Finder

• Pressing Alt+Tab does not hide the Search list from the Command Finder (ME-383759).

• Executing Custom tool commands from Command Finder print "Idle" text on the Status Bar
(ME-383121).

• Entering double quote in the Command Finder shows Google link at the bottom of the dialog
(ME-382812).

• Command Finder search list stays as it is, after user presses enter on the command (ME-375427).

• Corrected an issue with the enabled/disabled state of the Status Bar window not being reflected in
Command Finder (ME-379332)

• Corrected an issue when clicking the parent of Command Finder overlaying menu popup item
which leads to crash (ME-369418).

• Disabled combo box commands from toolbar won't pop up when it will be hovered from search
list (ME-372822).

• Command finder pops up the hovered command quickly (ME-372794).

• Corrected an issue with toolbox commands not popping up again, once they are popped up.

• Corrected an issue where the help hyperlink had to be clicked twice to open it successfully
(ME-372026).

• Corrected an issue when hovering over matched toolbox commands. Command Finder would
immediately hide the searched list (ME-371229).

• Corrected an issue with populating location for the Custom Tools & User Tools Code (ME-371224).

• Corrected an issue when clicking on the Model Info pane immediately after clicking on the
Command Finder scrollbar, would not hide the searched list dialog (ME-364354).
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• Corrected an issue with Clipping On command not popping-up when hovering over the label
(ME-369446).

• Command Finder Search remains visible on minimizing the Femap application (ME-366959).

• Corrected an issue where Command Finder search list stays as it is, after user press enter on the
command (ME-375427).

• Corrected an issue with Toolbox commands needed two clicks to open after it has been popped
up (ME-383508).

• Corrected an issue where a search of hidden commands in Command Finder, the pop up appears
randomly on screen (ME-383752).

• Corrected an issue where pressing Alt+Tab does not hide the Search list from the Command
Finder (ME-383759).

• Corrected an issue with retaining current keyword/tooltip of menu and toolbar commands for
XML save. Renamed Description as tooltip in XML.

• Corrected an issue with the application crashing when a click on search dialog, and then on
empty white space on a pane in Model Info pane.

Femap v2306.0003

Updates and Enhancements

PostProcessing

• Added support for the following NH5RDB datasets - ELEMENTAL/STRAIN/
QUAD4_COMP ELEMENTAL/STRAIN/QUAD8_COMP ELEMENTAL/STRAIN/QUADR_COMP ELEMENTAL/
STRAIN/TRIA3_COMP ELEMENTAL/STRAIN/TRIA6_COMP ELEMENTAL/STRAIN/TRIAR_COMP

Geometry

• Enabled IGES export option when points and curves are present in the model but no solid
geometry is. Now exporting points and curves to IGES file when all solid geometries are hidden in
the model.

Teamcenter Share

• Added ReadShareUrl() function to read 'TCShareUrlLink' from registry for provide facility of
set url from outside of Femap.exe(i.e registry) for customer in case url chained by XShare team.
Added preprod url in url list. Replaced production url, connector.exe download url.

Corrections

Analysis Set Manager
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• Corrected issue where an analysis set is skipped when results are loaded manually from the Job
Monitor pane. (PR# 11108319)

• Corrected issue where Femap crashes when the Job Monitor pane is closed and the model is
closed while the jobs are running. Added a NULL check for activeJobMonitorData pointer.
(PR# 11092126)

Graphics

• Corrected issue introduced in 2022.1 MP1 when fixing PR# 10263076 where scaling of contour
arrows was not done correctly - however, fix did not handle negative values correctly and this fix
resolves that issue.

• Corrected issue when drawing stresses on beam cross-sections in screen space was including the
model drawn by Unified Architecture.

• Corrected issue where drawing freebody arrows as solid caused symbols and labels in Unified
Architecture to not be drawn.

Geometry

• Corrected issue when converting Femap curves (mainly arcs/circles) to Parasolid wire bodies. This
code was used in our IGES exporter to export Femap wireframe geometry.

• Corrected issue occurring when exporting Points and Curves to IGES file when options selected on
IGES export dialog. (PR# 11079846)

• Corrected issue where the scale_factor on solids was getting lost after a hole was filled with
the Femap menu command - Solid > Fill Hole. The new code grabs the scale_factor before the
Parasolid call, and then reapplies it after. (PR# 11086301)

• Corrected issue with geometry import code which was consolidated in version 2306 into a new
function. This function was inadvertently clearing the internal geometry scale factor, it was
always 1.0. (PR# 11045022)

• Corrected issue with complex expanded total translation. (PR# 10789657)

Meshing

• Corrected issue where parabolic TRIA6 elements were corrupted after Mesh > Extrude > Element
Face or Mesh > Revolve > Element Face commands.

• Corrected issue in the Body Mesher where entering a Mesh Quality, "Min Tri/Quad Quality" value
outside of the recommended range of 0.01 to 0.1 would cause the Body Mesher to crash.
Updated the values Femap will let one enter to match the 0.01 to 0.1 range.

• Corrected issue where some incorrect code logic was used to handle tolerances and multiple
nodes and curves. Updated code that sets the custom mesh size on curves with existing node
locations to work correctly. (PR# 11050134)

Entities
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• Corrected issue where the CBUSH element in the Entity Editor was prompting the wrong dialogs
from the orientation vector and coordinate system commands. This was only happening in
Japanese localization. (PR# 11084756)

• Corrected issue where using the AddEntitiesOnLayer method of the feSet object was not
adding Text entities on specific layers into the set object. Now also adding mesh points and
kinematic joints. The PR was only in regards to Text entities. (PR# 11084573)

• Corrected issue occurring if Validate is turned on for a Global Ply. User is prompted to update
the material and/or thickness of the plies in any Layups assigned with that Global Ply. This was a
capability that existed in versions prior to version 2301. Now the user will only be prompted if the
Validate check is on.

API

• Corrected issue from Tech Support where any API function with 18 variables. The macro
helper in Femap left off the last variable causing any API to think the wrong number of
entries was being entered. The only impacted the functions feElem.GetAllArray2 and
feProp.PutAllArray.

• Corrected issue where Femap crashed due to API call of feGetElementFacesFromSet. (PR#
11094366)

• Corrected issue with potential crash occurring when using feFileWriteNastran when you do
not have the AnalysisMgrSet created, causing us to use a nullptr object. This occurs when a going
through the old Analysis Control dialog with no Analysis Manager set created.

Femap v2306.0002

Updates and Enhancements

Analysis Set Manager

• NEW: Changed default of NLCNTL2 CRINFAC from 0.5 to 1 to follow Nastran 2312

• NEW: Changed dialog unloading to only unload some parameters when AUTOTIM is ON to follow
new NLCNTL2 Nastran 2312 footnote

Corrections

Loads

• Corrected an issue where CLOAD/DLOAD does not refer the correct NSET/ELSET (PR# 10934763).

Output/Results

• Corrected an issue to recover previous version, as this change causing Total Translation to
disappear (PR# 10900912).
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• Corrected an issue with Von Mises, Principals complex convert (PR# 10900912).

Graphics

• Corrected an issue where modifying the layer of a solid was not causing the graphics to
regenerate (backported from 2401).

Analysis Set Manager

• Corrected an issue where the NLCNTL2 parameter TSCVSC was incorrectly written as "TSVSC" in
2401, 2301, 2306 branches.

• Corrected an issue where a combo box was loading incorrect string resource, originally saying
Generalized Alpha -> now Modified Generalized Alpha.

• Corrected an issue with graying on Sol 414 specific parameters.

• Corrected an issue with IT2K default in nas write.

Licensing

• Corrected an issue with OEM licensing which could cause certain translator entitlements to be
lost during program execution.

User Interface – General

• Corrected issue in the Network License Information dialog box which caused only a single user
to appear in the list of users after clicking the Show Users button, regardless of how many users
were actually using a license.

Femap v2306.0001

Updates and Enhancements

Meshing Toolbox → Geometry Editing

Expanded the functionality of the Meshing Toolbox Geometry Editing command. Added the
Surface/Make Planar Geometry Type option to the Extend Operation. This command takes any
surface and attempts to replace its surfaces with a chosen planar one. For sheet/general bodies,
where the face picked has laminar (free) edges, Parasolid does not support this. Added specific case
support for when one picks an already planar face and attempts to move to a parallel planar face.
Code now detects this and offsets the surface which does work.

PostPocessing

For functional results from the SCD5 which have a complex data type, Femap will now generate
Real, Imaginary, Magnitude, and Phase (angle:0->360) functions for each result.

Miscellaneous

• Updated OEM security to restrict Solver, Solution, Topology and Property type.

• Updated Parasolid VTK and PLMXML.
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Licensing

Cleaned up logging, logic flow and deallocation in Salt.

Corrections

Analysis Manager

• Corrected issue where the Analysis Manager tree was displaying an incorrect number of
optimization limits after deleting a constraint via the Model → Optimization → Limits command
dialog box or the Delete → Model → Optimization command. (PR #10770705)

Interfaces - Simcenter Nastran

• Corrected issues with negative load values for geometry loads on points, curves and surfaces
that use surface normal or curve tangent to define direction. Also added code to remove small
component vectors. Value has to be greater than SUPER_TINY but if drawn as components, each
component has to be greater than SUPER_TINY times the maximum component.

• Corrected issue which prevented a value of '0' from being specified for NLCNTNL2's IA12
parameter (SOL414). The default value was also 1, instead of the correct default of 0.

• Corrected an issue which prevented complex eigenvalue extraction options from being specified
for SOL414 Frequency Response when a non-zero IA12 was specified.

• Corrected issue which prevented eigenvalue extraction bulk data entries from being written to
the input file for SOL414 when a modal subcase with modal options defined was copied and its
analysis type was changed.

• Corrected issue which could cause SOL414 nodal results in the absolute csys to be transformed as
if they were in the node's local csys. SOL414 nodal results are in absolute.

Geometry

• Corrected issue with labelling of boundaries made for surfaces so each surface is labelled with the
boundary ID.

• Corrected issues with negative load values for geometry loads on points, curves and surfaces that
use surface normal or curve tangent to define direction.

• Corrected issue where code that was checking if an curve/edge being projected was actually a
line. For very small curves, i.e. around 0.001, this could return a false positive. Tightened the
tolerance to 1.0E-6 more in line with Parasolid tolerances. (IR# 10833420)

Groups

• Corrected issue where the duplication of node selection occurred when using the Group →
Operations → Select Model command.

• Corrected an issue where "Propertys" was written for List → Group instead of "Properties". (PR#
10805038)
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Model
• Corrected an issue where an entities list needed to be cleared when switching category types

because different categories take different entity types or none at all. The list would remain filled
after selecting More from creating optimization limits. (PR 10760713)

• Corrected issue with the Solid Extend command when two aligned planar faces were selected, the
distance was not calculated properly resulting in an incorrect result.

• Corrected issue causing Follower Forces to not scale properly when using the Model → Load →
Combine command. Also, corrected issue with the File → Rebuild command that caused and
error message to be displayed if using Follower Forces.

• Corrected issue that caused Femap to hang if you used the Model → Merge command to merge
a model that contained one or more Groups generated using the Group → Operations → Select
Model command. (PR# 10777694)

• Corrected crash when bringing a model into Femap v2306 that has contact regions based on
property ID, and the model has elements with no property (eg Rigids).

Model Info
• Corrected issue preventing proper updates to the Entity Editor from the Model Info tree if you first

loaded the Entity Editor with an entity then switched to a different model and clicked the "same"
entity (same entity type and ID). Previously, as long as you switched entities everything updated
properly, the problem occurred only if you immediately clicked the "same" entity.

Graphics
• Corrected issues with fast front picking of curves and symbols (such as non Parasolid points) in
Unified Architecture.

• Corrected issues with fast front picking of geometry when using Unified Architecture.

• Corrected issue where hidden line was not drawn correctly. (PR# 10797791)

• Corrected issue where Intel Hardware drew incorrect lines when in VBO graphics mode for Unified
Architecture. (PR# 10799902)

• Corrected issue in Unified Architecture where the model flickered in and out of shading if shading
was off.

• Corrected issue where highlighting and marking of nodes and elements was not correct when
picking nodes or elements during animation with New Picking.

• Corrected issue where beams drawn with cross-section in a defomed plot, loose their deformation
if you dynamically roateate while front selecting nodes with fast pick visible preference enabled.

• Corrected issue when using New picking with front pick and fast pick visible on - could crash if
dynamic rotation carried out with a selection dialog box active. Needed to get rid of pointer to
FUGUE_Connectivity in FED_Picker and access it from OGL_Window each time in case
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it had been deleted. More important now the FUGUE Connectivity object is allowed to survive
outside picking.

• Corrected issue where boundary surfaces were causing incorrect scaling if an old model was
opened into Femap with a different Geometry units preference set. Workaround is to do a File →
Rebuild.

• Corrected issue where loads and constraints may not be drawn in Performance Graphics if loads
sets or constraint sets have been deleted and then recreated.

• Corrected issue where discrete contour legend text was not being scaled correctly when saving/
copying/printing the graphics region with commands like File → Picture → Save.

Toolbars

• Corrected issue where the user could save unchecked equations (unbalanced parenthesis, etc.) in
the Data Surface Toolbox, causing them to eventually end up in a loop of error messages after
creating loads or when using the Check → Sum Forces command. (PR# 10777233)

Miscellaneous

• Corrected issue where users not displayed in the Help About dialog box correctly. (PR# 10807894)

• Corrected issue in the Database Rebuild routine that was checking GAP elements to make sure
they had an orientation specified. Code was missing the fact that a GAP with no vector or
node orientation could have its orientation called out by a Coordinate System on its connected
property. Updated code to check for this method of specifying orientation.

• Corrected issue with a crash that can happen when switching from Salt licensing.

• Corrected issue which prevents heartbeats from being exchanged with the license server, causing
failed checkouts in certain cases. (PR# 10836240)

PostPocessing

• Corrected issue where running Model → Output → Computed Vectors in Run Now mode using
attached results was causing Femap to not display or list the vectors from the attached results file.

• Corrected issue which prevented solid stress/strain principal stress results from populating after
complex expansion of results.

• Corrected issue where Output Sets for Normal Modes analysis were labeled with their eigenvalue
rather than their eigenfrequency when attaching to the NH5RDB.

Meshing

• Corrected issue where a mesh was being offset on several surfaces. The issue was not in meshing
or the Mesh Control Explorer, but in some geometry code in Femap. Femap checks to see if a
surface is planar, or nearly planar before meshing. If so, we mesh on a plane in lieu of actual
geometry. The two surfaces in question here are nearly planar, and during that check, Femap
recovers the normal vector of the plane. The issue was in recovering the 3-D location in space of
the plane, we were looking at the parametric uv location of 0.0, 0.0. The issue with this geometry

1. Welcome to the Femap Readme

1-46  Femap Readme, Simcenter Femap 2412 Series
© 2024 Siemens



is that the underlying geometric surface under each of these Parasolid faces extends away from
the faces and curves up, and that's where the parmetric location 0.0, 0.0. Updated the code
to find the plane base point at the CG of the almost planar surface, everything now works as
expected. (PR# 10809245)

API Programming
• Corrected issue with the .CalculateSummation2 Method. Code was added in v2301 to check

all the internal Free Body error flags that might indicate there is a problem with the summation.
The error flag for a problem with the Free Body Group was inadvertantly being set, causing
CalculateSummation2 to not return FE_OK.

• Corrected issue with two API functions in the feSurf Object. In both .PutAllArray
and .PutAllAttrArray, a coding error was preventing these functions from working.

• Corrected issue with the .CalculateSummation2 Method. Code was added in Femap v2301
to check all the internal Free Body error flags that might indicate there is a problem with the
summation. The error flag for a problem with the Free Body Group was inadvertantly being set,
causing CalculateSummation2 to not return FE_OK.

• Corrected issue with feViewShow2 where the qAutoscale argument was not being honored if
set to True.

Femap v2306

Updates and Enhancements

Rotor Dynamics (SOL 414) - New for version 2306!
Added support for Rotor Dynamics for Nastran solvers (SOL 414). The Rotor Dynamics SOL 414 has 5
new analysis types:

• SOL 414, 101 - Maneuvers a linear static analysis with rotational forces.

• SOL 414,103 - an Eigenvalue analysis that computes modes of the system at rest.

• SOL 414, 110 - a Complex Modal analysis for finding critical speeds and analyzing stability of the
rotating system.

• SOL 414, 111 - a Harmonic analysis for frequency dependent excitation.

• SOL 414, 129 - Transient analysis.

Gear/Bearing/Fourier Elements and Element Property Types - New for version 2306!
To support Rotor Dynamics (SOL 414), new Element and Element Property types are added. The
Gear element is used for connecting rotors. This property is written out to the GEAR card. The
new Fourier element couples a node on the 3D portion of the model to a target node on the 2D
Fourier axisymmetric portion of the model. The Fourier property maps to the FOU3 card. Finally,
the new Bearing element supports the Nastran PBEAR2 property type. You can define Bearings with
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constant stiffness/mass/damping matrices, or stiffness/mass/damping matrix with rotation-speed/
time/frequency dependent values.

Rotor Dynamics (SOL 414) Entities - New for version 2306!

In addition to the new properties, there are 3 new entity types available for Rotor Dynamics (SOL
414). The Model Info tree has a new Rotor Dynamics branch containing the 3 new entity types: XY
Plot Definitions, Bearing Speed, and Rotation Speed.

The XY Plot Definition entity is used to create a Nastran OUTMGT entry which allows you to generate
Nodal, Elemental, and/or Advanced XY Plots for various types of Rotor Dynamics analysis runs. These
XY Plots appear as Femap functions which can be plotted in the Charting Pane after Results are
loaded.

The Bearing Speed entity maps to a Nastran SPEBE2 entry, and allows you to select the Rotors
(or table) that Simcenter Nastran uses to retrieve the correct speed for Bearing elements. Bearing
elements are dependent on Rotor speed.

The Rotational Speed entitiy is used to specify Rotation Speeds in 3 different forms: As Individual
rotation speeds that writes to a Nastran OMEGA entry. As a Linear Sweep with equally spaced
speeds that writes to a Nastran OMEGA1 entry. Finally, as a Logarithmic Sweep that writes to a
Nastran OMEGA2 entry.

Rotor Dynamics Options and Rotor Assembly Selection - New for version 2306!

There is a new Nastran Rotor Dynamics Options dialog box for the Rotor Dynamics solution
parameters needed for the Nastran ROTORD entry. You can specify the Modeling of the Rotor Speed
as either Constant, Linear, or a Function of a Sweeping Parameter (either Rotor Speed, Frequency
and Time for SOL 414, 110 111 and 129 respectively).

Nastran ROTORD supports up to 10 Rotors which you enter in the new Rotor Modeling Assembly
Selection dialog box. These Rotor Speeds can have either a Constant Multiplier or a Multiplier
defined by a Sweeping Parameter.

Rotor Dynamics Analysis Results - New for version 2306!

Results Data for Rotor Dynamics is stored to a file written in the HDF5 format, which is specific to
Siemens products (the SCD5). For Femap version 2306, Femap is able to interact with the SCD5
file generated by SOL 414 to create both Output Sets & Vectors and Femap Functions for use in
Postprocessing.

Geometry Interfaces

Updated Geometry Interfaces for importing different geometry formats from different CAD systems.
Added support for CATIA V6, Inventor 2023, Rhino 7, and a new feGeometryInterface object for
programmatic access to the capabilities of the File → Import → Geometry and File → Export →
Geometry commands.

All geometry interfaces have been updated with a common Read Options dialog box. The new Read
Options dialog box offers appropriate options for supported geometry applications. Also, the new
dialog box continues to support Read Options from previous versions of Femap via the Alternative
Interface... button.
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ABAQUS Enhancement for Connections
Enhanced support for ABAQUS in order to export Connections. Specifically, or exporting and
importing *CONTACT PAIR, *TIE, *SHELL TO SOLID COUPLING keywords.

Two new options, Adjust and Position Tolderance are added to the Define Connection Property
dialog box on the ABAQUS tab. They are located in the Other parameters section.

You can now toggle between on/off the Adjust parameter and set it to Yes or No. This option is
activated if Connect Type is 0..Contact (i.e. *CONTACT PAIR). It is also activated when Connect Type
is 1..Glued, and Enable Shell to Solid Coupling is turned off (i.e. *TIE). All options in the Other
section are turned off when Connect Type is 1..Glued and Enable Shell to Solid Coupling is turned
on.

In the case where Connect Type is 0..Contact (i.e. *CONTACT PAIR), the Position Tolerance option
is activated only if Adjust is set to Yes or No. If Connect Type is 1..Glued and Enable Shell to Solid
Coupling is turned off, you can turn on Adjust and Position Tolerance independently of each other.

Export Abaqus input files with *TIE keyword along with *CONTACT PAIR, TIED, and import the
Abaqus *SHELL TO SOLID COUPLING keyword. It is important to ensure the first surface in the data
line is an edge-based surface name and the second surface is an element based solid surface name.

Teamcenter Integration
A new option, available in the Sign In To Teamcenter dialog box, allows you to specify multiple
Teamcenter server environments via the Edit Teamcenter Server Environments dialog box. Add,
remove and reorder Server Environments using the controls in the dialog box.

Body Loads
Added support for Simcenter Nastran applied force direction from a Rotational Acceleration Body
load. Added options when defining the Body Load to control which direction you want. A rotational
acceleration setting, Direction of Applied Force is available in the Create Body Loads dialog box
(Model → Load → Body...). This setting has two options: Same as Acceleration and Opposite to
Acceleration.

Multi Step Analysis Options
Updated control options for both Multi-Step Nonlinear Kinematic Analysis and Multi-Step Structural
Analysis. The Multi-Step Global Control Options dialog box is replaced with the Strategy Parameters
(NLCNTLG) dialog box, and the Multi-Step Control Options dialog box is replaced with the Strategy
Parameters (NLCNTL2) dialog box.

API
New and updated API Objects and Attributes

• Added a new feGeometryInterface object to the API commands. It provides programmatic
access to the capabilities of the File → Import → Geometry and File → Export → Geometry
commands.

• Added NasMsNLKGlobalKINI, NasMsNLKGlobalFHMETH, fhpost,
NasBulkFHPOSTVal, NasBulkFHPNST, NasBulkFHPNSTVal,
NasBulkDFREQ, NasBulkDFREQVal, NasBulkRDMTRAK,
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NasBulkRDMTRAKVal, NasAppSpecUseRelativeMethod, NasAppSpecCID,
NasAppSpecDir, vNasRotorRegionSelection, NasRotorRegionSelection,
vNasRotorSpeedMultiplier, NasRotorSpeedMultiplier,
vNasRotorSpeedMultiplierFn, NasRotorSpeedMultiplierFn, NasMsnlkCnt2PRDR,
NasMsnlkCnt2PRDE, NasMsnlkCnt2ISTO, NasMsnlkCnt2IRDY, NasMsnlkCnt2BALF,
NasMsnlkCnt2IA4, NasMsnlkCnt2IA12, NasCaseFHAROn, NasCaseFHAR,
NasCaseFHACOn, and NasCaseFHAC Properties to the AnalysisMgr Object to support Rotor
Dynamics (SOL 414) analysis.

• Added PutOUTMGTSetID, GetOUTMGTSet, ClearOUTMGTSet, PutOUTMGTSet,
PutOMEGASetID, GetOMEGASet, ClearOMEGASet, and PutOMEGASet Methods to the
AnalysisMgr Object to support Rotor Dynamics (SOL 414) analysis.

• Updated the feProp and feElem objects with property values associated with the Rotor
Dynamics (SOL 414) Gear and Bearing elements.

• Updated the API Window so that closing a macro with the "x" on the tab, the Close command
or the Close All command initializes the new macro with the standard Femap startup macro.

• Enhanced the API Programming pane to automatically create the default Femap starting
script in a new window anytime you close the initial windows. Previously a default script was
created, however it did not automatically setup to connect to Femap.

• Updated the Data Surface object and added an AutoEvaluate( ) method that can be used in
place of Evaluate( ) and does not require any arguments. Also, Evaluate( ) can now be
called with the either or both of the geomID and eDataType arguments set to zero to use
the values of those options stored in the Data Surface.

• Added support fort writing PBUSH properties to Nastran with all zero stiffnesses. Model can
then be hand edited later to update stiffness, but will run as-is just like the element wasn’t
there. (ER#10755337)

Pre-Processing

• Enhanced modifying an RBE3 element. If editing the independent node list, the standard
entity select will propagate with already selected nodes if they have the same weight and
DOFs selected.

Meshing

• Updated the Mesh → Between and Mesh → Region commands to automatically delete the extra
mid-face nodes that were previously created but were not referenced by any element.

• Updated the Mesh → Region command to allow area selection of nodes in the starting/ending
regions. Previously, nodes had to be picked in a “path” order so area selection was not normally
feasible. The new capability only works if all selected nodes are along one continuous path of
element edges and only works for planar meshing (Tri/Quad), not solids.
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• Updated the Mesh → Region command to automatically merge/connect the new region with the
selected starting/ending region nodes. Previously, new duplicate nodes were created requiring a
later merge.

Interfaces – Comma Separated

• Updated the detection code for reading comma-separated results files to better detect basic or
extended table formats. If you attempted to create an extended format CSV file from Excel, extra
commas were added to the lines which only have one field in the defined format (like the table
type) and that caused the code to think it was the basic format.

Corrections

Optimization

• Corrected issue which occurred when an optimization limit was created with an entity selection
and selecting to create “More” limits then creating a Weight limit would write the previously
selected entity IDs on the DRESP1 card of the weight type limit. (PR# 10760713)

Output and PostProcessing

• Corrected issue which prevented Von Mises Stress/Strain output on plate elements from being
marked as "not linearly combinable" when recovered from a Nastran Random Vibrartion analysis.
(PR#9452268)

• Corrected issue where deformed arrows are set to 0% of model size and this prevented valid labels
being drawn. Workaround is to set deformation scale to 0.0001%.

• Corrected issue which sometimes caused deformed and contour vectors to be zeroed in the
PostProcessing Toolbox if you chose complex magnitude or invariant vectors.

User Interface - General

• Corrected issue where picking plate element faces in normal picking (not front picking) only
allowed one of a pair of coincident edges to be pickable. For example if element 10 and 11 shared
a common edge, the edge from element 10 was pickable, but the edge from element 11 was not
pickable. With the mouse over element 11, the element 10 edge would be picked.

• Corrected a problem that caused performance issues when using the Global Ply Manager and Ply
Material Manager if they had a large number of entries and you pressed Ok to close the dialog box
(PR#10660440)

• Corrected a problem that caused an unnecessary message saying that it was not possible to
compute the Explicit Time Step because needed material properties were not available. This
happened when using the selector to choose Tet elements that referenced materials with no
density when the Entity Editor was open. The message is no longer produced although the
Explicit Time Step will still be 0.0 if density is 0.0. (PR#10703821)

• Enhanced the Model->Merge and Copy/Rotate/Reflect commands when using Offset
Renumbering. Previously, the requested ID offset was updated if any entities existed in the
destination ID range even if there were gaps in the IDs of the entities being copied that would
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have prevented any ID "collisions". Now, individual entities are checked, and the ID offset is only
updated if the IDs are actually incompatible with the offset. (PR#10735075)

• Corrected a problem that left functions undeletable unless you did a File->Rebuild if you created
them by copying a function that was already referenced from the Model Info tree context menu.
The problem could also occur if you used the Function API object and saved a copy of a referenced
function to a new ID.

• Corrected issues to ensure Functions were appropriately deletable if they had been referenced on
Spring/Damper properties which were later modified or deleted.

• Corrected a problem that allowed the possible specification of rigid elements with no specified
degrees of freedom.

• Corrected a problem that caused the reference to a Layer ID on Mesh Points to not be renumbered
when Layers were renumbered. This caused the original Layer ID to be recreated. (PR#10637457)

• Corrected a problem with some message boxes that caused the highlighted default button to be
different than the button that had focus when the message is initially displayed. Clicking on a
button always worked properly, however choosing a button with the keyboard was confusing.
(PR#10760511)

• Corrected issue where "Change Button Image" menu item of a User Command was grayed out. (PR
10628691)

Aeroelasticity

• Corrected issue where deleting aero panel with overlapping panel boxes (not valid but can be in
the model until resolved) leaves incorrect graphics on remaining aero panel. Workaround is to
"/File /Rebuild... Yes".

Graphics and Performance Graphics

• Corrected issue where screen entities (like view legend, post titles, contour legend) are currently
active, post processing toolbox could undo any changes made.

• Corrected issue where multiple models are not regenerated correctly when switching between
Performance Graphics and not Performance Graphics.

• Corrected issue where combined boundary condition set and combined load set were not cleaned
up correctly if drawing in Performance Graphics.

• Improved performance of dynamic rotation for models with an extremely large number of
properties (such as a property per element).

Model Info Tree

• Corrected a number of problems that impacted the "Show/Hide Reverse", "Show SelectedOnly",
"Show All", and "Hide All" blanking commands on the context menus of the Model Info tree if the
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branch of the tree you were updating contained more than the maximum number of displayed
entites and therefore showed Next/Prev options.

• Corrected a problem that caused Load Definitions to disappear from the Model Info tree if you
renumbered Load Sets. The Load Definitions were not deleted, they simply were no longer
included in the tree. This problem only occurred in V2301 and simply reloading the tree brought
them back. (PR#10614667)

• Corrected a problem that prevented proper updating of the Entity Editor from the Model Info
tree if you first loaded the Entity Editor with an entity then switched to a different model and
clicked the "same" entity (same entity type and ID). Previously, as long as you switched entities
everything updated properly, the problem occurred only if you immediately clicked the "same"
entity.

Meshing

• Corrected a problem with the Mesh->Bodies command that did not allow Mesh Points to be
honored if you chose the "All Geometry" mesh associativity option. This problem also impacted
the mesh sizing around small holes and features and on surfaces with small radii of curvature.

Elements – Laminates

• Corrected issue that caused performance issues when using the Global Ply Manager and Ply
Material Manager if there were a large number of entries and you pressed Ok to close the dialog
box. (PR#10660440)

Interfaces – Nastran ( All Nastrans )

• Supported writing and reading Layup titles to Nastran files for laminate plates and solids.
(ER#10622362)

• Corrected issue that prevented Invariants/Von Mises/etc from being computed in Nastran Result
Sets that were read from OP2 files when that Result Set also contained results on Cohesive
elements. (PR#10734192)

• Corrected issue with reading Nastran scalar point springs to ground (CELAS1/CDAMP1/CELAS3/
CDAMP3) ... previously referenced an uninitialized degree of freedom variable.

• Corrected issue where if a Femap model filename contains an apostrophe “ ‘ “ Nastran job fails. (PR
10724856)

• Corrected issue where f06 file cannot be deleted when a Nastran analysis fails. (PR 10695216)

• Corrected issue where the Tools → Check → Sum Forces command gives incorrect (negative)
results compared to Simcenter Nastran. Simcenter Nastran changed the direction of the applied
force from a Rotational Acceleration Body load. The correction is due to this Simcenter Nastran
convention change. (PR#10627578)

Interfaces - ABAQUS

• Corrected issue where Abaqus export does not write NSET/ELSET for all the Loads. Also, does not
write CLOAD AND DLOAD cards for all the loads correctly. (PR 10651937)
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• Corrected issue where Abaqus export does not write data lines for *BOUNDARY when same
constraint set is used in consecutive cases/steps. (PR 10696329)

• Corrected issue where Abaqus export does not write correct NSET when a BC is applied on a curve
or a surface. (PR 10671128)

API Programming

• Corrected issue which caused the API property DialogAutoSkipMsg to not work properly and
still display questions/messages when they were not desired.

Import/Export

• Corrected issue which could occur if you exported a Femap Neutral File to a version prior to
V2020.1 from Femap V2020.1 or greater and them model contained attached results. In some
cases, when the Neutral File was imported, the results were corrupted and could be displayed
incorrectly. This was cleaned up if you detached and reattached the results file, but in its initial
state it could be incorrect. (PR#9960228)

• Corrected issue that could occur if you exported a Femap Neutral File to a version prior to
V2020.1 from Femap V2020.1 or greater and them model contained attached results. In some
cases, when the Neutral File was imported, the results were corrupted and could be displayed
incorrectly. This was cleaned up if you detached and reattached the results file, but in its initial
state it could be incorrect. (PR#9960228)

Femap v2301.0004

Updates and Enhancements

Analysis Set Manager

• NEW: Changed default of NLCNTL2 CRINFAC from 0.5 to 1 to follow Nastran 2312

• NEW: Changed dialog unloading to only unload some parameters when AUTOTIM is ON to follow
new NLCNTL2 Nastran 2312 footnote

Corrections

Analysis Set Manager

• Corrected an issue where the NLCNTL2 parameter TSCVSC was incorrectly written as "TSVSC" in
2401, 2301, 2306 branches.

• Corrected an issue where a combo box was loading incorrect string resource, originally saying
Generalized Alpha -> now Modified Generalized Alpha.

• Corrected an issue with graying on Sol 414 specific parameters.

• Corrected an issue with IT2K default in nas write.

1. Welcome to the Femap Readme

1-54  Femap Readme, Simcenter Femap 2412 Series
© 2024 Siemens



Graphics

• Corrected an issue where modifying the layer of a solid was not causing the graphics to
regenerate (backported from 2401).

Output/Results

• Corrected an issue to recover previous version, as this change causing Total Translation to
disappear (PR# 10900912).

• Corrected an issue with Von Mises, Principals complex convert (PR# 10900912).

Licensing

• Corrected an issue with OEM licensing which could cause certain translator entitlements to be
lost during program execution.

Femap v2301.0003

Corrections

Interfaces - Simcenter Nastran

• Corrected issues with negative load values for geometry loads on points, curves and surfaces
that use surface normal or curve tangent to define direction. Also added code to remove small
component vectors. Value has to be greater than SUPER_TINY but if drawn as components, each
component has to be greater than SUPER_TINY times the maximum component.

• Corrected an issue which could cause Femap to crash when writing loads for a dynamics solution,
and having the Write All Static Load Sets switch be active.

Interfaces - ABAQUS

• Corrected issue where ABAQUS export falsely issued a warning "advanced geom BC could not
export as boundary sets". (PR 10659520)

Geometry

• Corrected issue with the Solid Extend command when two aligned planar faces were selected, the
distance was not calculated properly resulting in an incorrect result.

• Corrected issue where code that was checking if an curve/edge being projected was actually a
line. For very small curves, i.e. around 0.001, this could return a false positive. Tightened the
tolerance to 1.0E-6 more in line with Parasolid tolerances. (IR# 10833420)

Graphics

• Corrected issue where Intel Hardware drew incorrect lines when in VBO graphics mode for Unified
Architecture. (PR 10799902)

• Corrected issue in Unified Architecture where switching out of Performance Graphics removes
geometry based loads until a Ctrl-G is keyed in. Also, when reading a neutral file with geometry
loads, geometry would not show until a Ctrl-G is keyed in.
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• Corrected issue where a hidden line was not drawn correctly. (PR 10797791)

• Corrected issues in fast front picking of curves and symbols (such as non-Parasolid points) in
Unified Architecture.

• Corrected issue where highlighting and marking of nodes and elements was not correct when
picking nodes or elements during animation with New Picking.

• Upgraded JT Open Toolkit to 11.4.1

• Corrected issue in Unified Graphics where blanking from the View Quick Options dialog box
(Ctrl-Q) was not applied immediately.

• Corrected issue where loads and constraints may not be drawn in Performance Graphics if loads
sets or constraint sets have been deleted and then recreated.

Miscellaneous

• Corrected issue where an entities list needed to be cleared when switching category types
because different categories take different entity types or none at all. The list would remain filled
after selecting More from creating optimization limits. (PR 10760713)

• Corrected issue in the Database Rebuild routine that was checking GAP elements to make sure
they had an orientation specified. Code was missing the fact that a GAP with no vector or
node orientation could have its orientation called out by a Coordinate System on its connected
property. Updated code to check for this method of specifying orientation.

PostPocessing

• Corrected issue where running Model → Output → Computed Vectors in Run Now mode using
attached results was causing Femap to not display or list the vectors from the attached results file.

• Corrected issue with reading results for composites from the NH5RDB which occured for smaller
results datasets.

• Corrected issue (reported from Blas) where running computed vector with attached results
was causing Femap to not display or list the vectors from the attached results file.
Femap_MarknonlinearVectors was looping through all vectors and messing with the vector
header to say they were in the DB. Same thing with Femap_AssignVectorComponents, but
really should be Femap_AssignComputedVectorComponents.

• Corrected issue where Output Sets for Normal Modes analysis were labeled with their eigenvalue
rather than their eigenfrequency when attaching to the NH5RDB.

Meshing

• Corrected issue where a mesh was being offset on several surfaces. The issue was not in meshing
or the Mesh Control Explorer, but in some geometry code in Femap. Femap checks to see if a
surface is planar, or nearly planar before meshing. If so, we mesh on a plane in lieu of actual
geometry. The two surfaces in question here are nearly planar, and during that check, Femap
recovers the normal vector of the plane. The issue was in recovering the 3-D location in space of
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the plane, we were looking at the parametric uv location of 0.0, 0.0. The issue with this geometry
is that the underlying geometric surface under each of these Parasolid faces extends away from
the faces and curves up, and that's where the parmetric location 0.0, 0.0. Updated the code
to find the plane base point at the CG of the almost planar surface, everything now works as
expected. (PR# 10809245)

API Programming

• Corrected issue with the .CalculateSummation2 Method. Code was added in v2301 to check
all the internal Free Body error flags that might indicate there is a problem with the summation.
The error flag for a problem with the Free Body Group was inadvertantly being set, causing
CalculateSummation2 to not return FE_OK.

• Corrected issue with two API functions in the feSurf Object. In both .PutAllArray
and .PutAllAttrArray, a coding error was preventing these functions from working.

Femap v2301.0002

This Femap maintenence pack contains the following changes:

Analysis Manager

• Corrected issue which caused the Add/Update buttons in the Solution Frequencies tab of the Nastran
Dynamic Analysis dialog box to deactivate a separate solution frequency when one was added or
update.

• Corrected issue which prevented the Check All button in the Solution Frequencies tab of the Nastran
Dynamic Analysis dialog box to not work correctly for subcases. "

Analysis Monitor

Corrected issue in the Analysis Monitor where a .f06 file may remain locked when a Nastran job fails.

Interfaces - FEMAP Neutral

Corrected an issue which prevents the ID of the mesh sizing propagation selection list from being
migrated when reading in a neutral file with an ID offset defined.

Interfaces - Simcenter Nastran

• Corrected issue which prevented SOL 401's ADJUST parameter on the BCTPARM card from being
exported, and also greyed its edit control after editing. (PR# 10668728)

• Corrected issue which caused GROUP bulk data entries referenced by ELAR bulk data entries to in
include entries for previously written GROUPs. (PR# 10676386)
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• Corrected issue which prevented ELAR element references from being correctly updated when a
selection list was used to select the elements.

• Corrected issue where the counts of ELAR and Flexible Slider entities in the model were not being
updated on a database rebuild.

• Corrected a number of issues writing parameters for NLCNTL.

Interfaces - MSC Nastran

Corrected an issue which prevented results data from attached NH5RDBs from being loaded correctly
when post-processing if the attached file was reloaded.

Interfaces - ABAQUS

• Corrected issue where load definitions may have been skipped when exporting the input file. (PR#
10651937)

• Corrected issue where *BOUNDARY data lines were improperly written when constraint sets were
used in consecutive steps/cases.(PR# 10696329)

• Corrected issue Constraint defs on curves and surfaces are not exported correctly as NSETs. (PR#
10671128)

• Corrected issue where duplicate Constraint definitions were exporting NSETS inconsistently when
Write All Groups as Sets is checked.(PR# 10592496)

Computed Vectors

• Corrected issue which prevented shear panel average shear force from being computed when
Attaching to results files.

• Corrected issue editing an existing User Defined API Computed Vectors where Femap would create a
new one.

• Corrected issue When editing User Defined API Computed Vectors where the dialog box would not
initialize properly.

Teamcenter Share

• Corrected issue updating the status when a user saves the file in Teamcenter.

• Corrected issue with XShare webview dialog box when touch screen is enabled which caused
problems selecting controls.
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API Programming

• Added Suppressshortedges argument on feMeshSizeSurface2.

• Corrected issue setting the EvalAlways API property of the Group object.

• Corrected problem with feSurfaceRuled which caused the method to fail when using composite
curves.(PR# 10660833)

Femap v2301 MP1

Updates and Enhancements

Interfaces - Simcenter Nastran

Added support for the Subspace iteration eigenvalue extraction method in the NASTRAN Modal
Analysis dialog box as support was added in Simcenter Nastran 2212. Previously, this option could
not available to select because it was not supported.

PostProcessing

• Added support for attaching to MSC Nastran NH5RDBs created using the 2019.0 Schema.

• Added support for the NODAL_GRID_FORCE, ELEMENTAL_STRESS_GAP_NL,
ELEMENTAL_STRESS_BEAM_NL, and ELEMENTAL_ENERGY_STRAIN_ELEM NH5RDB Datasets
for MSC Nastran.

Corrections

Graphics - Unified Architecture

• Corrected issue when using the Project Curve operation in the Geometry Editing tool of the
Meshing Toolbox, other operations in the Meshing Toolbox, and other commands throughout
Femap which caused Femap to exit unexpectedly.

• Corrected an issue where points were not pickable using the Geometry → Curve - From Surface
→ Split At Locations command if they were created using the Modify → Break → At Location
command until the view was regenerated.

• Corrected an issue where Snap to Point did not work for points created using the Geometry →
Point command (PR# 10600669).

• Corrected an issue where geometry-based loads and boundary conditions were not blanked
correctly with the corresponding geometry.

• Corrected an issue where coordinate systems were not drawn in groups.

• Corrected an issue where coordinate systems were not always being drawn shaded.
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• Corrected an issue where geometry-based loads with their Direction defined by Vector, Along
Curve, Normal to Plane, or Normal to Surface in the various Create Loads dialog boxes were not
being drawn correctly.

• Corrected an issue where surfaces and curves could be picked in a group if they were part of a
solid/volume in the group but not actually in the group themselves. In this situation, they should
not have been pickable.

• Corrected issue where facets were not being drawn on the faceted surfaces of Convergent Bodies
(i.e., surfaces defined by facets and not by NURBS).

• Corrected issue where individual surfaces in boundary surfaces, individual curves in combined
curves, and individual points internal to boundary surfaces were not highlighted when
attempting to select the appropriate entity type.

• Corrected an issue which required the Window → Regenerate command (Ctrl-G hotkey) to be
used after toggling the Filled Edges option found on the View Style icon menu on both the View
and View - Simple Toolbars.

• Corrected an issue which could occur when switching from View Visible Layers Only to View
All Layers using the context-sensitive menu for Layers in the Model Info tree, or switching from
View Multiple Layers to View All Layers on the Layer tab of the View → Visibility command
which caused the view to not be updated as expected (PR# 10625668).

Graphics Overall

• Corrected an issue when using Front Pick to select an element face which cased the face to
remain highlighted in the graphics window when the mouse moved outside the model.

• Corrected an issue where updated curves was not being drawn correctly. For instance, this could
occur when using the Modify → Scale → Curve command. (PR# 10616425).

Geometry

• Corrected an issue with splitting curves introduced in Femap version 2301. All commands and
other functionality where curves were split at a point now function as they did in previous
versions of Femap.

• Corrected an issue where the reference to a Layer ID on Mesh Points was not renumbered when
Layers were renumbered resulting in the original Layer ID being recreated (PR#10637457).

User Interface - Dockable Panes

Model Info tree

• Corrected issues impacting the Show/Hide Reverse, Show Selected Only, Show All, and Hide
All commands on the context-sensitive menus for the Visibility check boxes available for
multiple entity types in the Model Info tree. If the branch of the tree being updated contained
more than the maximum number of displayed entities, thus is showing the Next/Prev options,
these commands might cause the check boxes to show the wrong state of visibility for
entities. In particular, Show/Hide Reverse almost never worked as expected.
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• Corrected an issue that caused Load Definitions to disappear from the Model Info tree if Load
Sets were renumbered. The Load Definitions were not deleted, they simply were no longer
included in the tree. This problem only occurred in v2301 and could be rectified by reloading
the tree from the model (PR#10614667).

Analysis Monitor and Analysis Queue

• Corrected an issue which caused the Elapsed Time field in the Analysis Monitor Pane to not
update until the analysis completed (PR# 10598237).

• Corrected an issue where the state of the INREL bulk data was not accurately reflected in the tree
structure of an Analysis Set within the Analysis Set Manager (PR# 10591068).

Interfaces - Femap Neutral

Corrected issues which caused data for Element Monitor Points to be written incorrectly to the
neutral file in all but very specific circumstances. Once the data was written incorrectly, which could
occur using v2022.2 (up to MP 3) or v2301, the neutral file could not by imported correctly into
any version of Femap which can read Element Monitor Point (MONPNT2) data from the neutral file,
including v2022.2 MP 4 and v2301 MP 1. Even though v2022.2 MP 4 and v2301 MP 1 now write
the Neutral file correctly, those files can only be imported properly into 2022.2 (MP 4 and above)
and 2301 (MP 1 and above), as 2022.2 (MP 3 and below) and 2301 both also have an issue reading
the properly formatted Neutral File.

Interfaces - Simcenter Nastran

Corrected issue which would incorrectly write certain entries to input file when attempting to use
the Subspace option in the NASTRAN Modal Analysis dialog box for a Model Frequency Response
analysis (PR# 10621489).

Meshing

• Corrected issue which allowed creation of a Rigid element with no DOF specified when using the
RBE2 tab in the Define RIGID Element dialog box.

• Corrected an issue with the Mesh → Bodies command that did not allow Mesh Points to be
honored when the All Geometry option was selected in the Mesh Associativity section on the
Geometry tab. This issue also impacted the mesh sizing around small holes and features and on
surfaces with small radii of curvature.

Output and PostProcessing

• Corrected issue which could cause incorrect vectors to be indexed when attaching to a MSC
Nastran NH5RDB with composites results and multiple domains (Output Sets).

• Corrected issue with post-processing where results for different domains (Output Sets) from an
MSC Nastran NH5RDB were not collected correctly.

• Corrected issue which prevented the functionality of the Merge tab in the Model → Output →
Process command from fully merging output when selected vectors had components.

• Corrected issue which could cause Femap to exit unexpectedly if an attached SCD5 file contained
“SCBucklingMode” legend information.

Femap v2301 MP1

Femap Readme, Simcenter Femap 2412 Series  1-61
© 2024 Siemens



• Corrected issue which caused contact forces, which Nastran already returns in the “Basic”
coordinate system, to be transformed to “Basic” from the nodal output CSys, leading to incorrect
results.

• Corrected issue when attaching to Nastran output files containing results for laminate elements
created by a nonlinear analysis, where output vectors were only created for a subset of plys for
some laminate elements (PR# 10521948).

Groups and Layers

Corrected an issue that caused the reference to a Layer ID on Mesh Point entities to not be
renumbered when Layers were renumbered, resulting in the original Layer ID being recreated any
time the database was rebuilt, including after using the File → Rebuild command (PR# 10637457).

Documentation and Help

Corrected an issue where the Analysis Program Interfaces section of the User Guide did not show
the currently supported version for various solvers, which are 2021 for ABAQUS, 2021 R2 for ANSYS,
2021 R2 for LS-Dyna, and 2212 for Simcenter Nastran (PR# 10621301).

API

Corrected issue with Info_Orient… calls which set options in the Current Output Orientation
dialog box used to set the “From” orientation accessed by various commands to specify
output transformation options in the current model. Also, corrected the same issue with the
Pref_Orient… calls which set default values for output orientation for the various commands
which transform output. In both cases, these properties were unable to be set to the value of 3 in
previous versions.

Femap v2301

Updates and Enhancements

Teamcenter Integration - New for version 2301!

Added support for direct integration with Teamcenter so Femap files can be managed via the
Teamcenter Environment and is accessed by using commands on the Teamcenter sub-menu found
on the new PDM menu. This new functionality includes check-in and check-out from the Teamcenter
Rich Application Client (RAC), along with the ability to import assemblies of individual JT geometry
files stored within the Teamcenter environment as an assembly.

Command Finder - New for version 2301!

Added Command Finder functionality which allows the user to type keywords in to a Search
Commands field which then displays the full menu path to each command related to the keywords.
Once the commands are displayed, user can then select one from the list to invoke the command.

Connection Properties, Regions, and Connectors

• Added Contact Algorithm drop-down to the Multistep Structural (401) tab of Define Connection
Property dialog box. Also, removed *Closed Gap Tolerance (GAPTOL) value and *No Separation
(NOSEP) value as they are no longer used.
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• Added the *Friction Behavior Selection drop-down, *Critical Slip value, *Friction Param 1
value, *Friction Param 2 value, *Critical Sliding Velocity value, *Frict vs Sliding Velocity drop-
down, *Frict vs Time drop-down, *Frict vs Temp Velocity drop-down, and Remove Small Force
Magnitude Pairs value to the Multistep Nonlinear Options dialog box accessed by clicking the
More Options button on the Multistep Structural (401) tab of the Define Connection Property
dialog box. Also, updated *Adjustment Tolerance (ADJUST) to allow it to be toggled and accept
negative values as well as removed the Stiffness Stabilization value as it is no longer used.

• Added the Normal Modulus Scaling value to the Multistep Kinematic (402) tab of the
Define Connection Property dialog box. Also, added the More Options button and moved the
Regularization Models drop-down and corresponding Value value along with the Normal Reg.
Type drop-down and corresponding Value value to the Multistep Kinematic (402) dialog box
accessed via the More Options button.

• Added the Tangential Contact Stiffness Scale value, Adjust Grid Points value, Enable Contact
Friction boolean, Slide Distance Computation drop-down, Stabilization Damping Option drop-
down, Normal Damping Scaling value, Tangential Damping Scaling value, and Gap Tolerance
Scale Factor value to the Multistep Kinematics (402) dialog box accessed by clicking the More
Options button on the Multistep Kinematics (402) tab of the Define Connection Property dialog
box.

Geometry

Added two new options to the Geometry → Midsurface → Automatic command; Remove Holes
and Keep Untrimmed Midsurfaces, which are both designed to allow more flexibility during
the midsurfacing. Remove Holes simply removes all internal loops (holes) from the resulting
midsurface geometry, while Keep Untrimmed Midsurfaces retains any midsurface geometry which
is found but not trimmed correctly instead of being deleted.

User Interface - General

• Added the PDM menu which is used to access to the new Teamcenter submenu, the Teamcenter
Share submenu (previously accessed via the File → Share submenu), and the References
command (previously accessed via the File → References command).

• Added 8..Fluid and 7..Other as material types which can be selected in the standard entity
selection dialog box when Method^ is set to Type when selecting materials and these types are
now also selected when using Select All when Method^ is set to Type.

• Updated From Node on the Method^ menu of the standard entity selection dialog box when
selecting curves and surfaces to work with geometry created using Femap's Standard Geometry
engine (i.e., non-Parasolid geometry).

User Interface - Toolbars and Icons

• Added the Teamcenter Toolbar which contains icons representing the PDM → Teamcenter
→ Open, PDM → Teamcenter → Import JT Assembly, and PDM → Teamcenter → Save
commands.

• Updated toolbar commands that show multiple different icons so that all instances of those
commands are correctly updated if user places such a command on existing or custom toolbars.
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User Interface - Dockable Panes

Model Info tree

• Added Element Add | Remove to the Simulation Entities branch. The New command on
the context-sensitive menu can be used to create a new Element Add | Remove entity (ELAR
or ELAR2) while the Set command can be used to create a Set of existing Element Add |
Remove entities (ELARADD). The Manage command on the context-sensitive menu opens
the Element Add | Remove Manager, while other commands can be used to Copy, Edit, List,
Delete, or Renumber the selected Element Add | Remove entities or Sets.

• Added new commands to the context-sensitive menu for Analysis Sets. They are Continue
Running Analysis Queue, which offers the ability to run the next job in analysis queue if
previous job failed, Load Results, which loads the results from the Analysis Sets highlighted
in the tree, and Show Analysis Monitor Pane, which opens the Analysis Monitor pane if
it was closed for any reason. Also, updated the Clear Analysis Queue command on the
context-sensitive menu for Analysis Sets, which existed in previous versions, but was updated
to work with the new features of the Analysis Queue.

Meshing Toolbox - Geometry Editing Tool

Updated various tools in the Meshing Toolbox which can be used to move/project Femap points
which also modify curves, surfaces, and solids created with Femap’s Standard Geometry engine
(i.e., non-Parasolid geometry).

Data Table

Updated how Constraint Equations are shown in the Data Table by making columns line up
when nodes reference a different number degrees-of-freedom (DOF) and now showing the ID of
the Constraint Set instead of the selected node.

Interfaces - FEMAP Neutral

Updated Neutral Read and Write for the Femap version 2301 changes.

Analysis Manager

Updated the Analysis Set dialog box by adding a brief description of the type of analysis represented
by an Analysis Set which is now displayed beneath the Analysis Type drop-down. These descriptions
are based on a combination of the selected Analysis Program and Analysis Type and include
information which is likely to be quite useful to users familiar with solver nomenclature.

Simcenter Nastran

Analysis Type = 2..Normal Modes/Eigenvalue (SOL 103)

Updated the NASTRAN Response Spectrum Application dialog box to support new options in the
Method drop-down of the Modal Combination section as well as updating the field to specify
the factor as needed.

Analysis Type = “27..Multi-Step Structural” (SOL 401)

• Updated defaults for Equilibrium Min Factor (EQMFMIN) and Equilibrium Max Factor
(EQMFMAX) in the Multi-Step Control Options dialog box.

1. Welcome to the Femap Readme

1-64  Femap Readme, Simcenter Femap 2412 Series
© 2024 Siemens



• Added the Always Output Results at Last Converged Step (LSTCONV) boolean and updated
the Diagnostic Level (MSGLVL) from boolean to a drop-down to accommodate additional
options in the Solution and Convergence dialog box.

• Added the Tangential Cont Stiff Options (KMODTN) drop-down and the Modal Subcase
Scale (KMODSCL) value to the Contact/Bolt Preload dialog box.

• Added the Adjust Integration Factor (CRLIMR), Max Equivalent Plastic Strain (PLLIM), and
Max Plastic Strain Multiplying Factor (PLLIMF) values to the Creep/Plasticity dialog box.

• Updated the Boundary Conditions dialog box to include an Element Add | Remove drop-
down to specify an Element Add | Remove entity or Set.

Analysis Type = “28..Multi-Step Nonlinear Kinematic” (SOL 402)

• Added the Storage Cycle for Grid Point Results (IA16) value, Storage Cycle for XY
Plotting Results (IA19) value, Ramping Load Factor Interpolation (RFVAR) drop-down,
Free Thermal Expansion (ITHE) boolean, Laws of Excitation Storage (LL2) value, Max
Equivalent Plastic Strain (PLLIM) value, Creep Strain Increment (CRICOFF) value, Adjust
Integration Error (CRLIMR) value to the Multi-Step Control Options dialog box. Also,
updated Enable Inertial in Dynamics (INERTIA) to be a drop-down to accommodate the
additional option and changed default value for Minimum Decrease Ratio (EQMFMIN)
(from 2.1 to 0.476).

• Added the Stiffness Update (KUPDATE) drop-down, Max Time Step Reductions (MAXBIS)
value, Modified Generalized Alpha Param (RHOINF) value, Tangential Contact Stiffness
(KMODTN) drop-down, and Diagnostic Output (MSGLVLC) drop-down in the Solution and
Convergence dialog box. Also, updated the default values for Max Iter (ITMA) from 10 to 20,
Relative Disp Force (PRCQ) from 1.0 to 0.1, and Generalized Scheme Param (TETA) from
0.80 to 0.55

MSC Nastran - All Analysis Types

Updated the NASTRAN Output Requests dialog box by adding the Generate HDF5, With
Compression, and With Input Data options to the Results Destination section.

Analysis Monitor and Analysis Queue

• Updated several aspects of Femap to improve monitoring when analyzing multiple Analysis
Sets at once. There is now an icon which will be displayed to let the user know the Status of
various Analysis Sets in the Analyses section of the Model Info tree. A Green Square means the
Analysis Set is currently running, while a Red Square means the Analysis Set in analysis queue.
Once an Analysis Set has finished running, a Green Thumbs Up indicates the Analysis completed
successfully while a Red Thumbs Down denotes that the Analysis did not run to completion for
some reason.

• Updated the Analysis Monitor pane to update based on the Analysis Set which is Active in the
Model Info tree. To make things easier for the user, the ID of the Active Set is now shown in the
Analysis Monitor and clicking the Load Results button will load the results which were created by
the active set, so long as they exist.

Interfaces - Simcenter Nastran
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Added ability to attach to results which have been stored in a SCD5 file (Siemens DI Software's HDF5
format). There is currently no way to request results in the SCD5 format in the Femap user interface,
so users should only attach to SCD5 files created by the OP2-to-SCD5 file converter provided by
Siemens DI Software.

SEMODES - SOL 103

Added read and write support for the simplified user interface for response spectrum application
runs which includes the RSAPPLY case control command, the RSAPPLY, RSPECTR, and RSPOPT
bulk data entries, and the ability to specify the CQC, DSUM, GRP, and ROSE modal combination
methods.

NLSTEP - SOL 401

• Added read and write support for Element Add | Remove in SOL 401, which includes the ELAR
and ELAROUT case control commands as well as the ELAR, ELAR2 and ELARADD bulk data
entries.

• Added support to read results specifically created by Element Add | Remove functionality,
which are Pre-Born and Removed Elem Flag and Activate-Deactivate Elem Time.

• Added support for various types of Strain results for Axisymmetric, Plane Strain, and Plane
Stress elements.

• Updated support for new items available in the Analysis Manager which are written to or read
from NLCNTL.

NLSTPKIN - SOL 402

• Added support for various types of Strain results for Axisymmetric, Plane Strain, and Plane
Stress elements.

• Updated support for new items available in the Analysis Manager which are written to or read
from NLCNTL2.

Interfaces - MSC Nastran

Added ability to attach to results which have been stored in the HDF5 format file (NH5RDB). What
is included in the NH5RDB-style HDF5 file depends on the options selected in the NASTRAN Output
Requests dialog box, which writes the appropriate value for the HDF5 param on the MDLPRM bulk
data entry.

Interfaces - ABAQUS

• Added support for SHELL TO SOLID CONNECTION for glued contact.

• Added support for 13-node pyramid elements, which are degenerate hexahedral elements.

• Added support for NASTRAN RBE3-like interpolation elements.

• Updated Standard Beam Section to write out for Implicit Analysis, not just Explicit Analysis. Also
corrected issues when reading standard sections from ABAQUS input file.
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• Updated reading of output files to read in Forces for Spring and DOF Spring elements, which are
created using a STRESS request.

Interfaces - ANSYS

• Added the ability to read meshed cross-section for Beams from ANSYS input files and store them
with the appropriate Beam Property so they can later be exported.

• Added support to read in additional ANSYS APDL-style inputs which are often used in input files
created by ANSYS Mechanical (formally ANSYS Workbench) and were not supported in previous
versions.

Interfaces - Geometry

• Added support for NX 2212, Solid Edge 2210, Parasolid 35.0.209, STEP AP203, AP214, and
AP242 (both Ediiton 1 and Edition 2), CATIA V5-6R2014 SP4 (or R24), SolidWorks 2021, and JT
11.2.

• Added support for reading Points in the Catia V4 direct geometry interface.

Laminates (Layups, Ply Materials, and Global Plies)

Updated the Convert to Plys command in the Layup Manager convert child plys that referenced a
Ply Material to identical Ply Material plys that retain their original references. To acctually remove the
Ply Material reference, simply reselect them and use Convert to Plys a second time.

Aeroelasticity

Added an All Boxes option to the Aerodynamic Points section of the Create Aero Spline dialog box,
which automatically selects all aero boxes of the Aero Panel/Body specified in the CAERO ID field. If
user would like to select a subset of the aero boxes from the Aero Panel/Body, choose the Custom
option and specify values for Box1 and Box2 as was done in previous versions.

Simulation Entities

Added the Model → Simulation Entities → Element Add | Remove command, which currently is
only is used to create Element Add | Remove entities (ELAR and ELAR2) and Sets made up of existing
Element Add | Remove entities (ELARADD) for Simcenter Nastran SOL 401. The command opens the
Element Add | Remove Manager dialog box, which can be used to create an Element Add | Remove
entity or an Element Add | Remove Set, as well as edit, renumber, delete, or copy any existing
Element Add | Remove entity or set. In addition, there is a commands to Convert selected ELAR2s
to the appropriate number of ELARs or Combine selected ELARs into as many ELAR2s as needed.
Finally, there is a command to delete all Element Add | Remove entities and sets currently in the
model.

Meshing

• Added the ability for the Body Mesher, accessed either by using the Mesh → Bodies command or
the Mesh → Geometry → Surface command when using the Body/on Mesh option, to recognize
Mesh Points (hard points) created by the Mesh Point Editor.

• Added Midside Nodes tab to the Mesh → Bodies command which can be used to allow projection
of midside nodes towards associated surfaces and allows the user to limit which nodes are
projected based on a user-defined distortion angle.
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• Added an Edge Imprinting section to the Mesh Sizing Propagation Options dialog box which is
accessed by various commands on the Mesh → Mesh Sizing menu or via the icon in the Mesh
Control Explorer pane which controls if a line should be imprinted onto a surface in areas where
small gaps exist because of the imprinting process. What constitues a small gap is controlled by
a tolerance which can be automatically determined based on the overall length of the model box
diagonal divided by 100,000 or user-specified.

• Updated Mesh → Mesh on Mesh command to be able to update line elements connected to
other element types regardless of if the mesh is refined or un-refined. Also, a Line Elements tab
has been added to allow the specification of an Orientation/Offset Deviation Limit Angle Along
Edge value which is used to determine if adjacent line elements should be treated together or
individually during the remeshing process.

• Updated the Mesh → Mesh Control → Size on Solid command by improving the determination
of surface matching when applying linked meshing approaches. In particular, surface matching of
adjacent cross sections of thin walled tubes is now more relaiable (ER# 10536389).

• Updated the Mesh → Geometry Preparation command by adding a confirmation question and
warning message if the Suppress Internal Voids option is selected and any void is much larger
than the specified mesh size. The intention of this update is to prevent accidental suppression of
large void regions, such as the inside of hollow tubes with closed ends.

• Updated the Mesh → HexMesh Bodies command to better match specified mesh sizes in very
specific case where the Size Surface if All Curves Sized option is turned on, all curves on either a
required surface are sized or the All Sized Curves option is turned on, and specified curve sizing is
close to the Target Element Size.

• Updated the Mesh → Editing → Cohesive Meshing command to properly support inserting
Cohesive elements at a location where some portions of the mesh could be missing adjacent
elements over part or the whole area.

Groups and Layers

• Added the Group → Operations → Reduce to Existing command which works much like the
Condense command, but instead of changing to ID rules, the command maintains each rule type
in the original group and only includes entities which currently exist in the model.

• Updated the Group → Operations → Condense command to update the group to use ID rules,
but now the group will only contain IDs of entities which currently exist in the model.

• Updated the Group → Operations → Automatic Add command so it will no longer add entity
IDs to the selected group when existing entities are renumbered, as only the IDs are new, not the
entities themselves.

• Updated the Group → Curve → From Node and the Group → Surface → From Node commands
to work with curves and surfaces created with Femap's Standard Geometry Engine (i.e., non-
Parasolid geometry).

Output and Post-Processing
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• Added the Model → Output → Computed Vectors command which is used to compute results
quantities which may not be calculated by the user's solver. Computed vectors can either be
computed every time results are read, attached, or otherwise created or at any time output sets
exist in the model. Also, the user can choose which vectors to compute from a list of standard
results quantities and/or a list of user-defined results quantities.

• Updated the File → Attach to Results command to be able to select a *.sdc5 file (Simcenter
Nastran's HDF5 file) when File Format is set to Simcenter Nastran or select a *.h5 (MSC
Nastran's HDF5 file) when File Format is set to MSC/MD Nastran.

• Updated the File → Attach to Results command by adding an error message when attempting to
attach to a Comma Separated output file if that file is locked by another application.

• Updated many aspects of post-processing by adding two new options for Data Conversion, Max
Value and Min Value, and renaming two others, Max Absolute Value and Min Absolute Value,
which were known as Max Value and Min Value, respectively, in previous versions to more
accurately indicate how data conversion is being accomplished.

• Updated the List → Output → Summary to Data Table command by adding the ability to create
a Report Style that provides max/min summaries by selected Groups of elements rather than by
Property or Material.

Preferences

PDM - New for version 2301!

Added field to specify the Selection Tools Path directory where API scripts can be stored for
use with the API Selection Tools submenu on the Pick^ menu of the standard entity selection
dialog box.

Graphics

Added a Unified Architecture option to the Graphics Options section which is used to turn
on the new Unified Graphics Architecture. Currently, Points, Mesh Points, Curves, Composite
Curves, Surfaces, Boundary Surfaces, Solids, and Volumes are supported, as are Coordinate
Systems and Geometry-Based Load and Constraints. In a future version, all entities will be drawn
using the Unified Graphics Architecture and all other graphics pipelines will be removed.

Results

• Added the Computed Vectors (from Computed Output Library) section which allows the
selection of a library, by ID, containing Standard and/or User-Defined computed vector types
and which results quantities should be set to Auto Run for new models.

• Removed the Compute Principal Stress/Strain and Compute Averaged Mid Stress/Strain
options from the General Solver Options section, as these preferences are now handled by
the settings in the Computed Vectors (from Computed Output Library) section.

Library/Startup

Added a Computed Output field to the Startup Personal Libraries section which can be used
to specify a full directory path to a Femap library file containing Computed Vector information.
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API

New and updated API Objects and Attributes

• Added the Solid Cleanup Tool (feSolidCleanupTool) Object to the API.

• Added CheckGeometry, MatchModelScaleFactor, RemoveRedundantGeometry,
ShowProgressMessages, EnableAdvancedCleanup, AdvCleanInvalidGeometry,
AdvRemoveSmallFeatures, AdvOptimize, and AdvStitch to select options in Solid
Validation and Cleanup dialog box of the Geometry → Solid → Cleanup command via the
Solid Cleanup Tool Object.

• Added AdvCleanValidGeometry, AdvRepairEdges,
AdvSmoothDiscontinuity, AdvRemoveSelfIntersection,
AdvAllowSurfaceMods, AdvRemoveSpikes, AdvRemoveSpikesTolerance,
AdvRemoveSmallEdges, AdvRemoveSmallEdgesTolerance,
AdvRemoveSmallFaces, AdvRemoveSmallFacesTolerance, AdvRemoveSlivers,
AdvRemoveSliversTolerance, AdvRemoveGashes, AdvRemoveGashesTolerance,
AdvSimplifyGeometry, AdvSimplifyGeometryTolerance,
AdvImproveEdges, AdvImproveEdgesTolerance, AdvMergeSharedGeometry,
AdvReapplyBlends, AdvStitchTolerance, AdvStitchSmoothDiscontinuity,
AdvStitchSmoothDiscontinuityTolerance, and
AdvStitchReplaceMissingGeometry to specify options in the Advanced Cleanup
Options dialog box of the Geometry → Solid → Cleanup command via the Solid Cleanup
Tool Object.

• Added the Computed Vectros (feComputedResultsVectors) Object to the API.

• Added PlateSolidPrincipals, PlateAveragedMid, BeamVonMises,
PlateSolidMaxVonMises, PlateSolidTresca, PlateSolidMohrCoulomb,
PlateSolidMaxNormal, LaminateHill, LaminateHoffmann, LaminateTsaiWu,
LaminateMaxStrain, EnvelopeBeamAll, EnvelopePlateLamPly,
EnvelopePlateLamAll, and EnvelopeSolidAll to specify the Auto Run option for
various results quantities when When To Compute is set to Automatically when Results are
Read or Created using the Computed Vectors Object.

• Added PlateSolidUseCorners and DesignFactorOfSafety to specify an option and
value for the Plate/ Solid Failure Theory Options dialog box when When To Compute is set to
Automatically when Results are Read or Created using the Computed Vectors Object.

• Added NowPlateSolidPrincipals, NowPlateAveragedMid,
NowBeamVonMises, NowPlateSolidMaxVonMises, NowPlateSolidTresca,
NowPlateSolidMohrCoulomb, NowPlateSolidMaxNormal, NowLaminateHill,
NowLaminateHoffmann, NowLaminateTsaiWu, NowLaminateMaxStrain,
NowEnvelopeBeamAll, NowEnvelopePlateLamPly, NowEnvelopePlateLamAll, and
NowEnvelopeSolidAllto specify the Run Now option for various results quantities when
When To Compute is set to Now in Existing Output Sets using the Computed Vectors
Object.
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• Added NowPlateSolidUseCorners and NowDesignFactorOfSafety to specify an
option and value for the Plate/Solid Failure Theory Options dialog box when When To
Compute is set to Now in Existing Output Sets using the Computed Vectors Object.

• Added Element Add and Remove (feElemAddRemove) Object to the API.

• Added title, AltType, NasTYPE, NasGRPID, NasHasAC, NasAC, NasADOpt, NasAD,
NasHasRC, NasRC, NasRDOpt, NasRD, NasSTNFREE, HasElemList, and ElemSetID to
the Element Add and Remove Object.

• Added AllowMeshIntersections, MidsideOntoGeometry, MidsideAngleLimitOn,
and MidsideAngleLimit to the BodyMesher Object.

• Added NasMsnlCntKMODTN, NasMsnlCntCRLIMR, NasMsnlCntPLLIM,
NasMsnlCntPLLIMF, NasMsnlCntKMODSCL, and NasMsnlCntLSTCONV to the Analysis
Case Object to support options for SOL 401. Also, updated NasMsnlCntMsglvl to support a
change from a Boolean to a drop-down in the User Interface.

• Added NasMsnlkCnt2ITHE, NasMsnlkCnt2LL2, NasMsnlkCnt2CRICOFF,
NasMsnlkCnt2CRLIMR, NasMsnlkCnt2PLLIM, NasMsnlkCnt2RHOINF,
NasMsnlkCnt2MAXBIS, NasMsnlkCnt2KMODTN, NasMsnlkCnt2MSGLVLC,
NasMsnlkCnt2IA16, NasMsnlkCnt2IA19, NasMsnlkCnt2KUPDATE, and
NasMsnlkCnt2RFVAR to the Analysis Case Object to support options for SOL 402. Also,
updated NasMsnlkCnt2INERTIA to support change from a Boolean to a drop-down in the
User Interface.

• Added NasGenerateHDF5, NasHDF5WithCompression, and NasHDF5WithInputData
to the Analysis Manager to support options to request HDF5 output from MSC Nastran.

• Added NasMsnlCntKMODTN, NasMsnlCntCRLIMR, NasMsnlCntPLLIM,
NasMsnlCntPLLIMF, NasMsnlCntKMODSCL, and NasMsnlCntLSTCONV to the Analysis
Manager Object to support options for SOL 401. Also, updated NasMsnlCntMsglvl to
support change from a Boolean to a drop-down in the User Interface.

• Added NasMsnlkCnt2ITHE, NasMsnlkCnt2LL2, NasMsnlkCnt2CRICOFF,
NasMsnlkCnt2CRLIMR, NasMsnlkCnt2PLLIM, NasMsnlkCnt2RHOINF,
NasMsnlkCnt2MAXBIS, NasMsnlkCnt2KMODTN, NasMsnlkCnt2MSGLVLC,
NasMsnlkCnt2IA16, NasMsnlkCnt2IA19, NasMsnlkCnt2KUPDATE, and
NasMsnlkCnt2RFVAR to the Analysis Manager Object to support options for SOL 402. Also,
updated NasMsnlkCnt2INERTIA to support change from a Boolean to a drop-down in the
User Interface.

• Added items to pval attributes to support new options on Mutlistep Strucural (401) and
Multistep Kinematic (402) tabs to the Connection Property Object.

• Added ReduceToExisting to the Group Object.
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• Added AutoAssign to the Mesh Point Object.

• Updated ibox1 on the Aero Spline Object to allow a value of -1, which sets the All Boxes
option in the user interface.

New and Updated API Methods

• Added SetTolerances, Dialog, and Cleanup to the Solid Cleanup Tool Object.

• Added Clear, Dialog, GetCountUserDefined, GetUserDefinedInfo,
EnableUserDefined, EnableNowAll, FindUserDefined,
NewUserDefinedAPI, NewUserDefinedCombine, NewUserDefinedEnvelope,
SetUserDefinedVectorIDRange, DeleteUserDefined, and RunNow to the Computed
Vectors Object.

• Added GetComponentSet, ClearComponentSet, PutComponentSet,
GetELAR2Entry, PutELAR2Entry, PutCombination, GetELAR2List, PutELAR2List,
GetCombinationSet, GetCombinations, and PutCombinations to the Element Add
and Remove Object.

• Added ClearJobMonitorData to the Analysis Manager Object.

• Added OnPoint2, AtCoordinates, Clear, and OnSurface to the Mesh Point Object.

• Added HasShape to the Property Object.

• Added SetColumnComponents2 and Save2 to the Results Browsing Object.

• Added HasConsistentSurfaceMesh to the Surface Object.

• Added SetClippingPlane to the View Object.

• Updated CurvesAsSet and SurfacesAsSet on the Point Object to work with curves and
surfaces created using Femap's Standard Geometry Engine (i.e. non-Parasolid geometry).

• Updated SurfacesAsSet on the Curve Object to work with surfaces created using Femap's
Standard Geometry Engine (i.e. non-Parasolid geometry).

New and Updated Global Variables

• Added Pref_UnifiedArchitecture to specify the Unified Architecture option in the
Graphics Options section on the Graphics tab in the Preferences dialog box.

• Added Pref_RenderDebugOGLErrors2 to specify option for the Debug Messages drop-
down in the Advanced/Debug Options section on the Graphics tab in the Preferences dialog
box.

• Added Pref_LibComputedVectorNumber to specify options in the Computed Vectors
(from Computed Output Library) section on the Results tab in the Preferences dialog box.
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• Updated Pref_ComputePrincipal and Pref_ComputeAverageMidResults to specify
the Auto Run option for Plate/Solid Principals and Invariants and Plate Averaged Mid Stress/
Strain, respectively, in the Computed Results Vectors dialog box.

• Added Pref_LibComputedResultsVectors to specify the full directory path for a library
file to use for Computed Output in the Startup Personal Libraries section on the Library/
Startup tab in the Preferences dialog box.

• Added Pref_TCDownloadDir and Pref_SaveTeamcenterInfo to, respectively, specify
the full directory path of a Download Directory and specify the Save Teamcenter Info
option in the Teamcenter section on the PDM tab of the Preferences dialog box.

The following functions have been added or updated:

• feFileReadCatia3

• feFileReadNeutral4

• feFileWriteNeutral3

• feCurveSplitPointToPoint2

• feCurveSplitPcointToEdge2

• feCurveSplitEdgeToEdge2

• feCurveBreak2

• feSurfaceMidAuto5

• feMeshEditingSplit

• feMeshExtrudeElem3

• feMeshExtrudeCurve2

• feMeshRevolveElem2

• feMeshRevolveCurve2

• feGroupReduceToExisting

• feAddUserCommand2

• feLoginToTeamcenter

• feIsUserLoggedInToTeamcenter
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• feOpenModelFromTeamcenter

• feSaveModelToTeamcenter

• feGetCurrentModelPDMInfo

• feGetTeamcenterDatasetInfo

Corrections

Views

Corrected issue that prevented changes to Font and Font Size values for the Label Parameters
option found in the Labels, Entities and Color category of the View → Options command from
being applied to all views even if the All Views option was turned on (PR# 10521803).

Graphics

• Corrected issue with quality of highlighting of text objects.

• Corrected issue where text was not marked properly after selection.

• Corrected issue where geometry-based constraint labels were not controlled correctly by the
Label Group option found on the Groups tab of the View → Visibility command.

• Corrected issue that prevented Femap surfaces (i.e., non-Parasolid surfaces) from showing
direction arrows on the hatching.

• Corrected issue where beam property assigned as a mesh attribute on a curve is not displayed
correctly if there is no actual section and the neutral axis offsets are different at each end of the
property.

• Corrected issue when drawing weld elements defined by projecting onto properties or elements,
as the cylinder in the weld graphics was not drawn of the correct length or correct orientation.

• Corrected issue where convection loads on curves were not drawn correctly.

• Corrected several issues that prevented curve and geometry-based element Heat Flux loads from
being drawn correctly.

• Corrected issue when using a decimal place format for labels with only one decimal place
rounded incorrectly and output a value such as 9.99950 as “1.0” instead of “10.0”.

• Corrected issue where no results was not handled correctly for 8-noded quadrilateral elements
with thickness displayed for nodal contour, which worked as expected in Performance Graphics.

• Corrected issue when using any of the Entity ID options in the View → Advanced Post → Model
Data Contour command, such as Property ID, which caused the incorrect values to displayed
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when Show As was set to Contour, but was correct when Show As was set to Criteria or when
using options in the Discrete Values section.

Performance Graphics

• Corrected issue where free edge display was not controlled correctly by the Label Group option
found on the Groups tab of the View → Visibility command.

• Corrected issue where an extra line was being drawn on any Nastran General Element (GENEL).

Geometry

• Corrected several issues that could occur when checking surfaces for planarity or radius of
curvature. These issues normally impacted only a limited number of surfaces but could cause
failures in both centerline determination and when embedding a surface (PR# 10312102).

• Corrected issue that caused Parasolid to fail and possibly corrupt geometry if the total memory
allocated to Parasolid exceeded 2 GB (PR# 10327799).

• Corrected issue which would cause Femap to exit expectedly when selecting solids and the
geometry was invalid, such as when a solid has more surfaces than curves.

• Corrected issue which caused an ambiguous error message box to appear when attempting
to break a non-Parasolid curve when curve was included as part of a boundary surface. Now,
warning and information messages explaining why the curve cannot be split are sent to the
Messages Window.

User Interface - General

• Corrected issue in the Standard Entity Selection dialog box where if user had chosen the Remove
or Exclude option and then pressed the Show button, the selection mode automatically reset to
Add. Now, the selection mode is not changed. Also, if the user pressed the Clear/Reset button,
the mode did not reset to Add if currently set to Remove, which was incorrect (PR# 10347944).

• Corrected issue when identifying internal and outer loops in geometry when the underlying
surfaces were completely closed, such as a sphere, which prevented loop picking in the Meshing
Toolbox and potentially other issues with sweeping, embedding, and selection.

• Corrected issue that occurred if user used the Select Toolbar to add entities simultaneously to the
Entity Editor and Data Table. Previously, if you had entities loaded and then switched the entity
type, the first selection did not load the correct entity into the Entity Editor. Selections after the
first one following an entity change were correct, but not the first one. If only adding to the Entity
Editor, then it was also always correct.

• Corrected issues which caused certain messages or questions to have the incorrect default button.
Previously, the first button was always the default even though in some cases it was intended that
other buttons should be the default.

• Corrected issue that could occur if user attempted to use File → Save As to save to an existing file
that was not writable, either because it was read-only or open in another program, which would
make the existing file writable.
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• Corrected issue that caused Femap to exit unexpectedly if user was attempting to use the Face
Selection dialog box to choose adjacent element faces and those elements referenced nodes with
very large IDs, on the order of 1,000,000,000 (PR# 10540638).

• Corrected issue where any color ID which was typed into a field which represented a color in the
View → Options command would be overwritten if user clicked the Palette button without first
pressing the Apply button or choosing a different option in the Options list.

• Corrected issue when attempting to pick coordinate systems by node or point which occurred if
both the Fast Picking and New Picking options were turned off on the Graphics tab of the File →
Preferences command.

• Corrected issue which occurred if picking weld elements when using New Picking and the
element was defined by projection to property.

User Interface - Dockable Panes

Meshing Toolbox

Corrected issue when using the Meshing Toolbox to remesh a solid which was meshed with
both solid tetrahedral and triangular shell elements on surfaces where triangular elements
which were not updated by the operation were being deleted instead of retained (PR#
10266065).

Entity Editor

Corrected an issue that prevented updating Load Set information, including but not limited to
the title, in the Entity Editor if the field P the Node ID on the DAREA card for Aerodynamic Loads
was zero. Now, if this field is zero, it is ignored.

Interfaces - FEMAP Neutral

Corrected issue when reading a Neutral file that contained Layups (Block 927) which had no ply
data, which was never possible to do via the user interface, which caused reading of the remainder
of the Neutral File to be skipped.

Analysis Manager and Analysis Queue

• Corrected issue which caused Femap to exit unexpectedly if the MultiSet button was clicked and
the Generate Buckling Subcases option was turned on for a buckling analysis but a different
analysis set was selected.

• Corrected issue which caused only the first analysis set to run when multiple analysis jobs were
submitted and the Automatically Load Results option in the Analysis Monitor Options section
found on the Interfaces tab of the Preferences dialog box was turned off, which caused the user
to have to manually load results of the analysis sets to continue running the next analysis job in
the analysis queue (PR# 9358881).

Interfaces - Nastran

Corrected an issue which occurred when a user selected either 1..Ignore or 2..Replace from the
Existing SPOINTs drop-down in the NASTRAN Create SPOINTS dialog box accessed by clicking the
"…” icon button next to the QSET drop-down in the NASTRAN External Superelement Creation dialog
box which caused SPOINTs to be added to the existing list of SPOINTs instead of ignoring them
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and only using the newly specified SPOINTs when modifying the QSET for use in a Craig-Bampton
Superelement model (PR# 9708048).

Interfaces - Simcenter Nastran

Corrected an issue which caused bolt pre-load diagnostic output parameter (MSGLVLB) to be written
out as contact diagnostic parameter (MSGLVLC) on NLCNTL card for Multi-step Structural (SOL 401)
analyses.

Interfaces - ANSYS

Corrected an issue when writing shear area in y and z of section property for BEAM4 elements
where y and z were switched (PR# 10541141).

Properties

Corrected an issue when modifying a beam property section from the General Section to something
else, then the user pressed Cancel, which resulted in either a partial draw or no draw of the
General Section if the Cross Section Definition dialog box was then entered again without leaving
the command.

Laminates (Layups, Ply Materials, and Global Plies)

• Corrected an issue where visual cues which appear when using the Validate check box in the
Global Ply Manager now toggle as expected.

• Corrected issues which would happen if user typed the ID of a non-existent material into a field
or top-level drop-down control in the Global Ply Manager where the non-existent ID would stay
visible instead of changing to 0..None, which is valid.

• Corrected issue with the Convert to Plys command in the Layup Manager which occurred when
attempting to convert plys from a multi-level child Layup, as it would not delete invalid plys that
were not fully defined.

Aeroelasticity

• Corrected an issue when reading functions from a Nastran input file created by Femap to run an
Aerodynamic Flutter analysis (SOL 145) which caused the titles of functions referenced by the
MKAEROx and FLFACT entries to not be transferred to any function read from the file that was
renumbered during import.

• Corrected an issue when using Custom for the Number Body Elements for an Aero Panel/Body
set to 1..Aero Body which caused a message box to appear informing the user that the Number
of Slender Body Divisions does not match the (Areo Property) Half-Widths, which was erroneous
because the Aero Property was displaying the Number of Slender Body Divisions instead of the
number of Slender Body Elements in the Create Custom Cross Section dialog box.

Meshing

• Corrected an issue when using the Mesh → Mesh on Mesh command that could cause Nodes
that were Loaded or Constrained to be merged with other adjacent nodes even though they were
not in the portion of the model being remeshed (PR# 10506361).
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• Corrected several issues that could occur when checking surfaces for planarity or radius of
curvature which could cause failures in various meshing commands (PR# 10312102).

• Corrected an issue that could occur when attempting to generate some mapped meshes with
a high number of nodes along each edge. In some cases, the mapped mesh could fail and
user would get a free mesh even though the surface had mapped meshable sizing. This was
demonstrated in some cases of a 180-degree circular annulus with mesh sizes of 20 or more
nodes along the edges.

• Corrected an issue that could cause Femap to exit unexpectedly in certain cases when attempting
to mesh surfaces with imprinted curves using the Mesh → Geometry → Surface command and
forced the command to use the Body/on Mesh mesher.

• Corrected an issue with mesh points on the interior of Solids when creating a tetrahedral mesh
where those mesh points on the interior were used even if they were disabled in the Mesh Point
Editor.

• Corrected an issue when using the Mesh → Editing → Split command that could occur if user
chose to split based on certain values for the Warping option.

• Corrected an issue in Mesh → Bodies command that could cause some curves to be ignored even
though they were required. This problem did not normally occur in traditional geometry but was
encountered mostly in faceted geometry/convergent bodies and only happened in cases where a
single curve formed and entire closed loop in a surface and therefore only had one common start
and end point. It also required that adjoining surfaces were somewhat tangent at their common
edges, which in these cases caused the mesh associativity to be incorrect and nodes may not have
been associated with the curves.

• Corrected issue which prevented the Mesh → Editing → Interactive and Mesh → Editing
→ Element Refine commands from correctly processing connection regions referencing line
elements on edges.

Listing

• Corrected an issue where the “EERR0067” error was being generated by the List → Output →
Results to Excel command and sent to the Messages Window when there was no error (PR#
10402215).

• Corrected an issue where some values from the Multi-step Kinematic (402) tab were not listed
when using the List → Connection Property command.

Output and Post-Processing

• Corrected an issue that was introduced in Femap version 2020.2 and beyond with the Model
→ Output → Process command when creating a Linear Combination or RSS Combination, using
the the One or More Selected Output Vectors option with the Combine Each Vector in All
Sets approach, then selected results from multiple Output Sets, as only the vectors from the
first output set were added to the Operations That will be Processed list. The user could work
around this issue by selecting Vectors from each Output Set one set at time, however that would
be time consuming if there were many Sets and it was not the intent of the command.

1. Welcome to the Femap Readme

1-78  Femap Readme, Simcenter Femap 2412 Series
© 2024 Siemens



• Corrected an issue when using Model → Output → Process to create a Linear Combination of
results that caused Thermal and Elastic Strains to be linearly combined rather than recomputed
from the linear combinations of their tensor values. Also, prevented combination of Nonlinear,
Thermal and Elastic Plate Fiber locations at elemental corners.

• Corrected an issue where min/max contour values output in float precision and not double
precision like values in the contour legend. This was an issue when using the View → Advanced
Post → Model Data Contour command to display property IDs with extremely large values.

• Corrected an issue which caused a performance regression when attaching to or post-processing
laminate results stored in a .op2 file (PR# 10510932).

• Corrected an issue which led to incorrect results on rod elements when attaching to a .op2 file
generated by SOL401 or SOL402.

• Corrected issues which caused incorrect population of results for Tension-Only Shell Status,
Cohesive Matl CSID, and Cohesive Matl Rel CSID output vectors when attaching to a .op2 file.

• Corrected an issue when reading vG and vF plots from the Flutter Summary in a .f06 file created
by a flutter analysis (SOL 145) when using the PKNL flutter solution method (PR# 8336578).

• Corrected issue regarding reading flutter results from a .f06 file created by a flutter analysis (SOL
145) when there were multiple aero panels with IDs that were offset more than the previous
panel’s ID plus the number of aero boxes on the aero panel.

JT Files

Corrected an issue that prevented large models being written to multi-result JT files. Also corrected
issue that wrote no results if all stress invariants but one has been deleted and collated, average
with corners options were used for multi-result JT output.

API

• Corrected an issue when using the CalculateSummation2 method of the Freebody Object that
prevented it from returning FE_FAIL if the summation was computed with possible errors.

• Corrected an issue which would cause Femap to exit unexpectedly if using the AddColumn
method of the Data Table Object to add columns to the Data Table if the table already contained
data with a summary table, then user tried to copy the Data Table to the clipboard or use the Send
to Excel functionality.

• Corrected an issue with the GetBoxSet method on the AeroPanel and AeroSpline Objects, as
neither method was filling the set with the proper aero box IDs.

• Corrected an issue where the GetTitleList and GetTitleIDList methods were not working
properly for the Analysis Study, Chart, Chart Data Series, Optimization Relationship (Variable),
Optimization Response (Limits), Optimization Manufacturing Constraints, Monitor Point, Variable,
Global Step, Table Data, Frequency, Discrete Value Set and Mesh Point Objects.

Custom Tools
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Corrected issues with the Custom Tools → Data Table → Get Change Column Width (API script)
that is shipped with Femap to more closely perform the operation described in the Documentation.
Previously it only changed the width of one column, not all columns as documented. Now it
changes all visible columns and allows the user to specify a scale factor (PR# 10385805).

Femap v2022.2 MP 4

Corrections

Graphics

Corrected an issue where subscription licensed Femap had poor dynamic rotation performance. (PR#
10632059)

Simulation Entities

Corrected an issue with renumbering of flexible slider references to driver/sensor nodes.

Analysis Manager

Corrected an issue which could cause crash if the Multi-set command was used on a buckling
analysis set when the Generate Buckling Subcases switch is activated and a different analysis set
was selected.

Interfaces - Femap Neutral

Corrected an issue which could cause a neutral file to be written with a corrupted Monitor Point
block (1280), if the model contained Monitor Points and a MONPNT2 was not the last Monitor Point
or the last Monitor Point was a MONPNT2 but had no selections.

Output and PostProcessing

• Corrected an issue with Nastran OP2 reader where Femap could skip certain composite ply output
for nonlinear analysis. (PR# 10521948)

• Corrected an issue which caused contact forces (which Nastran gives in Basic) to be transformed
to basic from the nodal output CSys, leading to incorrect results.(PR# 10616976)

Security

• Updated JT to 11.3.2

• Updated Parasolid to 34.1.254

Femap v2022.2 MP 3

Updates and Enhancements

Femap and Siemens Digital Exchange (SDEX)

Added functionality so Femap can be installed and have licenses activated through the Siemens
Software Center app.
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Dockable Panes - PostProcessing Toolbox

Added support for selecting Coordinate Systems from a list with filtering options for Freebody
Properties. This is done through a button next to the existing drop-down, which previously brought
up the creation dialog.

Loads and Constraints

Added support for selecting Coordinate Systems from a list with filtering options for Freebody
Properties. This is done through a button next to the existing drop-down, which previously brought
up the creation dialog.

Interfaces - Comma-Separated Tables

Added an error message when attaching to a Comma Separated output file if that file is locked by
another application.

Corrections

Elements

Corrected an issue with the Modify → Update Elements → Midsurface Thickness and Offset
command that occurred if one used it to modify surface elements to match a Solid and the elements
were located on one surface of the Solid rather than in its interior. Previously, some elements might
be updated, while others might not. Now element thicknesses and offsets are properly updated for
all elements. (PR 10497834)

Materials

Corrected an issue which prevented negative Tsai-Wu interaction terms (12, 13, 23) from being
unloaded from the "Ply/Bond Failure" page of the Define Material dialog.

Interfaces

(All Nastrans)

• Corrected an issue which could cause a resource leak when file open operations fail in the
Nastran read translator.

• Corrected an issue which could cause a memory leak when File → Open operations fail in the
Nastran import translator.

MSC Nastran

Corrected an issue which prevented negative Tsai-Wu interaction terms (12, 13, 23) from being
unloaded from the "Ply/Bond Failure" page of the Define Material dialog.

Ansys

• Corrected an error in element selection by element names (ename) when reading an ANSYS
input file (PR 10469023).

• Corrected an error in reading empty second field of NMODIF command of an ANSYS input file.

Simcenter Nastran
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• Corrected an issue which prevented Tension-Only Quad Status results from being correctly read
into Femap.

• Corrected issue where the correct current defaults for certain fields on the NLCNTL bulk data entry
were not being used for SOL 401. Also, corrected issue where not all items were properly grayed
when using the Skip NLCNTL option.

• Corrected issue where the correct current defaults for certain fields on the NLCNTL2 bulk data
entry were not being used for SOL 402. Also, corrected issue where not all items were properly
grayed when using the Skip NLCNTL option.

• Corrected issue which prevented ply membrane-only principal stress angles for shell composite
elements from being read from the OP2.

LS-Dyna
Corrected issue which could cause *ELEMENT_SHELL_THICKNESS to not be properly written to
LS-Dyna input file.

Graphics and Performance Graphics
• Corrected issue where labels on both rigid elements and rigid elements with formulation set to

“1..RSPLINE” were not drawn correctly when specifying a group in the Label section of the Group
tab in the Visibility dialog box.

• Corrected issue where constraint equations were drawn in a group even when they were not in
the group.

Model Merge
Corrected issue where constraint equations were drawn in a group even when they were not in the
group.

Geometry
• Corrected issue to allow for matching of tolerance levels for older versions of
feCurve.IsArc(). PR reported an arc shaped curve that was not correctly identified. (PR
10501008)

• Corrected an issue with the Modify → Update Elements → Midsurface Thickness and Offset
command that occurred if you used it to modify surface elements to match a Solid and the
elements were located on one surface of the Solid rather than on its interior. Previously, some
elements might be updated, others might not. Now element thicknesses and offsets are properly
updated for all elements. (PR#10497834)

Dockable Panes
Model Info

Corrected issue where Analysis Study objects would not populate IDs and Titles using
either .GetTitleList or ,GetTitleIDList.

Output and Post-Processing
Corrected issue introduced in V2020.2 and beyond with the Model → Output → Process
command. If a user choses to create a Linear Combination or RSS Combination along with using

1. Welcome to the Femap Readme

1-82  Femap Readme, Simcenter Femap 2412 Series
© 2024 Siemens



the “One or More Selected Output Vectors” option, is using the “Combine Each Vector in All
Sets” approach, and then selected results from multiple Output Sets, only the vectors from the
first Output Set were added to the “Operations That Will Be Processed” list. A workaround for
this issue was to select Output Vectors from each Output Set individually, one Output Set at
a time, however that would be time consuming if there were many Output Sets and it was
not the intent of the command. The combination that was created was “correct” based on the
operations in the list, but the user had to verify that the list contained everything needed to
create the desired combination.

Meshing

Corrected an issue which prevented Tension-Only Quad Status results from being correctly read
into Femap.

API

• Corrected issue to allow for matching of tolerance levels for the IsArc property on the Curve
Object in older versions of Femap (PR 10501008).

• Corrected issue where Analysis Study objects would not populate IDs and Titles using either
GetTitleList or GetTitleIDList method.

• Corrected issue reading results from the ANSYS *.RST output file when using
feFileReadAnsysResults API call.

Femap v2022.2 MP 2

Updates and Enhancements

Teamcenter Share - New add-on module for version 2022.2!

• Added file download progress indicator when opening ‘stubbed files’ from Teamcenter Share.

• Added message to alert they are saving to a Connector folder without full access when using the
File → Save As command.

• Enhanced user experience by redirecting users to Connector Sign-in Page when connector has not
been started.

User Interface - General

Added “Read-Only” to title of the model tab when read-only files are in Femap.

Interfaces - Geometry

Added support for Parasolid 34.1.188.

API New and updated API Objects and Attributes

• Added SubcaseNotSeqDep to AnalysisCase Object.
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• Added SubcaseNotSeqDep to AnalysisMgr Object (not currently in User Interface).

Corrections

Teamcenter Share - New add-on module for version 2022.2!

• Corrected issue which occurred when using Teamcenter Share files containing foreign language
characters in the file path.

• Corrected issue where all Femap sessions would become unresponsive when performing a
computationally intensive operation in any one of the opened sessions.

Graphics

• Corrected issue where model and contour legend interact depth-wise if the model has text and
text entities are visible.

• Corrected issue when post processing negative integer results. This issue caused the negative
values to be one less, in absolute value, than they should be in contour and criteria displays. For
example, a value of -2 would be displayed as a value of -1.

Performance Graphics

• Corrected issue where deformations for mid-side nodes of parabolic beam elements were not
scaled correctly (PR# 10439546).

• Corrected issue when post processing negative integer results. This issue caused the negative
values to be one less, in absolute value, than they should be in contour and criteria displays. For
example, a value of -2 would be displayed as a value of -1.

Geometry

Corrected issue which caused a local performance regression when saving geometry to the
database, with the severity varying based on the size of the geometry.

User Interface - General

Corrected issue that prevented running multiple API selection scripts or the same API selection script
multiple times from the same occurrence of a selection dialog box.

Interfaces - Femap Neutral

• Corrected issue that was introduced for Version 2022.1 that caused boolean fields in Neutral Files
to be written as integer values, not just 0/1, but could not be read as anything but 0/1. Certain
third\u0002party products store booleans as 255(i.e.-1)/0 and all came out as 0 when reading a
neutral file. This patches Version 2022.1 MP 3 and 2022.2 MP 2 and beyond to again write as 0/1
and read other values and convert to 0/1. It also patches the Version 2022.1 Neutral File converter
to write 0/1.

• Corrected issue that caused rigid interpolation elements (RBE3s) to be converted to rigid elements
(RBE2s) when translated thru Neutral Files. This only occurred when rigid elements had properties
assigned which is invalid, as they normally should not have properties assigned.

Interfaces - Nastran
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Corrected issue when writing Beam Properties that contained Neutral Axis or NonStructural Mass
offsets, which only occurred if the Write Alternate Line Continuation option was turned off on the
Interfaces tab of the Preferences dialog, as it would cause Nastran to terminate with fatal error.

Interfaces - Simcenter Nastran

Corrected issue which prevented a value of “0” from being written to the Nouti field of the TSTEP1
entry when a value of 0 is specified for Output Increment and Output Frequency is set to “Skip
Factor” in the Subcase Time Steps dialog box for SOL 401 and SOL 402.

Interfaces - LS-Dyna

Corrected issue that caused Femap to exit unexpectedly when attempting to read LS-DYNA results
while which contained output on Laminate Elements with more than 14 plies.

Laminates (Layups, Ply Materials, and Global Plies)

Corrected issue that caused opening the Global Ply Manager and the Ply Material Manager to show
poor performance if there was a large number of items. Previously, startup time increased rapidly
as the number of items increased with times of 20-30 seconds to open the dialog with ~1500
items and much longer with more. Now startup is under 1 second for several thousand items and
increases fairly linearly. Also, significantly improved the performance of the dialogs Paste function
and reduced flickering during Paste (PR#10411479).

Meshing

Corrected issue that could occur when attempting to generate a mapped meshes with a high
number of nodes along each edge. In some cases, the mapped mesh could fail and a free
mesh would be generated even though surface was properly size for mapped meshing. This was
demonstrated in some cases of a 180-degree circular annulus with mesh sizes of 20 or more nodes
along the edges.

Output and Postprocessing

Corrected issue which could occur when using the VEC( ) calculator function to compute additional
output vectors using the Model → Output → Calculate command.

JT Files

Corrected issue where midside contour values were not written to JT multi-result files correctly. The
centroid value was written instead, which could lead to poor quality contours in areas which had
high stress variation.

API

Corrected issue that was introduced in version 2022.1 MP 1 that caused a dialog box
to appear and the function to perform incorrectly when using any of the following
API methods: feModifyOffsets, feModifyRadialOffsets, feModifyRadialOffsets2,
feModifyOffsetsToRefPt, or feModifyOffsetsToRefPt2.

Siemens Security Advisory issues

For more information about Siemens Security Advisory issues, see: https://new.siemens.com/global/en/
products/services/cert.html#SecurityPublications.
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• Corrected ZDI-CAN-16973 (PR# 10356693)

• Corrected ZDI-CAN-17276 (PR# 10369244)

• Corrected ZDI-CAN-17284 (PR# 10369249)

• Corrected ZDI-CAN-17289, ZDI-CAN-17292, and ZDI-CAN-17296 (PR# 10369251)

• Corrected ZDI-CAN-17485, ZDI-CAN-17493, ZDI-CAN-17496, ZDI-CAN-17502, ZDI-CAN\u000217506,
and ZDI-CAN-17513 (PR# 10378077)

• Corrected ZDI-CAN-17293, ZDI-CAN-17494, ZDI-CAN-17733, ZDI-CAN-17735, ZDI-CAN\u000217736,
ZDI-CAN-17740, ZDI-CAN-18187, ZDI-CAN-18188, ZDI-CAN-18192, and ZDI-CAN\u000218196 (Non-
PR)

Femap v2022.2 MP 1

Updates and Enhancements

Interfaces - Simcenter Nastran

• Added support for reading results from CROD elements for SOL 401/SOL 402 analyses.

• Added support for reading/writing SOL 401-specific properties (F3, F4) for the shear panel
element available in Simcenter Nastran 2206.

• Added read/write and API support for the new TOQDGAUS and ADTOQDLD parameters for SOL
401 in Simcenter Nastran 2206.

• Updated the default for the STRCONV parameter on the NLCNTLG bulk data entry to align with the
new “Standard Method” default in Simcenter Nastran 2206.

Corrections

Teamcenter Share - New add-on module for version 2022.2!

Corrected issue regarding file selection synchronization in Teamcenter Share dialog for File → Share
Open and File → Share → Import when user switches between project or folder within web
application.

Connection Properties, Regions, and Connectors

Corrected issue which caused settings defined for Connection Properties on dialog boxes called from
the main tabbed dialog to not be recovered when a Connection Property is loaded from a library, or
copied from another Connection Property (PR# 10342816).

Graphics
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• Corrected issue where view axes labels were disappearing if the font size was large and the pull
forward was large (PR# 10312099).

• Corrected issue where single contour arrows were not drawn with the correct length in
non\u0002Performance Graphics (PR# 10343711).

• Corrected issue where surface normal arrows visibility was not being controlled correctly.

• Corrected issue where mesh points, kinematic joints, and joint connectors were not highlighted
in the graphics window when Show when Selected is turned on in the Model Info tree and the
group those entities reside in is selected in the Model Info tree.

Performance Graphics

Corrected issue where performance graphics lines were drawn stippled if body loads were drawn in
the model itself, but not the in the View Axis.

User Interface - General

• Corrected issue when front picking surfaces that are pierced more than once by the picking
vector are not picked correctly when using the New Picking option on the Graphics tab of File→
Preferences.

• Corrected issue which could occur when copying data to the Clipboard and sending data to Excel
from the Data Table, Entity Editor, various other Table-based panes and the API Publish object. The
problem only occurred when copying a large amount of data (thousands of lines), in HTML format
and were running on a multibyte version of Windows like Japanese or Chinese. In that case, some
of the data at the end of the copy could have been lost (PR# 10296289).

User Interface - Dockable Panes - Meshing Toolbox

Corrected issue which could cause the Point to Point, Point to Edge, and Edge to Edge Operations in
the Geometry Editing tool to cause a straight line split to create a 360 degree helical split.

Interfaces - Simcenter Nastran

• Corrected issue where certain values for the STFR parameter on the BCTPAR2 entry were not
exported due to an outdated default (PR# 10280884)

• Corrected issue which prevented the RELC parameter on the NLCNTL2 bulk data entry from being
written unless a non-zero value was specified for DTMAX.

• Corrected issue where the STROUT parameter on the NLCNTLG bulk data entry was written to the
input file when the “-1..Nastran Default” option was selected.

• Corrected issue which allowed mutually exclusive parameters (STFR and TOL) to be written to
the BCTPAR2 card in the Nastran input file if values were specified for both, regardless of the
regularization model selection.

Elements - Slide Line

Corrected issue where incorrect error message issued when validating topology and type for Slide
Line elements.
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Properties

Corrected issue which occurs if Analysis Filtering is turned on, the Autodesk Nastran option is not
selected, and option “5..Use X Stress in Material CSys” is selected for Component Direction, the
Component Direction drop-down would be set to “6..Use Y Stress in Material CSys” after leaving the
dialog then entering it again.

Meshing

Corrected issue that occurred when meshing surfaces that have embedded curves if those curves
connected to the point at the first edge of the surface. In that case, coincident nodes could be
generated unless a node merge was done. In many cases, the coincident nodes were automatically
merged but when meshing a single surface or a single sheet body sometimes merging was not
done, especially from the Meshing Toolbox. This correction prevents the coincident nodes from ever
being created.

Output and Postprocessing

Corrected issue in the Model → Output → Extrapolate command that caused Femap to abort if
all output was located in one or more attached results files. Also improved performance slightly by
skipping Nodal results without loading them even if they were selected. Nodal results were never
extrapolated but previously if Nodal results were selected they would be loaded then discarded (PR#
10283178).

Tools

Corrected issue in Tools → Check → Sum Forces for any loads on Solid element quad faces (other
than face 1) that caused the force summation to be incorrect. This issue was introduced in Femap
version 2022.1 MP 1 (PR# 10339930).

Preferences - Interfaces

Corrected issue where the OGEOM parameter was not activated when the “Results Destination”
option was switched from Femap to Simcenter (PR#10348792).

Femap v2022.2

Updates and Enhancements

Teamcenter Share- New add-on module for version 2022.2!

• Added the File → Share menu to allow Femap users to interact with Teamcenter Share, Siemens
Digital Industries Software’s collaboration platform hosted on the cloud. Teamcenter Share offers
the ability to collaborate with colleagues by allowing users to upload various types of files to the
cloud which can then be checked out and downloaded locally by a different user for whatever
is needed. Once the user is finished, the file is then checked in and the revision uploaded to the
cloud.

• Teamcenter Share is an add-on that must be purchased in order to take advantage of the cloud-
based functionality. If a user does not have a license to run Teamcenter Share, the File → Share
menu and Teamcenter Share toolbar will not be displayed.

User Interface - General
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• Added From Node to Method^ menu of the standard entity selection dialog box when selecting
points, curves, surfaces, or solids. When used, any point, curve, surface, or solid, respectively,
which has a node associated with the geometric entity will be selected.

• Added From Element to Method^ menu of the standard entity selection dialog box when
selecting points, curves, surfaces, or solids. When used, any point, curve, surface, or solid,
respectively, which has all nodes of the selected element associated with the geometric entity will
be selected.

• Added a capability similar to the Custom Tools and User Tools menus into the Pick^ menu of the
Standard Selection Dialog so that it is possible to update or make selections with custom API tools
which have been specially coded for use this menu.

• Enhanced ability to specify bitmap files for the Custom Tools, User Tools, and the new Selection
Tools menu to add icons to the commands. Previously, those bitmaps were required to be 16x16
pixels. Now they can be any size, however 16x16, 24x24 and 32x32 pixels provide the clearest
images depending on the resolutions and Windows Display settings used when running Femap.

• Added the Help → Using Help command to assist users with the new help system.

User Interface - Toolbars and Icons

Added the Teamcenter Share toolbar, which includes commands from the File → Share menu, as
well as icons to check in and check out files from the cloud, using Teamcenter Share.

User Interface - Dockable Panes - PostProcessing Toolbox

Added ‘No Labels, Contour Colors’ and ‘No Labels, View Color’ options to the Label Color
drop\u0002down for Legend in the Contour tool, which allow the contour legend to be drawn
without labels.

Interfaces - Femap Neutral

Updated Neutral Read and Write for v2022.2 changes.

Analysis Manager

Added ‘31..Aeroelastic Frequency Response’, ‘32..Aeroelastic Transient Response’, and
‘33..Aeroelastic Random Response’ to the Analysis Type drop-down for both Simcenter Nastran and
MSC Nastran to support Aeroelastic Response (SOL 146).

Interfaces - Nastran

• Added support for Aeroelastic Response (SOL 146), which includes the ability to specify values
for the Mach Number (MACH), Dynamic Pressure (Q), and Gust Load (GUSTAERO) options in
the NASTRAN Aerodynamic Data (AEROx, MKAEROx) dialog box, specify options for Transient,
Frequency, or Random Response via the NASTRAN Dynamic Analysis dialog box, specify Gust PSD
Input for Random Response in the NASTRAN Power Spectral Density Factors (SOL 146) dialog box,
and choose a unique load set for the analysis using the Loads (Aerodynamic) drop\u0002down in
the Boundary Conditions dialog box. In addition, a Vertical Gust Load can now be defined using
the Model → Load → Body command for use with SOL 146.
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• Added read and write support for the MONPNT2 bulk data entry, which is specified using the
NASTRAN Element Monitor Point dialog box accessed via the NASTRAN Monitor Point Manager.

• Added support for specifying the number of tasks for a Distributed Memory Parallel (DMP)
analysis using MPI402/DMPARALLEL by turning on the ‘Number of DMP CPUs’ option in the
NASTRAN Executive and Solution Options dialog box, then entering a value.

• Added support for writing and reading Property titles as comments to and from Nastran files
when they are associated to Mass and Mass Matrix elements. (ER# 10233234 & ER# 10230704)

Interfaces - Simcenter Nastran

Updated “Plastic Matl. Measures (STRMEAS)” and “Output Measure (STROUT)” in the
Multi\u0002Step Golbal Control Options dialog box to be marked OBSOLETE and changed the
default to be a value of ‘-1..Nastran Default’.

Interfaces - ANSYS

Added read and write support for ANSYS MPC184 Joint Elements, including options for SECDATA,
SECJ, TB, SECLOCK, and SECSTOP.

Interfaces - Geometry

Added support for NX 2007, ACIS 2022.1, CATIA V5-6R2021 SP4, SolidWorks 2022.1, and JT 11.1

Elements

Updated the dialog box of Modify → Update Elements → Line Element Offsets command to be
more intuitive and also added the ability to enter a value to offset “Along Vector” at the same time as
specifying a “Radial Offset” when using the “Around Vector” option.

Materials

Updated the Material dialog box to significantly improve performance when opening the dialog box
in a model that contains a large number of functions.

Laminates (Layups, Ply Materials, and Global Plies)

• Enhanced Layup Manager dialog to work more like Microsoft Excel where cells for input data of
plies can be updated directly in the table control.

• Added ability to reference an existing layup when creating a new layup. All plies of a referenced
layup will be brought forward into the newly created layup. Plies of referenced layups are only
editable on the source layup level.

• Added Model → Laminates → Ply Material Manager command to create Ply Material entities
which contains a material and associated thickness. This can be selected as a ply in a layup and
aims to reduce duplicating effort for inputting data.

• Added the ability to turn individual plies, ply materials, or referenced layups on or off to specify
which plies will be written to the solver input file.
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• Added ability to copy plies within in a layup in matching order, symmetric, anti, or anti-symmetric.
These plies can optionally be “linked” to the original source ply. If using a ply is linked to a source
ply any updates made will propagate on the copied ply.

• Added Model → Laminates → MultiLayup Editor command, which allows user to select multiple
layups, then view their composition of the selected layups side-by-side to assign global ply IDs or
add/delete plies across multiple layups.

Simulation Entities

• Added “ANSYS” tab to the Joint Properties dialog box for Kinematic Joints which allows user to
specify options for SECDATA, SECJ, TB, SECLOCK, and SECSTOP.

• Added '11..General' as a Joint Type to both the Define Kinematic Joint and Define Joint Connection
dialog boxes. This type of joint is only used for ANSYS.

• Added New Elem Monitor button to access the NASTRAN Element Monitor Point dialog box, which
is used to support the MONPNT2 entry for Simcenter Nastran and MSC Nastran.

Loads and Boundary Conditions

Added the ability to create Aerodynamic Vertical Gust Load using the Model → Load → Body
command for use with Aeroelastic Frequency Response, Aeroelastic Transient Response, and
Aeroelastic Random Response (SOL 146 in Simcenter Nastran and MSC Nastran).

Output and Post-Processing

• Added the File → Export → Femap Neutral Output command, which exports a Femap native
FNO file that stores output results and improves performance when importing or attaching to
results. When exporting an FNO file, the user is able to select results from the full model, a
set of groups, or a selected set of elements. In addition, there is an option to also export a
corresponding Femap Neutral file containing all entities from the original model needed for
post-processing.

• Added ability to display contour legend without labels via the Contour/Criteria Legend option
found in the PostProcessing Category of View → Options.

Groups and Layers

• Added capability to allow add geometric entities which are associated to selected nodes to a
Group using the Group → Point → From Node, Group → Curve → From Node, Group →
Surface → From Node, and/or Group → Solid → From Node commands.

• Added capability to allow add geometric entities which are associated to all nodes of selected
elements to a Group using the Group → Point → From Element, Group → Curve → From
Element, Group → Surface → From Element, and/or Group → Solid → From Element
commands.

Tools

Added NextID and Increment field for Design Equation to Tools → Parameters command.

Preferences - Library/Startup
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Added field to specify the Selection Tools Path directory where API scripts can be stored for use with
the “API Selection Tools” submenu on the Pick^ menu of the standard entity selection dialog box.

API

New and updated API Objects and Attributes

• Added Ply Material (fePlyMaterial) Object to the API.

• Added title, matID, thickness, and failuretheory to the Ply Material Object.

• Added NasExecNumDmpCPU, NasAeronPARAMgustaero, NasAerodPARAMmach,
NasAerodPARAMq, and NasMonitorElemEnabled to Analysis Manager Object.

• Added NasCaseMonitorElemEnabled to Analysis Case Object.

• Added validate to Global Ply Object.

• Added JointProp, vJointProp, flag, and vflag to the Joint Object.

• Added OnOff, vOnOff, and IncludeOffPlys to the Layup Object. Also, updated
thickness, vthickness, angle, vangle, matID, vmatID, globalply, vglobalply,
failuretheory, and vfailuretheory to work with updated Layup Manager dialog box.

• Added BodyGustOn, BodyGustWG, BodyGustX0, BodyGustVelocityOpt,
BodyGustVelocity, BodyGustAppliedNode, and BodyGustFunction to the Load Set
Object.

• Added NumberOfContributions to Monitor Point Object.

New and Updated API Methods

• Added IsGust, GetCorrelateGust, and PutCorrelateGust to the Analysis Manager
Object.

• Added GetAllArray, GetAllAttrArray, PutAllArray, and PutAllAttrArray to the
Curve Object.

• Added SetReferencedGroups to the Group Object.

• Added AddPlyMaterialPly, AddLayupPly, AddMatchedPlys, GetPlyInfo,
GetAllPlyDefinition, MaterialsUsed, GlobalPlysUsed, and PlyMaterialsUsed
to the Layup Object.

• Added GetAllArray and PutAllArray to the Material Object.

• Added AddManualContribution, GetElemContributions,
SetManualContributions, ClearElemContributions, GetAtIndex, and
SetAtIndex to Monitor Point Object.
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• Added GetAllArray, GetFlagArray, PutAllArray, and PutFlagArray to the Property
Object.

• Added GetAllArray, GetAllAttrArray, PutAllArray, and PutAllAttrArray to the
Surface Object.

• Added SetOpenGLTransformationSpace, GetOpenGLTransformationSpace,
CollectorContourLegendText, and CollectorAddTextContourLegendLocations
to User Defined Graphics Object.

New and Updated Global Variables

Added Pref_SelectionToolsPath to specify the directory to store API scripts to be used
with the API Selection Tools submenu on the Pick^ menu in the standard entity selection dialog
box.

The following functions have been added or updated:

• feStartSelectionTool

• feEndSelectionTool 

• feAbortSelectionTool 

• feModifyRadialOffsets2 

• feModifyOffsetsToRefPt2 

• feElementTypeCount 

• feElementShapeCount

Corrections

Performance Graphics

Corrected issue where line contour not in sync with Performance Graphics switch in File →
Preferences. Line contours have not been implemented in Performance Graphics yet so if line
contour is selected, Femap resorts to using non-Performance Graphics, which results in line
contours that do not completely correspond to filled contours in Performance Graphics (PR#
10236674).

User Interface - General

• Corrected issue where mouse wheel zoomed a view if the mouse was over a dialog box that was
over the view. If a dialog is visible, the mouse wheel now only zooms the view if it is directly over
the view.
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• Corrected issue with the Fill Down and Fill Right commands on the context menus of various
Grid Controls. Previously they did not allow selecting multiple ranges of cells in a column (for Fill
Down) or row (for Fill Right).

• Corrected issue that caused the “Toggle Title Bars” command on the context menu of undocked
views to not turn off the title bars. (PR# 10316426 and PR# 10143995).

User Interface - Dockable Panes
PostProcessing Toolbox

Corrected issue where the Label Erase Background check box was not being hidden correctly
when contour legend was turned off.

Data Table
• Corrected issue that caused a memory leak to occur when using the selector for Loads or

Constraints if an entity that did not have a Load/Constraint was selected to send the data to
the Data Table.

• Corrected issue which significantly improved the performance of adding mass element
properties to the Data Table. This reverses a performance problem that was inadvertently
introduced in V2020.1 MP2 when the Element Mass properties functionality was enhanced to
allow adding data to the Clipboard. (PR# 10312074)

Interfaces - FEMAP Neutral
• Corrected issue introduced at V2022.1 that caused boolean fields in Femap Neutral Files to be

written as integer values, not just 0 or 1, but they could not be read as anything but 0 or 1.
This did not impact any regular Femap data but did impact some TMG data. Updated V2022.1.3,
V2022.2 and beyond to again write as 0 or 1 and read other values and convert to 0 or 1. It also
patches the V2022.1 Neutral File converter to write 0 or 1.

• Corrected issue regarding neutral file read where the contour legend exponent value was not read
correctly from files older than version 2020.1

Analysis Manager
Corrected issue which prevented Analysis Cases belonging to Analysis Sets other than Set 1
from being properly selected for deletion and/or renumbering via standard entity selection (PR#
10073058).

Interfaces - Nastran
Corrected issue which assigned Aero Property/Connection Property entity titles to Property entity
titles when importing a Nastran input file.

Interfaces - Simcenter Nastran
Corrected issue which prevented certain glue properties from being written to the Nastran input file
for SOL 401 or SOL 402 when a global glue property was specified but only one glue connector was
being used. (PR# 10310421)

Interfaces - ANSYS
Corrected issue which occurred when writing Femap mass element with non-zero off-diagonal of
rotary inertia to ANSYS MASS21 element. A new coordinate system ID should be created and used
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in defining the MASS21 element, instead the coordinate system ID of the Femap mass property was
used

Interfaces - Geometry

Corrected issue that caused valid STEP files to not be imported if they did not have a filename
extension of .STEP or .STP. (PR# 7423832)

Elements

Corrected issue in the Modify → Update Elements → Orient Plate Normal/First Edge command.
Previously if the “Align to CSys Direction” option, unlike the “Align to Vector” option, loads on
element faces would remain on the same face ID which means the loads would change direction or
where they were applied. Now they move to a new face ID, but remain acting like the original load.
(PR# 10315377)

Meshing

Corrected issue with Mesh → Editing → Interactive command where user could not override
snapping of new mesh point to attached Curve if no Surfaces were present in model. User can now
switch off Curve and Surface snapping with “On Geometry” button in dialog if Surfaces or Curves are
present in model. (PR# 10242033)

Output and Post-Processing

• Corrected issue where curved beams and tubes were not drawn correctly when a contour is being
displayed.

• Corrected issue with transformation of solid laminate results for 15-node parabolic wedge
elements.

• Corrected issue that could result in incorrect values for Von Mises stress, or even a cause Femap
to exit unexpectedly, if the Model → Output → Process command was used to envelope entire
Output Sets and the selected Output Sets were from multiple sources. For example, if results were
attached files of different formats and/or internal to the Femap database. The problem did not
occur if all results were in the same format (i.e attached or internal). It also did not occur if you
used the Function/Table editor to create an “As Needed/Temporary” Result Set. (PR# 10194976)

Tools

Corrected issue with the Tools → Check → Sum Forces command when computing the result of a
pressure load on a quadrilateral element face. The method used previously gave correct results for
planar faces but deviated as faces became warped. (PR# 10238290)

Program File

Corrected issue which occurred when recording a Program file so that the internal “automatic
analyze” command … {~1051} … does not get recorded. When this command is recorded, playback
of the Program File results in the analysis being run twice. (PR# 10309860)

API

• Corrected issue which prevents the feFilePictureSave and feFilePictureSave2 calls
from processing animated images that are not a single graphics window. Femap cannot save
animations of multiple graphics windows or a single window with the desktop or layout.
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• Corrected issue in with CollectorAddSymbolEntityLocations method of the user defined
graphics Object could cause Femap to exit unexpectedly if the symbols were being added to a
surface.

• Corrected issue where API call to get approximate face normals for quadrilateral elements had a
small numerical error in averaging corner normals.

Femap v2022.1 MP 2

Corrections

Geometry

Corrected issue which could occur if Composite Curves and/or Boundary Surfaces (Composite
Surfaces) with geometric-based loads and/or constraints applied, which caused the geometric loads
and/or constraints may be duplicated, sometimes numerous times, when the geometry which
is loaded or constrained is subdivided using various commands and tools available in Femap.
This issue does not impact models with mesh-based loads and/or constraints, but only models
with geometric loads and/or constraints on regular curves and surfaces, it can only happen with
Composite Curves and Boundary Surfaces (PR# 10287870).

User Interface - General

Corrected several “Zero-Day Initiative” issues. 15420, which still causes issues in Parasolid Facetting,
along with 15592 and 15594.

Simulation Entities

Corrected issue which prevented Aero Mesh from being selected for Aerodynamic Control Monitor
Points if there were no Aero Panels in the model with custom division lists.

Interfaces - Nastran

Corrected issue that could occur when reading Wide Field, Free Format Nastran files if all fields were
not completed either with a value or a comma to skip fields. This only happened on the first line,
which includes fields 1 thru 5 of the Nastran Bulk Data Entry (PR# 10290051).

Interfaces - Simcenter Nastran

Corrected issue which caused the MATS1 entry to be exported with an erroneous value for STRMEAS
when a nonlinear elastic material was specified for use in SOL401 or SOL402.

Output and Post-Processing

Corrected issue where contour arrow display is not oriented correctly for the combined shear force
vectors when the Arrow Display Mode is set to any of the “Shear (XY)/Axial (Z)” type modes.

Femap v2022.1 MP 1

Updates and Enhancements

Meshing Toolbox - Geometry Editing Tool
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Updated the Point to Point, Point to Edge, and Edge to Edge options in the Operation section to use
more robust methods to determine and process how a surface is split by these operations.

Interfaces - Geometry

Added support for NX v2007.

Corrections

Geometry

• Corrected issue where highlighting solids created filled highlights with varying colors.

• Corrected issue where a solid made of a single faceted surface, which could potentially occur
when importing geometry after performing topology optimization, were not highlighted when
picking solids.

• Corrected issue where solids made of a single Parasolid faceted surface could sometimes not be
selected.

• Corrected issue which caused the Geometry → Curve - From Surface → Project and Geometry
→ Curve - From Surfaces → Project Along Vector commands to not obey the Update Surface
toggle.

• Corrected issue when using Geometry → Solid → Embed Face which prevented proper
embedding of surfaces in all but one solid if multiple surfaces where selected on multiple solids.

• Corrected issue when using Geometry → Solid → Embed Face which prevented the Automatic
option from being available if more than one surface was selected.

Graphics

Corrected issue which prevented an abort from occurring during frame creation for animations.

Performance Graphics

Corrected issue where Model Data Contour with discrete values was not drawing the contours unless
the Entity Transparency value for the Performance Graphics view option was set to 0..None (PR#
1026630).

User Interface - General

Corrected issue that caused the Femap 2021.2 splash screen to be displayed when using a localized
version of Femap 2022.1.

User Interface - Dockable Panes

Postprocessing Toolbox - Deform Tool

Corrected issue where certain settings were being lost if the Auto Draw option was turned off. If
you changed the deformation mode and then brought up a dialog box or clicked in the graphics
window, the deformation mode would revert to the previous value.

Postprocessing Toolbox - Freebody Tool
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Corrected issue which prevented selection of locations in the graphics window when defining
a vector or plane in a new Freebody with Display Mode set to Section Cut. This only happened
when the Select Toolbar was active and the active entity type was set to Node or Element (PR#
10257528).

Simulation Entities

• Corrected issue which caused Femap to exit expectedly if a node used by any Kinematic Joint
was deleted, which could occur in a number of ways, including using the Tools → Check →
Coincident Nodes command.

• Corrected issue which prevented Monitor Points, Joint Connections, and Flexible Sliders from
having their entity references updated when the references are deleted.

Analysis Manager

Corrected issue which caused the Type in the Joint Time Constraint (SOL402) dialog box to swap
the DOF Fixation and DOF Liberation types when loading/unloading the dialog box. This dialog box
is only available when Analysis Program is set to 36..Simcenter Nastran and Analysis Type is set to
28..Multi-Step Nonlinear Kinematic.

Interfaces - Geometry

Corrected issue that prevented users from exporting geometry in the currently supported versions of
Parasolid and ACIS.

Interfaces - Nastran

• Corrected issue which caused a memory leak that occurred any time Nastran results were read,
including results that were automatically read after solving with the bundled Simcenter Nastran
solver.

• Corrected issue which could cause Femap to exit unexpectedly that could occur when reading a
corrupted and/or invalid Nastran file.

Interfaces - Simcenter Nastran

• Corrected issue which caused the PJOINT2 bulk data entry to be written with a syntax error
when rotational nonlinear spring properties were defined without translational nonlinear spring
properties.

• Corrected issue which caused overlapping IDs between connection elements (e.g. RBE2/RBE3
entires) and CJOINT bulk data entries when kinematic joints were defined in Femap as Kinematic
Connections.

• Corrected issue which caused the default DOF identification between Joint nodes, the OPT field on
PJOINT entry, to be loaded as Boolean in the dialog, rather than Lagrangian multipliers.

• Corrected issue which prevented the EQMFMX and EQMFMIN parameters from being exported to
the NLCNTL2 entry unless DTMAX was specified (PR#10255340).

Interfaces - ANSYS
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Corrected issue which caused the element results to not be properly imported into Femap when the
output file (*.rst file) was created in version of ANSYS prior to 19.0.

Output and Post-Processing

Corrected issue where Contour Arrows shown as Resultant were not being drawn in the correct
direction (PR# 10263076).

Tools

Corrected issue with Tools → Convert Units command, which caused the Structural Damping
coefficients on a Spring/Damper Property with Type set to CBUSH to be converted, which should not
happen because these values are dimensionless quantities (PR# 10265545).

API

• Corrected issue with the DialogAutoSkip property. Previously it worked properly if the value was
set to 1 (Press OK) or 2 (Show Dialog), but not when set to 0 (Cancel).

• Corrected issue which prevented indices 4-7 in the Property Object's flag array from being
accessed.

Femap v2022.1

Updates and Enhancements

User Interface - General

• Added on Points of Solid, on Curves of Solid, and on Surfaces of Solid to the Method^ menu of
the standard entity selection dialog box when selecting nodes. When used, any node is associated
with points, curves, or surfaces, respectively, of the selected solids will be selected.

• Added on Points of Solid, on Curves of Solid, and on Surfaces of Solid to the Method^ menu
of the standard entity selection dialog box when selecting elements. When used, any element
which has at least one it its nodes associated with points, curves, or surfaces, respectively, of the
selected solids will be selected.

• Added ID, Material, Global Ply, and on Property to the Method^ menu of the standard entity
selection dialog box when selecting layups. When using Material, any layup with references the
selected materials will be selected. When using Global Ply, and layup with references the selected
global ply will be selected. When using on Property, any layup with is referenced by the selected
property will be selected.

• Updated dialog box for commands which require selection of a file folder, instead of a file,
by providing an edit control which allows the user to type in the desired path, including UNC
paths. For example, this is used commands such as File, Attach to Results; on various tabs of
File, Preferences; accessed by various dialog boxes in the Analysis Set Manager, and others (ER#
10141396).

User Interface - Toolbars and Icons
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Added toggle to Entity Display toolbar which can be used to control overall visibility of the available
entity types or overall visibility of labels for the available entity types.

User Interface - Dockable Panes - Model Info Tree

• Added Kinematic Joints to Simulation Entities branch. Kinematic Joint command on
context\u0002sensitive menu can be used to create a new Kinematic Joint, while Kinematic
Connection command can be used to create a Joint Connection. The Manage command on
context-sensitive menu opens the Kinematic Joint Manager, while other commands can be used
to Copy, Edit, List, Delete, Renumber, change the Color, or change the Layer of existing Kinematic
Joints and/or Joint Connections.

• Added Flexible Sliders to Simulation Entities branch. New command on context-sensitive menu
can be used to create a new Flexible Slider, while the Manage command opens the NASTRAN
Flexible Slider Manager. In addition, other commands on the context-sensitive menu can be used
to Copy, Edit, List, Delete, or Renumber existing Flexible Sliders.

• Added Evaluate command to context-sensitive menu for Groups, which runs the Group →
Operations → Evaluate command on the highlighted Groups.

Interfaces - Femap Neutral

• Updated Neutral Read and Write for v2022.1 changes.

• Updated how entity lists are written to Groups in the Neutral File. Added a new block, 2208, that
replaces the old 408 Group block in versions 2022.1 and later. The new block writes entity ID
ranges instead of expanded ID lists.

Analysis Manager

Added search capability to the Preview dialog box of the Analysis Set Manager via the Find field (ER#
10159050).

Interfaces - Nastran

• Added ability to specify PARAM,POST,-2 via the User Interface by choosing Simcenter in the
Customization section of the NASTRAN Output Requests dialog box.

• Updated reading the Nastran Case Control SET=ALL command. Instead of creating a Group with
labels 1 to “Max Label”, it now creates a Group with only the entities in the input file.

• Added support for reading user-defined titles for entities in Nastran files in the following form:
$ TITLE: my_title. Any number of spaces, including zero, can precede or follow TITLE and/or the
colon which is also optional.

Interfaces - Simcenter Nastran

• Added ability to launch the Simcenter Nastran Solution Monitor by setting the Solution Monitor
option in the NASTRAN Executive and Solution Options dialog box to “2..Launch Simcenter
Nastran's Solution Monitor”. The Solution Monitor displays curated output from Simcenter
Nastran including detailed warnings, information messages, and errors for any type of analysis.
There are also separate SOL401 or 402 tabs to display time steps and number iterations requested
to converge the model. In addition, can also be used to display graphs and information for time
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steps, iterations for each time step, and other items such as convergence criteria, cumulative
number of iterations, elements which have experienced plastic deformation, etc.

• Added support for new methodology used to run the Dynamic Design Analysis Method (DDAM)
which now uses an entry written to the Nastran input file, DDAMCTR, instead of an external
control file to instruct the NAVSHOCK program, as well as a new entry to specify Base Excitation
for the Analysis. In addition, import of membrane results from DDAM analysis is now supported.

• Updated support for reading Simcenter Nastran entity titles when reading a Nastran model file.
This worked for earlier versions of Nastran however Simcenter Nastran changed the format of
their titles. Both formats are now supported.

SOL 401 and 402 Only

• Added read/write support for DTEMP entry, which can be used to create a time-assigned
temperature loading conditions.

• Added support for Plasticity Computation (PLSHSOL) to Multi-Step Global Control Options
dialog box.

SOL 401 Only

• Added support for Solid Elem. Output Strategy (RESXTRP) to Multi-Step Global Control
Options dialog box.

• Added support for the new stiffness update option where the stiffness is updated only at the
first iteration of each new time step.

• Added support for the tension-only shell element in SOL401, as well as the TENSOQD
parameter for controlling its conversion behavior.

• Added Hydrostatic Pressure Plasticity to Multi-Step Control Options dialog box

SOL 402 Only

• Added support for requesting modal participation factors and effective mass when the
analysis set includes a modal subcase.

• Added support for Bolt Preload Method (BOLTMETH) to Multi-Step Global Control Options
dialog box.

• Added Hydrostatic Pressure Plasticity to Multi-Step Control Options dialog box.

Interfaces - ANSYS

• Added read and write support for parabolic elements which only have a subset of mid-side nodes
defined.

• Added support to read UNBL entry from ANSYS .cdb files. UNBL entry was added for ANSYS 2020
R2.

Femap v2022.1

Femap Readme, Simcenter Femap 2412 Series  1-101
© 2024 Siemens



• Enhanced support for reading files which contain parameters and components in supported
ANSYS commands.

Interfaces - Geometry

Added support for Parasolid 34.0.

Elements

• Updated how Elemental Material Angles are computed when applied via a Vector or Coordinate
System Axis direction for planar elements. The updated approach gives better results for warped
elements. A typed-in User Preference, NastranMaterialAngle=0, can be added if the previous
approach to computing these angles is preferred.

• Updated the Modify → Update Elements → Line Element Offsets command by changing the
default to be modifying both End A and End B offsets to be identical.

Properties

Added support to offset NonStructural Mass from the Shear Center of Beam Elements using the
Y Axis Offset and/or Z Axis Offset fields in the new Nonstructural Mass Properties section of the
dialog box. The default is to maintain the NonStructural Mass axis at the Shear Center as in previous
releases. The new offsets, if provided, are also included in Mass Properties computations.

Simulation Entities

• Added Model → Simulation Entities → Kinematic Joints command, which currently is only
is used to create Kinematic Joint entities (CJOINT, PJOINT, PJOINT2, etc) for Simcenter Nastran
SOL 402. The command opens the Kinematic Joint Manager dialog box, which can be used to
create a new kinematic joint in one of two ways, as well as edit, renumber, delete, or copy any
existing kinematic joint or joint connection. In addition, there is a command to expand a joint
connection to see what will be created during export. Finally, there is a command to delete all of
the kinematic joints and joint connections currently in the model.

• Added Model → Simulation Entities → Flexible Sliders command, which is used to create
Flexible Slider entities (FLXSLI and FLXADD) for Simcenter Nastran SOL 402. The command opens
the NASTRAN Flexible Slider Manager dialog box, which can be used to create a new flexible
slider, as well as edit, delete, copy or renumber any existing flexible slider. In addition, there is a
command to highlight all of the entities being used by a flexible slider in the graphics window.
Finally, there is a command to delete all of the flexible sliders currently in the model.

Loads and Boundary Conditions

• Improved the performance of load expansion of surface loads onto planar elements for Parasolid
surfaces. In a model with 2.5 million plate elements being expanded onto 300 surfaces load set
expansion saw a 2X performance improvement.

• Updated the Load Definition dialog box for Nodal and Geometric loads to show text that reflects
the type of the Load Definition Coordinate System. This update only applies to load types that
use vector components. For example, for Forces, the fields were always labeled FX, FY and FZ.
Now, for Cylindrical and Spherical systems, they will be labeled FR,FT,FZ (cylindrical) or FR,FT,FP
(spherical).
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• Added support for creating a time-assigned temperature load via a new “NASTRAN DTEMP
Sequence” load set type for SOL401/SOL402.

Meshing
• Added Mesh → HexMesh Bodies command, which can be used to perform Hex-dominant

meshing of solid geometry with little to no simplification or subdivision into smaller and simpler
geometric regions. This mesher creates as many hex (brick) elements in that part as possible, then
fills the remainder of the solid volume with a mix of tetrahedral, pyramid, and wedge elements.
The dialog box contains three sections, one which controls Mesh Sizing, another to specify
options for Mesh Associativity, and a third to control Node Options, such as which elements
should be given midside nodes.

• Added Mesh → Editing → Mapped Hex Refine command, which can be used to subdivide
selected elements of a mapped hex mesh and then automatically transition from the newly
subdivided elements to the elements of the original mesh which were not modified by the
command. There is also an option to Repeat Refinement to make an even finer mesh.

Output and Post-Processing
Updated how results are loaded into memory to improve performance. This update will only impact
cases where results are attempting to be loaded when the corresponding nodes or elements do not
exist. Loading results for deformation and contouring of a model where the mesh no longer existed
went improved from 70 seconds to 2 seconds.

Groups and Layers
• Added capability to allow selection of mesh entities attached to geometric entities which are used

by Solids. For nodes, this includes the Group → Node → on Points of Solid; Group → Node
→ on Curves of Solid; and Group → Node → on Surfaces of Solid commands. For elements,
Group → Element → on Points of Solid; Group → Element → on Curves of Solid; and Group →
Element, on Surfaces of Solid commands.

• Added Add to Copied Entity Groups option to the dialog box for Copy/Rotate/Reflect commands
for Geometry and Finite Element Entities. Turning this option on insures that if the original
entities are in any Group those Groups will also include the newly duplicated entities.

• Improved performance of updating Groups when there are many entities selected in contiguous
ranges. In models with large numbers of Groups this can be significant when using the Mesh
Editing tools.

Tools
Updated the Tools → Check → Mesh Interference command to have selected Plot Only plates
elements be treated as having zero thickness, removing numerical roundoff and false positive mesh
interferences.

Preferences
User Interface

Added Help button which is used to specify Help Type, either Online HTML or Local HTML and
a Help Location, which is only used for Local HTML. When using Online HTML the Helpis hosted
on the Siemens DI Software Support Center website and opened via a web browser. To use
the Local HTML option, the Siemens Documentation Server must first be installed, either on a
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user’s computer or on a server machine available to an organization, then the HTML content is
installed locally on that machine.

Interfaces

• Added Activate OGEOM Parameter to Nastran Options section. When turned on, any new
Analysis Set created with Analysis Program set to “4..MSC Nastran”, “31..Autodesk Nastran”,
or “36..Simcenter Nastran” will automatically have the OGEOM option turned on in the
NASTRAN Bulk Data Options dialog box.

• Added Results Dest option to Nastran Options section to automatically select the Results
Destination in the Customization section of the NASTRAN Output Requests dialog box for any
new analysis created with Analysis Program set to “4..MSC Nastran”, “31..Autodesk Nastran”,
or “36..Simcenter Nastran”. When set to Femap, the Femap option will be selected, which
writes PARAM,POST,-1 to the Nastran input file. When set to Simcenter, the Simcenter option
will instead be selected, which writes PARAM,POST,-2 to the Nastran input file.

API

Overall Functionality

Updated API methods to be able to pass Variants or single valued variables dimensioned as
BOOLEAN, INT2/INT4/INT8, or REAL4/REAL8 to input array arguments if all values of the array
are supposed to contain the same value. Previously numeric constants and dimensioned array
variables were supported, but not the new combinations.

New and updated API Objects and Attributes

• Added Kinematic Joint and Joint Connection (feJoint) Object to the API.

•  Added color, layer, title, type, JointBehavior, G1, G2, PID,
HasCID1, CID1, HasCID2, CID2, HasG3, G3, KT, KR, CF, FR0, LR, LX,
LY, LZ, RegularizationOpt, TOL, KCF, LIBL, PITCH, OPT, HasSPR1TRA,
K1T, K1TTID, SK1TTID, HasSPR1ROT, K1R, K1RTID, SK1RTID, HasDAM1TRA,
B1T, B1TTID, SB1TTID, HasDAM1ROT, B1R, B1RTID, SB1RTID, JointLoc1,
vJointLoc1, JointLoc2, vJointLoc2, JointLoc1_x, JointLoc1_y, JointLoc1_z,
JointLoc2_x, JointLoc2_y, JointLoc2_z, HasTarget1List, HasTarget2List,
Target1SetID, Target2SetID, Target1Type, Target2Type, CurveExpansionOpt,
SurfExpansionOpt, and ElemExpansionOpt to the Kinematic Joint and Joint Connection
Object.

• Added Flexible Slider (feFlexibleSlider) Object to the API.

• Added color, layer, title, NasTYPE, NasNGRPID, NasBGRPID, NasSGID, NasPROJ,
NasHasNLIM, NasNLIM, NasDTYPE, NasDGID, NasDVAL, NasDTID, NasFOP, NasCF,
NasTOL, NasKCF, HasNodeList, HasElemList, NodeSetID, and ElemSetID to Flexible
Slider Object.

• Added AddToCopiedEntityGroups and CopyMeshSize to the CopyTool Object.

• Added NasBulkTENSOQD, NasBulkTENSOQDval, NasSolutionMonitorOpt,
NasMsNLKGlobalRESXTRP, NasMsNLKGlobalBOLTMETH, NasMsNLKGlobalPLSHSOL,
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NasDdamSpdirCSID, NasDdamSpdirCOMP, NasDdamFileUnit, NasMsnlkJCON,
NasMsnlCntPLSHUT, and NasMsnlkCnt2PLSHUT to Analysis Manager Object.

• Added VectorPressure, vPressureDirection, and PressureDirection to the
LoadMesh Object.

• Added IsSequence to the LoadSet Object.

New and Updated API Methods

• Added GetReferenceSet, ClearReferenceSet, PutReferenceSet, GetMotionSet,
ClearMotionSet, and PutMotionSet methods to the Kinematic Joint and Joint
Connection Object.

• Added GetComponentSet, ClearComponentSet, and PutComponentSet Methods to
Flexible Slider Object.

• Added PutFLXSLISetID, GetFLXSLISet, ClearFLXSLISet, and PutFLXSLISet to the
Analysis Manager Object.

• Added Solid to MeshPoint Object.

• Added GetSuperelementIDArray and PutSuperelementIDArray to Node Object.

New and Updated Global Variables

• Added Pref_OnlineHelp_Mode to set Help Type preference in the Help Options dialog box
accessed via User Interface tab of File → Preferences.

• Added Pref_OnlineHelp_Path to set directory path for Help Location preference in the
Help Options dialog box accessed via User Interface tab of File → Preferences.

• Added Pref_SC3DResultsDest to specify Results Dest preference on the Interfaces tab of
File → Preferences.

• Added Pref_nastran_param_ogeom to specify Activate OGEOM Parameter preference on
the Interfaces tab of File → Preferences.

The following functions have been added or updated:

feCheckCoincidentNode5

Corrections

Connection Properties, Regions, and Connectors

Corrected an issue in Connect → Automatic command that caused excessive numbers of
connections to be detected if you turned on the “Check for Connections to Internal Edges” option
when requesting “Edge-Face” connections and selected multiple adjacent solids. These connections
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will still be created if choose both “Edge-Face” and “Edge-Edge” connections, but will not if you
choose only “Edge-Face”.

Geometry

• Corrected an issue that caused Delete → Geometry → All to not be available if points did not
exist.

• Corrected an issue that caused some geometry to be improperly marked as deletable if it was
referenced by loads or constraints and it was created by a Copy/Rotate/Reflect command where
multiple copies were created.

• Corrected an issue that occurred in some faceted models that had bodies that were not divided up
into multiple surfaces. Previously, projecting coordinates/nodes/points/etc. onto these bodies did
not work. This was not a problem with normal Parasolid bodies or even faceted bodies that were
divided into surfaces like normal bodies.

• Corrected multiple issues that could occur when checking surfaces for planarity or radius of
curvature. These issues normally impacted only a limited number of surfaces but could cause
failures in meshing, centerline determination and surface embedding. (PR# 10312102)

• Corrected a problem that caused Parasolid to fail and possibly corrupt geometry if the total
memory allocated to Parasolid exceeded 2 GByte. (PR# 10327799)

Graphics

• Corrected issue where arrow heads of coordinate systems were not drawn correctly if axis was
directly in to or out of the screen when the coordinate systems were drawn as arrows. This
problem only occurred when not in Performance Graphics.

• Corrected issue where model files with large results but no mesh takes a long time to draw (PR#
10107424).

• Corrected issue where bar, beam and parabolic beam element end releases are drawn incorrectly
when shrink and offsets are on.

• Corrected issue where monitor points were not being correctly included in the Autoscale Visible
command.

• Corrected issue where contour arrows are not scaled by magnitude correctly when not in
Performance Graphics and not doing a 2D Tensor plot.

• Corrected issue with curve bearing load in local coordinate systems not being drawn correctly
and corrected issues introduced in Femap 2021.2 where loads in local coordinate systems with
components switched off behaved incorrectly.

• Corrected issue when using New Picking when animating where entities are not being
highlighted and marked in the correct locations. New Picking now has a pre-pick draw that
removes the deformation.
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• Corrected issue where New Picking did not work correctly after using Draw/Erase Toolbar with an
element property or element material.

• Corrected issue where solids were pickable even if all their surfaces and curves were hidden using
the Draw/Erase Toolbar (PR# 10220685).

• Corrected an issue that caused loads and boundary conditions that were applied to a planar
facet\u0002based surface to sometimes show up outside the surface or even on adjacent or
nearby surfaces. This did not impact how the loads/BCs were applied to the model, just how they
were displayed. It also did not happen on regular Parasolid surfaces.

Performance Graphics

• Corrected issue where mesh size on point was not drawn in Performance Graphics.

• Corrected issue where picking of solid laminate element layups did not work in Performance
Graphics.

User Interface - General

• Corrected an issue that occurred when attempting to save a database if there were zero-length
sub\u0002files in the scratch directory at the time of saving and the database preference for
Open/Save was set to either of the C I/O methods. Previously you would get an error message that
said that the save failed but there were no errors. The only problem was the extra message.

• Corrected an issue in the various Copy commands and the API Copy tools that occurred if you
attempted to copy combined curves or surfaces and you chose the “Assign to Active Color”
option. Previously these curves or surfaces were set to the active Curve or Surface color, not the
appropriate one for Combined geometry.

• Corrected an issue if you used the Selector in Multi-Select mode, chose some entities, turned off
the Selector, went to the Model Info Tree and right clicked on one of the entities in the Selection
List and then either cancelled the menu or chose one of the commands. Previously this would
leave the Selector turned back on, but now it remains in the off state.

• Corrected an issue which could occur when editing face selection for connection regions (PR
#10127079).

User Interface - Toolbars and Icons

• Corrected an issue that occurred when attempting to save a database if there were zero-length
sub\u0002files in the scratch directory at the time of saving and the database preference for
Open/Save was set to either of the C I/O methods. Previously you would get an error message that
said that the save failed but there were no errors. The only problem was the extra message.

• Corrected an issue that now handles the Cursor Position toolbar when Windows Scaling is
changed, as it no longer issues messages that the toolbars have changed and the Cursor Position
toolbar will be displayed using default icons and text.

User Interface - Dockable Panes

Meshing Toolbox - Mesh Locate Tool
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Corrected issue which caused display issues when using the Mesh Locate tool while blanking
was enabled for any entity (PR# 10123783).

Analysis Manager

Corrected issue which prevented Analysis Cases belonging to Analysis Sets other than Set 1
from being properly selected for deletion and/or renumbering via standard entity selection (PR#
10073058).

Interfaces - Nastran

• Corrected issue which caused the LGDISP parameter to be activated for nonlinear solutions when
an input file without LGDISP specification was imported (PR# 10177916).

• Corrected issue where aero panels with definition coordinate systems the same as the analysis
manager coordinate system were not being drawn in the correct orientation. Also corrected
issue when rotating or moving coordinate systems that are the analysis manager flow direction
coordinate systems was not reorienting the aero panels correctly (PR# 10225116).

• Corrected issue with several solution 200 optimization bulk data entires, such as DESVAR,
DVPREL1, DCONADD, DRESP1, were not being written in large field format (PR#10180758).

Interfaces - Simcenter Nastran

Corrected issue with improper reading of aero elasticity flutter results depending on the
PARAM,POST value and also if PARAM,OPPHIPA was being written to the file. Complex results were
not being read.

Interfaces - MSC Nastran

Corrected issue which resulted in an incorrect default value being computed for the PTINTRF
parameter on the BCONPRG/BCAUTOP entries.

Interfaces - ANSYS

• Corrected an issue where multiple EMODIF commands are read from an input file for the same
element, to account for the different node connectivity convention of ANSYS and Femap.

• Corrected an issue which arose when reading a shell edge contact from an input file, where a
Femap a connection region and a connector were not created.

• Corrected an issue regarding material orientation related to warped laminate plate elements, to
write the material orientation consistently to Simcenter Nastran convention.

Interfaces - ABAQUS

Coordinate System Titles which were not fedault values were not exporting to ABAQUS input file
(PR# 717556).

Elements

• Corrected issue with the computation of Mass Properties of Tapered Beam Elements, specifically
the position of the center of gravity along the length of the beam. Previously it was just located
using a weighted average of the end areas which is incorrect.
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• Corrected issue with Mass Properties of Beam Elements. Previously it reported and used the Shear
Center as the Center of Gravity. This only impacted elements where the Shear Center was offset
from the Center of Gravity. (PR# 10049522)

Properties

• Corrected issue where creating a General Section beam property to cause mesh sizing information
to be overwritten on the selected geometry.

• Corrected an Issue with Beam Properties. In previous releases, if there was a Tapered Beam
Property that referenced a General Cross Section, checking the Large Strain Property Extension
would corrupt the referenced Cross Section for End B. This did not change the actual properties
unless they were recomputed from the cross section.

Meshing

• Corrected an issue in Mesh → Mesh Control → Custom Size Along Curve when using the
“Match…” options. The problem occurred if you were setting sizes on a long curve by matching a
chain of several shorter joined curves. Previously, mesh locations at the ends of the smaller curves
which were interior to the chain were missed. (PR# 10172888)

• Corrected an issue that occurred if you meshed Solid Surfaces with Quad Elements, then meshed
the Solid with Pyramid and/or Tet elements and then used one of the Operations in the Geometry
Editing tool of in the Meshing Toolbox, such as Washer, to update the mesh. Previously if Meshed
with all tetrahedral elements, then became pyramids after the update. Now all elements will be
tetrahedrals, as requested. (PR# 10163471)

Loads and Constraints

Corrected an issue that caused enforced displacements on adjacent surfaces to not be combined on
the shared edges if the surfaces were not tangent at those edges to a very tight numerical precision.
The tolerance computation has been updated so that combination will occur if the surfaces are
tangent within approximately 0.008 degrees. (PR# 10184631)

Output and Post-Processing

• Corrected an issue reading results from double-precision .FNO files that were created in Femap
versions 2019.1 and prior. Results were read correctly, however Result Vector IDs were not
properly converted to the new Vector numbering scheme.

• Corrected capitalization of titles of Y and Z Cohesive Stress when reading from Nastran OP2 files.
(ER#10220131)

• Corrected issue where MATCID was not being accounted for in results transformation for solid
element contours.

• Corrected issue where solid laminate elements were not handling MATCID correctly when
transforming results.

• Corrected issue where the transformation for wedge laminate elements can fail occasionally for
particular plies in the thickness of the element.
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• Corrected issue in complex animation where there can be a slight jitter in animation at the end
of each cycle. This is due to the default animation style being linear full which runs up and down
the phase angles. Complex animation should always be run with an animation style of linear half.
This value is now overridden internally if doing a complex animation.

• Corrected issue that could cause Model → Output → Transform for composite results to store
transformed output in improper Output Vector IDs. This would only occur in some rare cases
when global ply IDs were used (PR# 10050427).

Groups and Layers

• Corrected an issue that prevented Groups from being properly updated in some models during the
Mesh → Editing → Edge Split command.

• Corrected an issue that occurred in some Group commands, like Group → Operations → Add
Related Entities. Previously, if the Group being evaluated was a subgroup of another “top-level”
Group, the “top-level” Group was not properly updated unless the group was evaluated using the
Group → Operations → Evaluate command or made some other change. Now update happens
automatically.

• Corrected an issue that could occur if you had multiple levels of Groups that reference other
Groups and made a change to one of the intermediate “Group of Groups” (Referenced Groups).
Previously, Groups that then referenced that updated Group would not be automatically updated
until they were evaluated with the Group → Operations → Evaluate command. Now, they are
automatically updated.

• Corrected an issue that caused existing Group titles to be lost if you used the “Create Group"
command on the Draw/Erase toolbar and chose one of the Add/Remove/Exclude options to update
an existing Group. Also, enabled these options if any Groups exist in the model. Previously they
were only available if there was an active Group.

Tools

• Corrected an issue with Tools → Check → Coincident Nodes. It was discovered that even with
“Safe Merge” turned on there were cases that could “over merge” and corrupt models. This
happened only in models where the default merge tolerance was very large compared to a local
refined mesh size, thus changes were made to prevent the corruption.

• Corrected an issue with listing of values for individual elements in Tools → Check → Element
Quality. Previously many of the results for solid elements were listed under the wrong column
header, but the results in the summary table were labeled correctly.

API

• Corrected an issue with adding the PID (process ID) and MID (model ID) to the command lines of
launched APIs. For custom User Commands an option has been added to “Add Process and Model
ID Arguments” to the command line which is off by default. For the Custom or User Tools Menu
items you must add a file to the directory that is named “api_name.pidmid”, where “api_name”
matches the name of the API file that you are running. If that file does not exist, PID and MID are
not added to the command line (PR# 10107155).
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• Corrected an issue in the MeshOnMesh method of the BodyMesher API object. Previously, it did
not properly honor the TargetSize mesh property. (PR#10191367)

• Corrected an issue which now allows the AlongVector method of the API CopyTool object to
make a copy in the same location if the “CopyInSameLocation” parameter is set to True prior to
copying. Previously the method failed.

Femap v2021.2 MP 2

Updates and Enhancements

API

Added a second FEVENT_SHUTDOWN API event to indicate that Femap will definitely shutdown. The
original event happens prior to the potential to cancel shutdown as the user is asked to save the
model. The original event has lParam=0, while the new event has lParam=1.

Corrections

Connection Properties, Regions, and Connectors

Corrected issue when editing face selection for connection regions which was improperly allowing
recursive usage of Elements “By Faces”. This is now prevented. (PR# 10127079)

Graphics

• Corrected issue which occurred when attempting to select parabolic hexahedral elements which
have missing midside nodes when using the “New Picking” option on the “Graphics” tab of File →
Preferences.

• Corrected issue where CBUSH elements imported from a Nastran input file which had been
created by another product would cause the element orientation data to be specified in a manner
that caused CBUSH elements to not be able to be highlighted using the Model Info Tree.

• Corrected issue where some back facing elements that shared edges with front facing elements
were selected when using the “Fast Pick Visible” option on the “Graphics” tab of File →
Preferences when the picking option is set to “Front”.

• Corrected issue where “New Picking” did not select elements at all when using the “Fast Pick
Visible” option on the “Graphics” tab of File → Preferences, the picking option is set to “Front”,
and the pick mode was set to “Pick All Inside”.

• Corrected issue where some back facing surfaces were selected when using the “Fast Pick Visible”
option on the “Graphics” tab of File → Preferences.

• Corrected issue which caused the Contour Legend and arrows to not be displayed in the correct
colors after using Window → Redraw or Window → Regenerate to refresh the graphics window
when displaying a Contour Arrow plot.
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User Interface - Dockable Panes

Model Info Tree

Corrected an issue that prevented Views from being properly shown immediately in the Model
Info Tree when they were Loaded from a Library using the View → Create/Manage command.
(PR# 10127190)

Entity Editor

Corrected several issues that occurred using the Entity Editor to update Load Sets or Body Loads
when the Body Loads were defined in a Coordinate System other than Global Rectangular.
Previously, using the Entity Editor in this fashion could change the orientation of the Body
Loads. (PR# 10137419)

Interfaces - ABAQUS

Corrected issue where ABAQUS was not exporting titles for coordinate systems (PR# 10138763).

Loads and Boundary Conditions

Corrected an issue when expanding Torque loads on Curves and Surfaces if the magnitude of the
torque was specified as a negative value around the direction vector. Previously, the resulting nodal
loads were identical to those created if the torque was specified as a positive value. Now they are
properly aligned to the direction of the negative torque (PR# 10137562).

Meshing

Corrected several issues that prevented assigning length-based mesh sizing on some curves. Issues
typically occurred on curves that had nearly, but not exactly equal length parametric sizing. The
issues impacted the Mesh → Mesh Control → Size on Curve; Mesh → Mesh Control → Size on
Surface; and Mesh → Mesh Control → Size on Solid commands.

Output and Post-Processing

• Corrected an issue that prevented Enveloping Stresses and Strains that were Computed as
Average Mid Plate values if the data was in an attached Results file rather than the internalized in
a model database.

• Corrected issue which occurred when importing results from the .f06 file from an Aerodynamic
Flutter analysis due to change in Simcenter Nastran format, which was changed for Simcenter
Nastran version 1899.

Femap OEM

• Corrected issue where the Femap icon in displayed after using the Help → About command did
not honor the icon defined by the OEM.

• Corrected issue when using the Help → About command that caused the information in the
dialog box to display the wrong license type for Femap OEM.
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Femap v2021.2 MP 1

Corrections

Geometry

Corrected issue which caused individual solids to not be Boolean added together one at a time if the
Geometry → Solid → Add command failed when attempting to Boolean add more than two solids
together.

Graphics

• Corrected issue where beam elements with a trapezoidal tube cross sections were not being
drawn in the correct place. This made the stress locations appear slightly incorrect, but they were
actually correct and it was the cross section being drawn in the incorrect location.

• Corrected issue where Nastran General Matrix elements were not correctly included in calculation
of the model box when using certain commands on the View → Autoscale menu.

• Corrected issue where nodes which had been hidden by Draw/Erase toolbar and/or the Visibility
check boxes in the Model Info Tree and Visibility dialog box could still be selected when the New
Picking option was on in File → Preferences.

Performance Graphics

Corrected issue where Box, Circle, Polygon, and Freehand picking did not select nodes if the Nodes
On check box was enabled on the Element/Material/Property tabs of Visibility dialog box.

User Interface - General

Corrected issue which caused Femap to become unresponsive if solution frequencies were selected
in subcases via the response frequency list and the File → Rebuild command was later used on the
model (PR# 10109314).

Interfaces - Nastran

Corrected issue that could cause Femap to become unresponsive when writing Nastran BLSEG
edge contact or slide line elements where the edge nodes are connected to unsupported element
topologies, such as Rigid elements.

Interfaces - Simcenter Nastran

• Corrected issue which prevented contact parameters other than PENN, PENT, and PENTYPE from
being written to the BCTPARM bulk data entry when a connection property was specified for the
Gaps as Contact option in the NASTRAN Bulk Data Options dialog box in the Analysis Set Manager.

• Corrected issue which caused the “MPC” case control command to not be written for SOL401/
SOL402 when the Constraint Equations drop-down in the Boundary Conditions dialog box is set to
“0..From Constraint Set” (PR# 10082779).

Interfaces - ANSYS

• Corrected issue reading and writing parabolic elements which did not have all midside nodes
defined (i.e., only certain midside nodes were defined on an element).
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• Corrected issue reading Ansys UNBL descriptor from some commands.

Properties

Corrected issue which forced the top dimension of Wide Flange (I-beam), trapezoidal, and
trapezoidal tube cross-sections used for Beam Properties to be smaller than the bottom dimension
(PR# 10081554).

Meshing

Corrected issue which caused Femap to become unresponsive when attempting to set a mesh
size of a surface which referenced corrupt geometry. While the mesh sizing may not come out as
expected, Femap will continue to run and cleanup of the corrupt geometry can be attempted.

Output and Post-Processing

Corrected issue that could cause the Model → Output → Transform command to fail when
transforming output in the newly created output vectors. This would only occur in some rare cases
when global ply IDs were used. In all cases, the laminate Failure Indices output was improperly
stored to invalid output vector IDs which would cause the failure (PR# 10050427).

Groups and Layers

Corrected issue where New Picking is allowing curves and surfaces to be picked when they are
only being displayed as part of solids which currently reside in a group, by removing code that was
incorrectly implemented to make curves and surfaces on solids in groups follow the solid visibility
switch (PR# 10025208).

JT Files 

Corrected issue where loads or boundary conditions that point directly into or out of the screen (i.e.,
directly towards or away from the user) are not being drawn correctly in JT file output.

API

Corrected an issue that was introduced in v2021.1 that prevented batch file (*.bat) from being run
from the User Tools menu on the Custom and User Tools Toolbar (PR# 10107155).

Femap v2021.2

Updates and Enhancements

User Interface - General

• Added All Nodes on Solid option to the Method^ menu of the standard entity selection dialog
box when selecting elements. When used, any element which has all its nodes associated to the
selected solids will be selected.

• Updated selection of Aero Panel/Body, Aero Property, Aero Splines, and Aero Control Surface
entities to use the picking technology enabled by the New Picking option on the Graphics tab of
File → Preferences, which takes advantage of OpenMP to improve performance.

User Interface - Dockable Panes

Model Info Tree
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Added Design Equations to Simulation Entities branch. Manage command on context-sensitive
menu opens the NASTRAN Design Equation Manager, while other commands can be used to
Edit, List, Delete, or Renumber existing Design Equations.

Meshing Toolbox - Geometry Editing Tool

• Added Projection Mode drop-down when Operation is set to Point to Edge. Choose from
Normal, which performs a normal projection of the selected point to the selected edge;
Vector, which allows specification of a vector to project the selected point along to the
selected edge; or Interactive, which is has the user select a point, select an edge, then specify
a vector to project along.

• Added Projection Mode drop-down when Operation is set to Project Curve. Choose from
Normal, which performs a normal projection of the selected curve(s) onto the selected
surface(s) or Vector, which allows specification of a vector to project the selected curve(s)
along to the selected surface(s).

Meshing Toolbox - Mesh Sizing tool

Added Set Size to the Operation section which allows the user to specify a Mesh Size to define
the number of elements on a curve. In addition, changed Set To in the Operation section to Set
Number which allows the user to specify Number of Elements on a curve.

Mesh Control Explorer

• Added “Show Edges that are Adjacent to Surface with No Imprinted Edges” and “Show
Surfaces that Pierce Other Surfaces with No Imprinted Intersections” tools to the Mesh
Control Explorer.

• Updated the position of the icons in the pane to group tools used to do similar operations
together

Interfaces - Femap Neutral

Updated Neutral Read and Write for v2021.2 changes.

Interfaces - Nastran

• Added support for defining dynamic subcases for “3..Transient Dynamic/Time History”,
“4..Frequency/Harmonic Response”, and “12..Nonlinear Transient Response” analysis types. In
addition, a static subcase can now be created for “3..Transient Dynamic/Time History” and
“4..Frequency/Harmonic Response” for the purpose of accounting for differential stiffness using
a STATSUB entry.

• Added support to read and write the CBUSH1D element type and corresponding PBUSH1D
property type entries. In addition, general nonlinear behavior can be defined with Functions or
Design Equations.

• Added support to read and write the DEQATN entry by using a Design Equation Simulation Entity.
In addition, general nonlinear behavior can be defined with Functions or Design Equations.

• Updated the default value of the PRGPST option in the NASTRAN Bulk Data Options dialog box to
off.
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Interfaces - Simcenter Nastran (formally NX Nastran)

Added support to specify a Connection Property when the Gaps as Contact option is enabled for SOL
101.

SOL 401/402

Added support for reading and writing the MPLAS entry used by SOL 401 and SOL 402.

Interfaces - LS-Dyna

Added support for element formulation EQ18 and EQ-18 for solid elements as well as element
formulation EQ16 for shell elements.

Interfaces - Geometry

• Added support for Parasolid 33.1, NX v1953, ACIS 2020.1.0 1.0.1, Creo 7, and SolidWorks 2021.

• Added ability to import Parasolid files with solids, sheet solids, and/or general bodies which
have any number of surfaces using a faceted representation (convergent modeling) instead of a
boundary representation (b-rep).

Elements

Added ability to create a CBUSH1D element for Nastran solvers by using a Spring/Damper element
which references a Spring/Damper property with the CBUSH1D option selected or by using a
Spring/Damper to Ground element which references a Spring/Damper to Ground property with the
CBUSH1D option selected.

Properties

Added CBUSH1D option to both the Spring/Damper property and the Spring Damper to Ground
property types. When a Spring/Damper element or Spring/Damper to Ground element references a
property which is set to CBUSH1D, a CBUSH1D and corresponding PBUSH1D will be written to the
Nastran input file. In addition, the Nonlinear/Freq Resp... button can be used to access the Define
Nonlinear 1D Spring/Damper dialog box to choose Functions or Design Equations to control Spring,
Damper, Shock Absorber, and/or Generalized Spring/Damper behavior on the PBUSH1D entry.

Simulation Entities

Added Model → Simulation Entities → Design Equation command, which is used to create
Design Equation entities (DEQATNs) for Nastran solvers. The command opens the NASTRAN Design
Equation Manager dialog box, which can be used to create a new design equation as well as
edit, renumber, delete, or copy any existing design equation, or delete all of the design equations
currently in the model.

Meshing

• Added the Mesh → Bodies command, which uses meshing methodologies which differ from
those used by the Mesh → Geometry → Surface and Mesh → Geometry → Solid commands
in an attempt to create a higher quality mesh by imposing fewer restrictions when meshing
geometric surfaces (sheet solids), solids, and general bodies. Can be used to create a 2-D surface
mesh on a connected sheet solid (stitched body) or general body or a 3-D solid tetrahedral mesh
in a solid part.
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• Added the Mesh → Mesh on Mesh command, uses meshing methodologies as the Mesh
→ Bodies command, only it uses existing triangular or quadrilateral elements as the starting
point instead of geometric entities. This is made possible by sending the facets used to display
the elements in the graphics window into the mesher, which then creates a triangular or
quadrilateral-dominant mesh based on those facets.

• Added the Body/on Mesh option to the Mesh → Geometry → Surface command. When selected,
surfaces are meshed with the same mesher used by the new Mesh → Bodies and Mesh → Mesh
on Mesh commands.

Output and Post-Processing

Updated the View → Advanced Post → Stress Linearization command to copy the underlying
transformed stresses to the clipboard instead of the regular output report by holding down the Shift
key when pressing the Copy to Clipboard button.

Groups and Layers

Added Group → Element → All Nodes on Solid command which places any element which has all
its nodes associated to the selected solids in a group.

Tools

Updated the Tools → Check → Mesh Interference command to have selected Plot Only plates
elements be treated as having zero thickness, removing numerical roundoff and false positive mesh
interferences.

JT Files

• Added ability to output the active, visible, selected, or all load sets and/or constraint sets to a JT
file when Type is set to Standard Output in the JT File Options dialog box. In addition, element
symbols can now be output to a JT file.

• Added Multi Result Output option to the JT File Options dialog box which allows selection of any
number of output vectors in any number of output sets to be output to a JT file either as Raw
Output Data or as Collated Vectors and Tensors with options to use averaging, transformation,
and/or include corner data.

API

New and updated API Objects and Attributes

• Added BodyMesher (feBodyMesher) object to the API.

• Added MeshType, MidsideNodes, TargetSize, MinSizeFactorOn, MinSizeFactor,
PointsAroundCircleOn, PointsAroundCircle, GrowthFactorOn, and
GrowthFactor attributes to control Mesh Sizing options for the Mesh → Bodies and Mesh
→ Mesh on Mesh commands when using the BodyMesher Object.

• Added AssociateTo, AssociateAngleOn, AssociateAngle, UseCurveSizing, and
UseSurfaceSizing attributes to control options on the Geometry tab of the Mesh →
Bodies command when using the BodyMesher Object.
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• Added RetainProperty, RetainElemType, RetainCornerThickness,
RetainOffset, RetainNormalDirection, RetainColor, RetainLayer,
RetainAssociativity, FeatureEdgeBreakAngle, KeepMeshOnFreeEdges, and
MergeNodes attributes to control options on the Mesh Features tab of the Mesh → Mesh on
Mesh command when using the BodyMesher Object.

• Added CurvatureAlignment, CurvatureRefinement,
CurvatureRefinementMaxPoints, CurvatureRefinementLimit,
ProximityRefinement, ProximityElemAcrossOn, ProximityElemAcross,
ProximityDistanceOn, ProximityDistance, ProximityDirection attributes to
control options on the Curvature/Proximity tab of the Mesh → Bodies and Mesh → Mesh
on Mesh commands when using the BodyMesher Object.

• Added MinQualityOn, MinQuality, EnhancedQualityMesh,
CompatibilityRefinement, FacetMaxSize, FacetDistanceError,
FacetAngleError, FacetChordError, FacetCurveFactor, and UseFaceter
attributes to control options on the Mesh Quality tab of the Mesh → Bodies and Mesh
→ Mesh on Mesh commands when using the BodyMesher Object.

• Added TetSliverRemoval, TetAllowVoids, TetMultipleThruThicknessOn,
TetMultipleThruThickness, TetOptimizationLevel, and TetGrowthRatio
attributes to control options on the Tet Options tab of the Mesh → Bodies command when
using the BodyMesher Object.

New and Updated API Methods

• Added Clear, Dialog, Size, UseSizing, Associate, MeshBodies, MeshOnMesh,
CalculateDefaultMeshSize, SetSizeOnCurves, and SetSizeOnSurfaces methods
to the BodyMesher Object.

• Added NodesAsSet method to the BCSet Object.

• Added NodesAsSet and ElementsAsSet methods to the ConnectionRegion Object.

• Added IsFacet method to the Curve Object.

• Added NodesAsSet and ElementsAsSet methods to the LoadSet Object.

• Added IsFacet and IsAllFacet methods to the Solid Object.

• Added IsFacet method to the Surface Object.

The following functions have been added or updated:

• feFilePictureSaveJT

• feFilePictureSaveJTMultiResults 

• feAppAllowUVSurfaceForMeshFaces
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Corrections

Analysis Manager

Corrected issue which caused the OK button in the Multi-Step Global Control Options dialog to
become the default button, which prevented stepping through the Analysis Options dialog boxes
using the Next button (PR# 999967).

Geometry

• Corrected issue in the Geometry → Curve - Centerline command which cased hollow circular
cross sections to being identified as solid circular cross sections.

• Corrected issue which caused new geometry created by Geometry → Surface → Offset and
Geometry → Solid → Thicken commands to not be assigned the active color or be placed on the
active layer.

• Corrected issue which caused the Geometry → Surface → Ruled/Between Curves command to
not be able to created a ruled surface between composite curves.

• Corrected issue where copying edge curves of solids, sheet solids, or general bodies would create
points on Femap curves which could not be deleted (PR# 10024802).

Graphics

• Corrected issue when using the Geometry → Curve - From Surface → Parametric Curve
command where the preview arrow of the surface u direction disappears when picking the split
location and any Snap Mode other than Snap to Screen is currently selected.

• Corrected issue where symbols for radiation loads on curves are not drawn. The value labels were
drawn correctly but if labels were off, nothing was drawn at all.

User Interface - General

• Corrected issue that occurred after attempting to open an invalid model file and then in the same
session attempted to overwrite that file using the File → Save As command. Previously you could
not overwrite the file.

• Corrected issues that could cause Femap to exit unexpectedly when parsing Femap model files
that may have been tampered with or become corrupt (PR# 10066346).

User Interface - Dockable Panes - Entity Editor

Corrected issue in that prevented help panel at bottom of pane from being manually resized.

Interfaces - Nastran

Corrected issue by writing “Not Supported” to the Messages window when reading a TABLED1 entry
with LOG specified in XAXIS or YAXIS field from a Nastran input file.

Interfaces - MSC Nastran

Corrected issue which prevented results on pyramid elements from being read from a .f06 file (PR#
8571578).
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Interfaces - ANSYS

• Corrected issue when reading IXX (torsional moment of inertia) value of ANSYS BEAM4 and
ANSYS BEAM44 elements. If IXX is not specified or equal to zero, it is assumed to be equal to the
polar moment of inertia (IYY+IZZ).

• Corrected issue when reading unused real constants from an ANSYS input file. Any real constants
not referenced by any elements will not be mapped to Femap properties.

Elements

• Corrected issue when deleting Weld/Fastener elements with Type set to “1..Elem to Elem
Vertex( ELEMID )” which improperly decremented the node counter and could cause nodes to
be deletable when they are still referenced by other elements.

• Corrected issue where ABAQUS and LS_DYNA element formulations could conflict.

Meshing

Corrected issue that caused property attributes on solids to be lost when using the Mesh → Mesh
Control → Size On Solid command when sizing for either Tet or Hex meshing.

Output and Post-Processing

• Corrected issue reading modal results for the superelement residual structure when data was also
recovered for any of the superelements (PR# 9839725).

• Corrected issue where post titles were losing the "Deformed" line when rotating and animating
model.

• Corrected issue where line element partial tensor results were being transformed as vectors. No
transformation is now done on line element partial tensors.

• Corrected issue where bar, beam, curved beam, curved tube, spring/damper, and parabolic beam
elements being displayed with a combination of high deformation and orientation vectors that
align somewhat along the beam, can cause the Y axis to flip incorrectly.

Tools

Corrected issue with the Tools → Convert Units command which caused the value for Penalty
Autoscale on the Linear tab of the Define Connection Property dialog box to be improperly
converted when the Penalty Factor Units option in the same section is set to “2..Force/(Length x
Area)” (PR# 10029904).

Preferences - User Interface

Corrected issue where toolbar icon sizing was not be properly handled when the UI Sizing option in
the Global Options section was set to “1..Disabled”.

JT Files

• Corrected issue when writing JT file from performance graphics where the Femap graphics were
left with no deformation or contours on.
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• Corrected issue when writing a JT file where contoured beam neutral axes might not be drawn in
the JT file.

• Corrected issue where JT file did not reflect the type of contour legend currently specified,
0..Continuous (smooth) or 1..Level Colors (stepped).

• Corrected issue where the wrong colors are written to JT file when doing a 2D tensor contour
arrow display on plate elements.

API

• Corrected issue which could cause Femap to become unresponsive when using the SetColumns
method on the Results Browsing Object (PR# 10034639).

• Corrected issue that caused the feSolidCleanup method to always prompt for selecting solids
even though the selected solids were specified as an argument.
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